summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2013-12-12 05:57:51 +0000
committerMark Wright <gienah@gentoo.org>2013-12-12 05:57:51 +0000
commit194195804f54d73609cd183e243df333f4f783a0 (patch)
treef93dc4e5fac3ef502af20cc2ee5fdb37c757d9e3 /dev-haskell
parentMove cairo, glib, gio, gtk2hs-buildtools, pango to slot 0 (diff)
downloadgentoo-2-194195804f54d73609cd183e243df333f4f783a0.tar.gz
gentoo-2-194195804f54d73609cd183e243df333f4f783a0.tar.bz2
gentoo-2-194195804f54d73609cd183e243df333f4f783a0.zip
Bump gtk to 0.12.5.0 - the .2 on the end of the gtk-0.12.5.0.2 is for slot 2 - as there is a slot 3 gtk3 version in the gentoo haskell overlay. Move cairo, glib, gio, gtk2hs-buildtools, pango to slot 0.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/gtk/ChangeLog10
-rw-r--r--dev-haskell/gtk/gtk-0.12.0.ebuild12
-rw-r--r--dev-haskell/gtk/gtk-0.12.4-r1.ebuild26
-rw-r--r--dev-haskell/gtk/gtk-0.12.5.0.2.ebuild48
4 files changed, 76 insertions, 20 deletions
diff --git a/dev-haskell/gtk/ChangeLog b/dev-haskell/gtk/ChangeLog
index adaa765c6247..fe938f558fc7 100644
--- a/dev-haskell/gtk/ChangeLog
+++ b/dev-haskell/gtk/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-haskell/gtk
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk/ChangeLog,v 1.15 2013/12/07 19:29:20 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk/ChangeLog,v 1.16 2013/12/12 05:57:51 gienah Exp $
+
+*gtk-0.12.5.0.2 (12 Dec 2013)
+
+ 12 Dec 2013; Mark Wright <gienah@gentoo.org> +gtk-0.12.5.0.2.ebuild,
+ gtk-0.12.0.ebuild, gtk-0.12.4-r1.ebuild:
+ Bump gtk to 0.12.5.0 - the .2 on the end of the gtk-0.12.5.0.2 is for slot 2 -
+ as there is a slot 3 gtk3 version in the gentoo haskell overlay. Move cairo,
+ glib, gio, gtk2hs-buildtools, pango to slot 0.
07 Dec 2013; Pacho Ramos <pacho@gentoo.org> gtk-0.12.4-r1.ebuild:
x86 stable, bug #488808
diff --git a/dev-haskell/gtk/gtk-0.12.0.ebuild b/dev-haskell/gtk/gtk-0.12.0.ebuild
index f675aa90f6b0..338160cdac7d 100644
--- a/dev-haskell/gtk/gtk-0.12.0.ebuild
+++ b/dev-haskell/gtk/gtk-0.12.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk/gtk-0.12.0.ebuild,v 1.5 2013/04/03 05:29:37 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk/gtk-0.12.0.ebuild,v 1.6 2013/12/12 05:57:51 gienah Exp $
# ebuild generated by hackport 0.2.13
@@ -19,16 +19,16 @@ SLOT="2"
KEYWORDS="amd64 x86"
IUSE="+gio"
-RDEPEND="=dev-haskell/cairo-0.12*:2
- =dev-haskell/glib-0.12*:2
+RDEPEND="=dev-haskell/cairo-0.12*:0
+ =dev-haskell/glib-0.12*:0
dev-haskell/mtl
- =dev-haskell/pango-0.12*:2
+ =dev-haskell/pango-0.12*:0
>=dev-lang/ghc-6.10.1
dev-libs/glib:2
x11-libs/gtk+:2
- gio? ( =dev-haskell/gio-0.12*:2 )"
+ gio? ( =dev-haskell/gio-0.12*:0 )"
DEPEND="${RDEPEND}
- dev-haskell/gtk2hs-buildtools:2"
+ dev-haskell/gtk2hs-buildtools:0"
PATCHES=("${FILESDIR}/${PN}-0.12.0-ghc-7.2.patch"
"${FILESDIR}/${PN}-0.12.3-glib-2.32.patch")
diff --git a/dev-haskell/gtk/gtk-0.12.4-r1.ebuild b/dev-haskell/gtk/gtk-0.12.4-r1.ebuild
index 6452ee10394c..1fea940ec080 100644
--- a/dev-haskell/gtk/gtk-0.12.4-r1.ebuild
+++ b/dev-haskell/gtk/gtk-0.12.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk/gtk-0.12.4-r1.ebuild,v 1.3 2013/12/07 19:29:20 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk/gtk-0.12.4-r1.ebuild,v 1.4 2013/12/12 05:57:51 gienah Exp $
EAPI=5
@@ -21,22 +21,22 @@ SLOT="${GTK_MAJ_VER}/${PV}"
KEYWORDS="~alpha amd64 ~ia64 ~ppc ~ppc64 ~sparc x86"
IUSE="+gio"
-RDEPEND=">=dev-haskell/cairo-0.12.0:${GTK_MAJ_VER}=[profile?]
- <dev-haskell/cairo-0.13:${GTK_MAJ_VER}=[profile?]
- >=dev-haskell/gio-0.12.0:${GTK_MAJ_VER}=[profile?]
- <dev-haskell/gio-0.13:${GTK_MAJ_VER}=[profile?]
- >=dev-haskell/glib-0.12.0:${GTK_MAJ_VER}=[profile?]
- <dev-haskell/glib-0.13:${GTK_MAJ_VER}=[profile?]
+RDEPEND=">=dev-haskell/cairo-0.12.0:0=[profile?]
+ <dev-haskell/cairo-0.13:0=[profile?]
+ >=dev-haskell/gio-0.12.0:0=[profile?]
+ <dev-haskell/gio-0.13:0=[profile?]
+ >=dev-haskell/glib-0.12.0:0=[profile?]
+ <dev-haskell/glib-0.13:0=[profile?]
dev-haskell/mtl:=[profile?]
- >=dev-haskell/pango-0.12.0:${GTK_MAJ_VER}=[profile?]
- <dev-haskell/pango-0.13:${GTK_MAJ_VER}=[profile?]
+ >=dev-haskell/pango-0.12.0:0=[profile?]
+ <dev-haskell/pango-0.13:0=[profile?]
>=dev-lang/ghc-6.10.4:=
dev-libs/glib:2
x11-libs/gtk+:${GTK_MAJ_VER}
- gio? ( =dev-haskell/gio-0.12*:${GTK_MAJ_VER}[profile?] )"
+ gio? ( =dev-haskell/gio-0.12*:0[profile?] )"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.8
- >=dev-haskell/gtk2hs-buildtools-0.12.4:${GTK_MAJ_VER}=
+ >=dev-haskell/gtk2hs-buildtools-0.12.4:0=
virtual/pkgconfig"
src_prepare() {
@@ -44,12 +44,12 @@ src_prepare() {
-e "s@gtk2hsHookGenerator@gtk2hsHookGenerator${GTK_MAJ_VER}@" \
-e "s@gtk2hsC2hs@gtk2hsC2hs${GTK_MAJ_VER}@" \
-i "${S}/Gtk2HsSetup.hs" \
- || die "Could not change Gtk2HsSetup.hs for GTK+ slot ${GTK_MAJ_VER}"
+ || die "Could not change Gtk2HsSetup.hs for GTK+ slot 0"
sed -e "s@gtk2hsC2hs@gtk2hsC2hs${GTK_MAJ_VER}@" \
-e "s@gtk2hsTypeGen@gtk2hsTypeGen${GTK_MAJ_VER}@" \
-e "s@gtk2hsHookGenerator@gtk2hsHookGenerator${GTK_MAJ_VER}@" \
-i "${S}/${PN}.cabal" \
- || die "Could not change ${PN}.cabal for GTK+ slot ${GTK_MAJ_VER}"
+ || die "Could not change ${PN}.cabal for GTK+ slot 0"
}
src_configure() {
diff --git a/dev-haskell/gtk/gtk-0.12.5.0.2.ebuild b/dev-haskell/gtk/gtk-0.12.5.0.2.ebuild
new file mode 100644
index 000000000000..5d674c7c7e45
--- /dev/null
+++ b/dev-haskell/gtk/gtk-0.12.5.0.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk/gtk-0.12.5.0.2.ebuild,v 1.1 2013/12/12 05:57:51 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.5.9999
+
+GTK_MAJ_VER="2"
+
+MY_PV="${PV%.*}"
+MY_P="${PN}-${MY_PV}"
+
+#nocabaldep is for the fancy cabal-detection feature at build-time
+CABAL_FEATURES="lib profile haddock hoogle hscolour nocabaldep"
+inherit haskell-cabal
+
+DESCRIPTION="Binding to the Gtk+ graphical user interface library."
+HOMEPAGE="http://projects.haskell.org/gtk2hs/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${MY_PV}/${MY_P}.tar.gz"
+
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-2.1"
+SLOT="${GTK_MAJ_VER}/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+gio"
+
+RDEPEND=">=dev-haskell/cairo-0.12.5:0=[profile?] <dev-haskell/cairo-0.13:0=[profile?]
+ >=dev-haskell/glib-0.12.5:0=[profile?] <dev-haskell/glib-0.13:0=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/pango-0.12.5:0=[profile?] <dev-haskell/pango-0.13:0=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+ dev-libs/glib:2
+ x11-libs/gtk+:${GTK_MAJ_VER}
+ gio? ( >=dev-haskell/gio-0.12.5:0=[profile?] <dev-haskell/gio-0.13:0=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/gtk2hs-buildtools-0.12.5.1-r1:0=
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # Upstream has this enabled, so we might as well force it enabled to be sure.
+ cabal_src_configure \
+ --flags=deprecated \
+ $(cabal_flag gio have-gio)
+}