summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-12-14 07:32:52 +0000
committerMark Wright <gienah@gentoo.org>2014-12-14 07:32:52 +0000
commit7f54cc424d2a56139f69042376181204ae9046de (patch)
tree9a927b01e46c8445052732b5de33eaf60f25dc8a /dev-haskell/x509-validation
parentBump x509-system to 1.5.0 (diff)
downloadgentoo-2-7f54cc424d2a56139f69042376181204ae9046de.tar.gz
gentoo-2-7f54cc424d2a56139f69042376181204ae9046de.tar.bz2
gentoo-2-7f54cc424d2a56139f69042376181204ae9046de.zip
Bump x509-validation to 1.5.1
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/x509-validation')
-rw-r--r--dev-haskell/x509-validation/ChangeLog7
-rw-r--r--dev-haskell/x509-validation/x509-validation-1.5.1.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-haskell/x509-validation/ChangeLog b/dev-haskell/x509-validation/ChangeLog
index fd0fa874c5c5..7c3e9d79a9a0 100644
--- a/dev-haskell/x509-validation/ChangeLog
+++ b/dev-haskell/x509-validation/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/x509-validation
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/x509-validation/ChangeLog,v 1.2 2014/07/25 08:58:48 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/x509-validation/ChangeLog,v 1.3 2014/12/14 07:32:52 gienah Exp $
+
+*x509-validation-1.5.1 (14 Dec 2014)
+
+ 14 Dec 2014; Mark Wright <gienah@gentoo.org> +x509-validation-1.5.1.ebuild:
+ Bump x509-validation to 1.5.1
25 Jul 2014; Sergei Trofimovich <slyfox@gentoo.org> metadata.xml:
Drop redundant '<maintainer>' field, leave only '<herd>'.
diff --git a/dev-haskell/x509-validation/x509-validation-1.5.1.ebuild b/dev-haskell/x509-validation/x509-validation-1.5.1.ebuild
new file mode 100644
index 000000000000..19e2445074f4
--- /dev/null
+++ b/dev-haskell/x509-validation/x509-validation-1.5.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/x509-validation/x509-validation-1.5.1.ebuild,v 1.1 2014/12/14 07:32:52 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="X.509 Certificate and CRL validation"
+HOMEPAGE="http://github.com/vincenthz/hs-certificate"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/asn1-encoding-0.9:=[profile?] <dev-haskell/asn1-encoding-0.10:=[profile?]
+ >=dev-haskell/asn1-types-0.3:=[profile?] <dev-haskell/asn1-types-0.4:=[profile?]
+ dev-haskell/byteable:=[profile?]
+ >=dev-haskell/crypto-pubkey-0.1.4:=[profile?] <dev-haskell/crypto-pubkey-0.3:=[profile?]
+ >=dev-haskell/crypto-pubkey-types-0.4:=[profile?] <dev-haskell/crypto-pubkey-types-0.5:=[profile?]
+ >=dev-haskell/cryptohash-0.9:=[profile?] <dev-haskell/cryptohash-0.12:=[profile?]
+ dev-haskell/data-default-class:=[profile?]
+ dev-haskell/hourglass:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/network:=[profile?]
+ >=dev-haskell/pem-0.1:=[profile?] <dev-haskell/pem-0.3:=[profile?]
+ >=dev-haskell/x509-1.5.0:=[profile?] <dev-haskell/x509-1.6:=[profile?]
+ >=dev-haskell/x509-store-1.5:=[profile?] <dev-haskell/x509-store-1.6:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"