summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-03-23 15:00:18 +0000
committerMark Wright <gienah@gentoo.org>2014-03-23 15:00:18 +0000
commit1e78267d9e1ac99d7c867b6fae30c6e67b2543c4 (patch)
treef6dfffe65ec908a4d28d9d2346c2a18e10daaa90 /dev-haskell/wxc
parentbump (diff)
downloadgentoo-2-1e78267d9e1ac99d7c867b6fae30c6e67b2543c4.tar.gz
gentoo-2-1e78267d9e1ac99d7c867b6fae30c6e67b2543c4.tar.bz2
gentoo-2-1e78267d9e1ac99d7c867b6fae30c6e67b2543c4.zip
Bump wxc to 0.90.1.1
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/wxc')
-rw-r--r--dev-haskell/wxc/ChangeLog9
-rw-r--r--dev-haskell/wxc/wxc-0.90.1.1.ebuild65
2 files changed, 72 insertions, 2 deletions
diff --git a/dev-haskell/wxc/ChangeLog b/dev-haskell/wxc/ChangeLog
index a8762071d908..959e05319d45 100644
--- a/dev-haskell/wxc/ChangeLog
+++ b/dev-haskell/wxc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/wxc
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxc/ChangeLog,v 1.2 2013/01/13 10:59:19 gienah Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxc/ChangeLog,v 1.3 2014/03/23 15:00:18 gienah Exp $
+
+*wxc-0.90.1.1 (23 Mar 2014)
+
+ 23 Mar 2014; Mark Wright <gienah@gentoo.org> +wxc-0.90.1.1.ebuild:
+ Bump wxc to 0.90.1.1
13 Jan 2013; Mark Wright <gienah@gentoo.org> wxc-0.90.0.4.ebuild:
Thanks to peanuts for reporting: unconditionally require x11-libs/wxGTK with
diff --git a/dev-haskell/wxc/wxc-0.90.1.1.ebuild b/dev-haskell/wxc/wxc-0.90.1.1.ebuild
new file mode 100644
index 000000000000..893f96e231ea
--- /dev/null
+++ b/dev-haskell/wxc/wxc-0.90.1.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxc/wxc-0.90.1.1.ebuild,v 1.1 2014/03/23 15:00:18 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+WX_GTK_VER="2.9"
+
+CABAL_FEATURES="lib profile"
+inherit haskell-cabal multilib versionator wxwidgets
+
+DESCRIPTION="wxHaskell C++ wrapper"
+HOMEPAGE="http://haskell.org/haskellwiki/WxHaskell"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="wxWinLL-3.1"
+SLOT="${WX_GTK_VER}/${PV}"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/wxdirect-0.90.1.0:${WX_GTK_VER}=[profile?]
+ x11-libs/wxGTK:${WX_GTK_VER}=[X,gstreamer,opengl]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6.0.3
+"
+
+src_prepare() {
+ sed -e "s@\"wx-config\"@\"${WX_CONFIG}\"@g" \
+ -i "${S}/Setup.hs" || die "Could not specify wx-config in Setup.hs"
+}
+
+src_configure() {
+ local cgcc=()
+ for i in ${CXXFLAGS}
+ do
+ cgcc+=( --gcc-option="${i}" )
+ done
+ # Trying to specify the LDFLAGS in --ld-option does not work, as ld does
+ # not understand ld options prefixed with -Wl,
+ # The linker that is used to link the libwxc.so shared library is hard coded
+ # in Setup.hs. So the --with-ld would not change the linker used when
+ # linking libwxc.so. --with-ld="gcc" does not help, as then cabal passes
+ # ld options like -x to gcc which then returns a non-zero exit status, then
+ # cabal ignores all the --ld-option parameters.
+ # So I place all the LDFLAGS in --gcc-option parameters. They are ignored
+ # when building .o files.
+ local cld=()
+ for i in ${LDFLAGS}
+ do
+ cld+=( --gcc-option="${i}" )
+ done
+ cabal_src_configure ${cgcc[*]} ${cld[*]} --verbose=3
+}
+
+src_install() {
+ cabal_src_install
+ dolib.so dist/build/lib${PN}.so.${PV}
+ dosym lib${PN}.so.${PV} /usr/$(get_libdir)/lib${PN}.so.$(get_version_component_range 1-2)
+ dosym lib${PN}.so.${PV} /usr/$(get_libdir)/lib${PN}.so.$(get_major_version)
+ dosym lib${PN}.so.${PV} /usr/$(get_libdir)/lib${PN}.so
+}