summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-12-17 13:18:03 +0000
committerMark Wright <gienah@gentoo.org>2014-12-17 13:18:03 +0000
commitc262d4d334d75c851174acd0fa75da63ccc2850f (patch)
tree1298359be7132656186890cba6d195ce4d7b7790 /dev-haskell/tasty-quickcheck
parentBump tasty-smallcheck to 0.8.0.1 (diff)
downloadgentoo-2-c262d4d334d75c851174acd0fa75da63ccc2850f.tar.gz
gentoo-2-c262d4d334d75c851174acd0fa75da63ccc2850f.tar.bz2
gentoo-2-c262d4d334d75c851174acd0fa75da63ccc2850f.zip
Bump tasty-quickcheck to 0.8.3.2
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/tasty-quickcheck')
-rw-r--r--dev-haskell/tasty-quickcheck/ChangeLog8
-rw-r--r--dev-haskell/tasty-quickcheck/metadata.xml3
-rw-r--r--dev-haskell/tasty-quickcheck/tasty-quickcheck-0.8.3.2.ebuild37
3 files changed, 47 insertions, 1 deletions
diff --git a/dev-haskell/tasty-quickcheck/ChangeLog b/dev-haskell/tasty-quickcheck/ChangeLog
index dbe2bcc0dbcf..6f49839acb63 100644
--- a/dev-haskell/tasty-quickcheck/ChangeLog
+++ b/dev-haskell/tasty-quickcheck/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/tasty-quickcheck
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/tasty-quickcheck/ChangeLog,v 1.5 2014/07/25 09:16:38 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/tasty-quickcheck/ChangeLog,v 1.6 2014/12/17 13:18:03 gienah Exp $
+
+*tasty-quickcheck-0.8.3.2 (17 Dec 2014)
+
+ 17 Dec 2014; Mark Wright <gienah@gentoo.org> +tasty-quickcheck-0.8.3.2.ebuild,
+ metadata.xml:
+ Bump tasty-quickcheck to 0.8.3.2
25 Jul 2014; Sergei Trofimovich <slyfox@gentoo.org>
tasty-quickcheck-0.3.1.ebuild, tasty-quickcheck-0.8.1.ebuild,
diff --git a/dev-haskell/tasty-quickcheck/metadata.xml b/dev-haskell/tasty-quickcheck/metadata.xml
index d8bbe912810f..baa19de8ba2e 100644
--- a/dev-haskell/tasty-quickcheck/metadata.xml
+++ b/dev-haskell/tasty-quickcheck/metadata.xml
@@ -5,4 +5,7 @@
<longdescription>
QuickCheck support for the Tasty test framework.
</longdescription>
+<use>
+ <flag name='old-quickcheck'>Use Quick-Check &lt; 2.7.</flag>
+</use>
</pkgmetadata>
diff --git a/dev-haskell/tasty-quickcheck/tasty-quickcheck-0.8.3.2.ebuild b/dev-haskell/tasty-quickcheck/tasty-quickcheck-0.8.3.2.ebuild
new file mode 100644
index 000000000000..2b55bf3244d2
--- /dev/null
+++ b/dev-haskell/tasty-quickcheck/tasty-quickcheck-0.8.3.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/tasty-quickcheck/tasty-quickcheck-0.8.3.2.ebuild,v 1.1 2014/12/17 13:18:03 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="QuickCheck support for the Tasty test framework"
+HOMEPAGE="http://documentup.com/feuerbach/tasty"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="old-quickcheck"
+
+RDEPEND="dev-haskell/tagged:=[profile?]
+ >=dev-haskell/tasty-0.10.1:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ old-quickcheck? ( >=dev-haskell/quickcheck-2.5:2=[profile?] <dev-haskell/quickcheck-2.7:2=[profile?]
+ dev-haskell/random:=[profile?] )
+ !old-quickcheck? ( >=dev-haskell/quickcheck-2.7:2=[profile?] <dev-haskell/quickcheck-3:2=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( dev-haskell/pcre-light
+ dev-haskell/tasty-hunit )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag old-quickcheck old-quickcheck)
+}