summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Vershilov <qnikst@gentoo.org>2013-08-26 04:12:13 +0000
committerAlexander Vershilov <qnikst@gentoo.org>2013-08-26 04:12:13 +0000
commit96924c29d79b681da17dca4ccc8a314f4c70ca9c (patch)
treed8cd504b2abd8fc5e173a63ff2ef37a51bedec6e /dev-haskell/skein
parentdev-haskell/crypto-random-api: 0.2.0 (diff)
downloadgentoo-2-96924c29d79b681da17dca4ccc8a314f4c70ca9c.tar.gz
gentoo-2-96924c29d79b681da17dca4ccc8a314f4c70ca9c.tar.bz2
gentoo-2-96924c29d79b681da17dca4ccc8a314f4c70ca9c.zip
dev-haskell/skein: 1.0.3
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0xEAD50D64D8D3571A!)
Diffstat (limited to 'dev-haskell/skein')
-rw-r--r--dev-haskell/skein/ChangeLog9
-rw-r--r--dev-haskell/skein/metadata.xml30
-rw-r--r--dev-haskell/skein/skein-1.0.3.ebuild36
3 files changed, 75 insertions, 0 deletions
diff --git a/dev-haskell/skein/ChangeLog b/dev-haskell/skein/ChangeLog
new file mode 100644
index 000000000000..1a80f713cfe9
--- /dev/null
+++ b/dev-haskell/skein/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-haskell/skein
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/skein/ChangeLog,v 1.1 2013/08/26 04:12:13 qnikst Exp $
+
+*skein-1.0.3 (26 Aug 2013)
+
+ 26 Aug 2013; Alexander Vershilov <qnikst@gentoo.org> +metadata.xml,
+ +skein-1.0.3.ebuild:
+ dev-haskell/skein: 1.0.3
diff --git a/dev-haskell/skein/metadata.xml b/dev-haskell/skein/metadata.xml
new file mode 100644
index 000000000000..2c436d43c1c6
--- /dev/null
+++ b/dev-haskell/skein/metadata.xml
@@ -0,0 +1,30 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Skein (&lt;http://www.skein-hash.info/&gt;) is a family of fast
+ secure cryptographic hash functions designed by Niels
+ Ferguson, Stefan Lucks, Bruce Schneier, Doug Whiting, Mihir
+ Bellare, Tadayoshi Kohno, Jon Callas and Jesse Walker.
+
+ This package uses bindings to the optimized C implementation
+ of Skein. We provide a high-level interface (see module
+ &quot;Crypto.Skein&quot;) to some of the Skein use cases. We also
+ provide a low-level interface (see module
+ &quot;Crypto.Skein.Internal&quot;) should you need to use Skein in a
+ different way.
+
+ Currently we have support for Skein as cryptographic hash
+ function as Skein as a message authentication code
+ (Skein-MAC). For examples of how to use this package, see
+ &quot;Crypto.Skein&quot; module documentation.
+ </longdescription>
+ <use>
+ <flag name="force-endianness">Use a manually selected endian when compiling (see flag 'big-endian')</flag>
+ <flag name="big-endian">When manually selecting the endianness, use big-endian (default is little-endian).</flag>
+ </use>
+</pkgmetadata>
diff --git a/dev-haskell/skein/skein-1.0.3.ebuild b/dev-haskell/skein/skein-1.0.3.ebuild
new file mode 100644
index 000000000000..fee69774d243
--- /dev/null
+++ b/dev-haskell/skein/skein-1.0.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/skein/skein-1.0.3.ebuild,v 1.1 2013/08/26 04:12:13 qnikst Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Skein, a family of cryptographic hash functions. Includes Skein-MAC as well."
+HOMEPAGE="https://github.com/meteficha/skein"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="big-endian force-endianness"
+
+RDEPEND="=dev-haskell/cereal-0.3*:=[profile?]
+ >=dev-haskell/crypto-api-0.6:=[profile?]
+ <dev-haskell/crypto-api-0.13:=[profile?]
+ >=dev-haskell/tagged-0.2:=[profile?]
+ <dev-haskell/tagged-0.7:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hspec-1.3
+ )"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag big-endian big-endian) \
+ $(cabal_flag force-endianness force-endianness)
+}