summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-12-23 03:11:17 +0000
committerMark Wright <gienah@gentoo.org>2014-12-23 03:11:17 +0000
commit8d067955a650211449c108dbcd988dd991ce4dfc (patch)
tree74bcd0ea95b51219ecc99f4b4681ea5c078dd13a /dev-haskell/shelly
parentrevbump; convert -> distutils-r1, drop refs to package kinterbasdb long purge... (diff)
downloadgentoo-2-8d067955a650211449c108dbcd988dd991ce4dfc.tar.gz
gentoo-2-8d067955a650211449c108dbcd988dd991ce4dfc.tar.bz2
gentoo-2-8d067955a650211449c108dbcd988dd991ce4dfc.zip
Apply patch by Michael Snoyman to allow shelly-1.5.6-r1 to compile with monad-control-1.0.0.1
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/shelly')
-rw-r--r--dev-haskell/shelly/ChangeLog9
-rw-r--r--dev-haskell/shelly/files/shelly-1.5.6-monad-control-1.1.patch95
-rw-r--r--dev-haskell/shelly/shelly-1.5.6-r1.ebuild40
3 files changed, 143 insertions, 1 deletions
diff --git a/dev-haskell/shelly/ChangeLog b/dev-haskell/shelly/ChangeLog
index 0aa248e194fe..6b24cc6b0f00 100644
--- a/dev-haskell/shelly/ChangeLog
+++ b/dev-haskell/shelly/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-haskell/shelly
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/shelly/ChangeLog,v 1.3 2014/12/14 05:49:51 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/shelly/ChangeLog,v 1.4 2014/12/23 03:11:17 gienah Exp $
+
+*shelly-1.5.6-r1 (23 Dec 2014)
+
+ 23 Dec 2014; Mark Wright <gienah@gentoo.org>
+ +files/shelly-1.5.6-monad-control-1.1.patch, +shelly-1.5.6-r1.ebuild:
+ Apply patch by Michael Snoyman to allow shelly-1.5.6-r1 to compile with monad-
+ control-1.0.0.1
*shelly-1.5.6 (14 Dec 2014)
diff --git a/dev-haskell/shelly/files/shelly-1.5.6-monad-control-1.1.patch b/dev-haskell/shelly/files/shelly-1.5.6-monad-control-1.1.patch
new file mode 100644
index 000000000000..a2ef39376c08
--- /dev/null
+++ b/dev-haskell/shelly/files/shelly-1.5.6-monad-control-1.1.patch
@@ -0,0 +1,95 @@
+commit 33b32439e7ef1ba60cc8d72ae0f0c53b6d01ae90
+Merge: d3aec33 b70a308
+Author: Greg Weber <greg@gregweber.info>
+Date: Mon Dec 22 10:32:40 2014 -0800
+
+ Merge pull request #84 from yesodweb/monad-control-1.0
+
+ monad-control 1.0
+
+commit d3aec338e23a03027c404aaf5a7b5790b3300ec5
+Author: Luite Stegeman <stegeman@gmail.com>
+Date: Mon Dec 22 16:21:01 2014 +0100
+
+ bump time upper bound
+
+diff --git a/shelly.cabal b/shelly.cabal
+index ed0d086..3d3c46d 100644
+--- a/shelly.cabal
++++ b/shelly.cabal
+@@ -39,7 +39,7 @@ Library
+
+ Build-depends:
+ containers >= 0.4.2.0,
+- time >= 1.3 && < 1.5,
++ time >= 1.3 && < 1.6,
+ directory >= 1.1.0.0 && < 1.3.0.0,
+ mtl >= 2,
+ process >= 1.0,
+
+commit c1da49fb0d59a56c9e4140a5cbf0700c9fc1ca5f
+Author: Luite Stegeman <stegeman@gmail.com>
+Date: Mon Dec 22 16:20:18 2014 +0100
+
+ Add Alternative instance for Sh, since it's now a superclass of
+ MonadPlus.
+
+diff --git a/src/Shelly/Pipe.hs b/src/Shelly/Pipe.hs
+index a8d0182..f0a64ec 100644
+--- a/src/Shelly/Pipe.hs
++++ b/src/Shelly/Pipe.hs
+@@ -138,6 +138,10 @@ instance Applicative Sh where
+ pure = return
+ (<*>) = ap
+
++instance Alternative Sh where
++ empty = mzero
++ (<|>) = mplus
++
+ instance MonadPlus Sh where
+ mzero = Sh $ return []
+ mplus a b = Sh $ liftA2 (++) (unSh a) (unSh b)
+
+commit b70a308ad14af0b57bbdd9cf8441bdc30ff65c36
+Author: Michael Snoyman <michael@snoyman.com>
+Date: Mon Dec 22 13:49:54 2014 +0200
+
+ monad-control 1.0
+
+diff --git a/shelly.cabal b/shelly.cabal
+index ed0d086..99a85d3 100644
+--- a/shelly.cabal
++++ b/shelly.cabal
+@@ -46,7 +46,7 @@ Library
+ unix-compat < 0.5,
+ system-filepath >= 0.4.7 && < 0.5,
+ system-fileio < 0.4,
+- monad-control >= 0.3.2 && < 0.4,
++ monad-control >= 0.3.2 && < 1.1,
+ lifted-base,
+ lifted-async,
+ exceptions == 0.6.*,
+diff --git a/src/Shelly/Base.hs b/src/Shelly/Base.hs
+index e05ad43..3d6fe00 100644
+--- a/src/Shelly/Base.hs
++++ b/src/Shelly/Base.hs
+@@ -71,11 +71,19 @@ instance MonadBase IO Sh where
+ liftBase = Sh . ReaderT . const
+
+ instance MonadBaseControl IO Sh where
++#if MIN_VERSION_monad_control(1,0,0)
++ type StM Sh a = StM (ReaderT (IORef State) IO) a
++ liftBaseWith f =
++ Sh $ liftBaseWith $ \runInBase -> f $ \k ->
++ runInBase $ unSh k
++ restoreM = Sh . restoreM
++#else
+ newtype StM Sh a = StMSh (StM (ReaderT (IORef State) IO) a)
+ liftBaseWith f =
+ Sh $ liftBaseWith $ \runInBase -> f $ \k ->
+ liftM StMSh $ runInBase $ unSh k
+ restoreM (StMSh m) = Sh . restoreM $ m
++#endif
+
+ instance Catch.MonadThrow Sh where
+ throwM = liftIO . Catch.throwM
diff --git a/dev-haskell/shelly/shelly-1.5.6-r1.ebuild b/dev-haskell/shelly/shelly-1.5.6-r1.ebuild
new file mode 100644
index 000000000000..6738940785dc
--- /dev/null
+++ b/dev-haskell/shelly/shelly-1.5.6-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/shelly/shelly-1.5.6-r1.ebuild,v 1.1 2014/12/23 03:11:17 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit base haskell-cabal
+
+DESCRIPTION="shell-like (systems) programming in Haskell"
+HOMEPAGE="https://github.com/yesodweb/Shelly.hs"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/async:=[profile?]
+ dev-haskell/enclosed-exceptions:=[profile?]
+ >=dev-haskell/exceptions-0.6:=[profile?] <dev-haskell/exceptions-0.7:=[profile?]
+ dev-haskell/lifted-async:=[profile?]
+ dev-haskell/lifted-base:=[profile?]
+ >=dev-haskell/monad-control-0.3.2:=[profile?] <dev-haskell/monad-control-1.1:=[profile?]
+ >=dev-haskell/mtl-2:=[profile?]
+ <dev-haskell/system-fileio-0.4:=[profile?]
+ >=dev-haskell/system-filepath-0.4.7:=[profile?] <dev-haskell/system-filepath-0.5:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ dev-haskell/transformers-base:=[profile?]
+ <dev-haskell/unix-compat-0.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+PATCHES=("${FILESDIR}/${PN}-1.5.6-monad-control-1.1.patch")