summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-07-02 12:32:06 +0000
committerMark Wright <gienah@gentoo.org>2014-07-02 12:32:06 +0000
commitf0a27c4706544d775e56e4c9c55eb7faf21562f9 (patch)
tree3f3131ffb142548fc03e18344608395533e9fedc /dev-haskell/quickcheck
parentAdd tf-random (diff)
downloadgentoo-2-f0a27c4706544d775e56e4c9c55eb7faf21562f9.tar.gz
gentoo-2-f0a27c4706544d775e56e4c9c55eb7faf21562f9.tar.bz2
gentoo-2-f0a27c4706544d775e56e4c9c55eb7faf21562f9.zip
Bump quickcheck to 2.7.5
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/quickcheck')
-rw-r--r--dev-haskell/quickcheck/ChangeLog9
-rw-r--r--dev-haskell/quickcheck/quickcheck-2.7.5.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/dev-haskell/quickcheck/ChangeLog b/dev-haskell/quickcheck/ChangeLog
index 9964eb17098a..d7d1cd5920f9 100644
--- a/dev-haskell/quickcheck/ChangeLog
+++ b/dev-haskell/quickcheck/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/quickcheck
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/quickcheck/ChangeLog,v 1.68 2013/07/21 17:44:15 ottxor Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/quickcheck/ChangeLog,v 1.69 2014/07/02 12:32:06 gienah Exp $
+
+*quickcheck-2.7.5 (02 Jul 2014)
+
+ 02 Jul 2014; Mark Wright <gienah@gentoo.org> +quickcheck-2.7.5.ebuild:
+ Bump quickcheck to 2.7.5
21 Jul 2013; Christoph Junghans <ottxor@gentoo.org> quickcheck-2.6.ebuild:
added ~amd64-linux (tested by me)
diff --git a/dev-haskell/quickcheck/quickcheck-2.7.5.ebuild b/dev-haskell/quickcheck/quickcheck-2.7.5.ebuild
new file mode 100644
index 000000000000..af7cd5ef912a
--- /dev/null
+++ b/dev-haskell/quickcheck/quickcheck-2.7.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/quickcheck/quickcheck-2.7.5.ebuild,v 1.1 2014/07/02 12:32:06 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+#hackport: flags: +base4,-base3,templatehaskell:template_haskell
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+MY_PN="QuickCheck"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Automatic testing of Haskell programs"
+HOMEPAGE="https://github.com/nick8325/quickcheck"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="2/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+template_haskell"
+
+RDEPEND="dev-haskell/random:=[profile?]
+ >=dev-haskell/tf-random-0.4:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/test-framework-0.4 <dev-haskell/test-framework-0.9 )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-base3 \
+ --flag=base4 \
+ $(cabal_flag template_haskell templatehaskell)
+}