summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-11-18 08:29:25 +0000
committerMark Wright <gienah@gentoo.org>2012-11-18 08:29:25 +0000
commit875f78556ce12f4ef9159e01df451f915b5e3315 (patch)
tree5bcfa25e7f187271b49e8a1518b5b151ae92b1cd /dev-haskell/mmap
parenttest-flags-PROG: use arrays to simplify code a bit (diff)
downloadgentoo-2-875f78556ce12f4ef9159e01df451f915b5e3315.tar.gz
gentoo-2-875f78556ce12f4ef9159e01df451f915b5e3315.tar.bz2
gentoo-2-875f78556ce12f4ef9159e01df451f915b5e3315.zip
Bump mmap to 0.5.8
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/mmap')
-rw-r--r--dev-haskell/mmap/ChangeLog7
-rw-r--r--dev-haskell/mmap/mmap-0.5.8.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-haskell/mmap/ChangeLog b/dev-haskell/mmap/ChangeLog
index 5b5249371c6a..26a03bb16a61 100644
--- a/dev-haskell/mmap/ChangeLog
+++ b/dev-haskell/mmap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/mmap
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/mmap/ChangeLog,v 1.21 2012/09/12 14:58:13 qnikst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/mmap/ChangeLog,v 1.22 2012/11/18 08:29:25 gienah Exp $
+
+*mmap-0.5.8 (18 Nov 2012)
+
+ 18 Nov 2012; Mark Wright <gienah@gentoo.org> +mmap-0.5.8.ebuild:
+ Bump mmap to 0.5.8
12 Sep 2012; Alexander Vershilov <qnikst@gentoo.org> mmap-0.4.1.ebuild,
mmap-0.5.7.ebuild:
diff --git a/dev-haskell/mmap/mmap-0.5.8.ebuild b/dev-haskell/mmap/mmap-0.5.8.ebuild
new file mode 100644
index 000000000000..c3d709776c1b
--- /dev/null
+++ b/dev-haskell/mmap/mmap-0.5.8.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/mmap/mmap-0.5.8.ebuild,v 1.1 2012/11/18 08:29:25 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Memory mapped files for POSIX and Windows"
+HOMEPAGE="http://hackage.haskell.org/package/mmap"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~ppc-macos ~x86-macos"
+# IUSE="test"
+IUSE=""
+
+RESTRICT="test" # the test suite compile fails: Not in scope: data constructor `Permissions'
+
+RDEPEND=">=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+# test? ( dev-haskell/hunit[profile?] )" # pcheck dislikes useless depends
+
+src_configure() {
+ cabal_src_configure # $(cabal_flag test mmaptest)
+}
+
+src_test() {
+ # breaking the abstraction a bit, we're not supposed to know about ./setup
+ # and how it works...
+ ./dist/build/mmaptest/mmaptest || die "tests failed"
+}
+
+src_install() {
+ cabal_src_install
+
+ rm "${D}/usr/bin/mmaptest"
+ rmdir "${D}/usr/bin" 2> /dev/null # only if empty
+}