summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2007-12-13 18:04:30 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2007-12-13 18:04:30 +0000
commit60e2252d0d5a72bb4ec4702f28dcfbd03b167a5b (patch)
treea20b3e0bdbdd351b90aa6d55e1361a05351ce209 /dev-haskell/hsshellscript
parentFix quoting in ebuild. (diff)
downloadgentoo-2-60e2252d0d5a72bb4ec4702f28dcfbd03b167a5b.tar.gz
gentoo-2-60e2252d0d5a72bb4ec4702f28dcfbd03b167a5b.tar.bz2
gentoo-2-60e2252d0d5a72bb4ec4702f28dcfbd03b167a5b.zip
Fix quoting in ebuild.
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-haskell/hsshellscript')
-rw-r--r--dev-haskell/hsshellscript/ChangeLog6
-rw-r--r--dev-haskell/hsshellscript/hsshellscript-2.2.2.ebuild8
-rw-r--r--dev-haskell/hsshellscript/hsshellscript-2.3.0.ebuild8
3 files changed, 13 insertions, 9 deletions
diff --git a/dev-haskell/hsshellscript/ChangeLog b/dev-haskell/hsshellscript/ChangeLog
index 54d34f1f6dcd..ea153e4c7f87 100644
--- a/dev-haskell/hsshellscript/ChangeLog
+++ b/dev-haskell/hsshellscript/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-haskell/hsshellscript
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hsshellscript/ChangeLog,v 1.17 2007/10/31 13:05:52 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hsshellscript/ChangeLog,v 1.18 2007/12/13 18:04:30 dcoutts Exp $
+
+ 13 Dec 2007; Duncan Coutts <dcoutts@gentoo.org>
+ hsshellscript-2.2.2.ebuild, hsshellscript-2.3.0.ebuild:
+ Fix quoting in ebuild.
31 Oct 2007; Duncan Coutts <dcoutts@gentoo.org>
hsshellscript-2.2.2.ebuild, hsshellscript-2.3.0.ebuild,
diff --git a/dev-haskell/hsshellscript/hsshellscript-2.2.2.ebuild b/dev-haskell/hsshellscript/hsshellscript-2.2.2.ebuild
index 9afc4e3709fa..5dcdf9d1afc3 100644
--- a/dev-haskell/hsshellscript/hsshellscript-2.2.2.ebuild
+++ b/dev-haskell/hsshellscript/hsshellscript-2.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hsshellscript/hsshellscript-2.2.2.ebuild,v 1.4 2007/10/31 13:05:52 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hsshellscript/hsshellscript-2.2.2.ebuild,v 1.5 2007/12/13 18:04:30 dcoutts Exp $
inherit base eutils ghc-package
@@ -19,7 +19,7 @@ RDEPEND=""
src_unpack() {
base_src_unpack
- cd ${S}
+ cd "${S}"
sed -i -e "/ghc-pkg/d" Makefile
}
@@ -28,7 +28,7 @@ src_compile() {
}
src_install() {
- ghc-setup-pkg ${S}/lib/hsshellscript.pkg
+ ghc-setup-pkg "${S}/lib/hsshellscript.pkg"
# Fix hsshellscript.pkg library path
ghc-fixlibpath "\${DEST_LIB}" "\${DEST_IMPORTS}"
make install \
@@ -38,5 +38,5 @@ src_install() {
DEST_DOC="/usr/share/doc/${PF}" \
|| die "make failed"
ghc-install-pkg
- ghc-makeghcilib ${D}/$(ghc-libdir)/libhsshellscript.a
+ ghc-makeghcilib "${D}/$(ghc-libdir)/libhsshellscript.a"
}
diff --git a/dev-haskell/hsshellscript/hsshellscript-2.3.0.ebuild b/dev-haskell/hsshellscript/hsshellscript-2.3.0.ebuild
index 558bf46d06dc..491954f2a85e 100644
--- a/dev-haskell/hsshellscript/hsshellscript-2.3.0.ebuild
+++ b/dev-haskell/hsshellscript/hsshellscript-2.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hsshellscript/hsshellscript-2.3.0.ebuild,v 1.4 2007/10/31 13:05:52 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hsshellscript/hsshellscript-2.3.0.ebuild,v 1.5 2007/12/13 18:04:30 dcoutts Exp $
inherit base eutils ghc-package
@@ -19,7 +19,7 @@ RDEPEND=""
src_unpack() {
base_src_unpack
- cd ${S}
+ cd "${S}"
sed -i -e "/ghc-pkg/d" Makefile
}
@@ -28,7 +28,7 @@ src_compile() {
}
src_install() {
- ghc-setup-pkg ${S}/lib/hsshellscript.pkg
+ ghc-setup-pkg "${S}/lib/hsshellscript.pkg"
# Fix hsshellscript.pkg library path
ghc-fixlibpath "\${DEST_LIB}" "\${DEST_IMPORTS}"
make install \
@@ -38,5 +38,5 @@ src_install() {
DEST_DOC="/usr/share/doc/${PF}" \
|| die "make failed"
ghc-install-pkg
- ghc-makeghcilib ${D}/$(ghc-libdir)/libhsshellscript.a
+ ghc-makeghcilib "${D}/$(ghc-libdir)/libhsshellscript.a"
}