summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-12-14 09:38:32 +0000
committerMark Wright <gienah@gentoo.org>2014-12-14 09:38:32 +0000
commit93284b822b08c5e5b15aac8b565950d7ac794f90 (patch)
tree8f632e2b888f44ec1162688a03365b7ca56c2e76 /dev-haskell/hs3
parentBump missingh to 1.3.0.1 (diff)
downloadgentoo-2-93284b822b08c5e5b15aac8b565950d7ac794f90.tar.gz
gentoo-2-93284b822b08c5e5b15aac8b565950d7ac794f90.tar.bz2
gentoo-2-93284b822b08c5e5b15aac8b565950d7ac794f90.zip
Bump hs3 to 0.5.9
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/hs3')
-rw-r--r--dev-haskell/hs3/ChangeLog7
-rw-r--r--dev-haskell/hs3/hs3-0.5.9.ebuild47
-rw-r--r--dev-haskell/hs3/metadata.xml3
3 files changed, 56 insertions, 1 deletions
diff --git a/dev-haskell/hs3/ChangeLog b/dev-haskell/hs3/ChangeLog
index 6c019f6bf80a..48bf7313e6ab 100644
--- a/dev-haskell/hs3/ChangeLog
+++ b/dev-haskell/hs3/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/hs3
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hs3/ChangeLog,v 1.6 2014/07/25 08:59:01 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hs3/ChangeLog,v 1.7 2014/12/14 09:38:32 gienah Exp $
+
+*hs3-0.5.9 (14 Dec 2014)
+
+ 14 Dec 2014; Mark Wright <gienah@gentoo.org> +hs3-0.5.9.ebuild, metadata.xml:
+ Bump hs3 to 0.5.9
25 Jul 2014; Sergei Trofimovich <slyfox@gentoo.org> metadata.xml:
Drop redundant '<maintainer>' field, leave only '<herd>'.
diff --git a/dev-haskell/hs3/hs3-0.5.9.ebuild b/dev-haskell/hs3/hs3-0.5.9.ebuild
new file mode 100644
index 000000000000..de26ee6822b3
--- /dev/null
+++ b/dev-haskell/hs3/hs3-0.5.9.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hs3/hs3-0.5.9.ebuild,v 1.1 2014/12/14 09:38:32 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="hS3"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Interface to Amazon's Simple Storage Service (S3)"
+HOMEPAGE="http://gregheartsfield.com/hS3/"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+network-uri"
+
+RDEPEND=">=dev-haskell/crypto-4.1.0:=[profile?]
+ dev-haskell/dataenc:=[profile?]
+ >=dev-haskell/http-4000.0.0:=[profile?]
+ >=dev-haskell/hxt-9.0.0:=[profile?] <dev-haskell/hxt-10:=[profile?]
+ >=dev-haskell/missingh-0.18.6:=[profile?]
+ dev-haskell/random:=[profile?]
+ dev-haskell/regex-compat:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ network-uri? ( >=dev-haskell/network-2.6:=[profile?]
+ >=dev-haskell/network-uri-2.6:=[profile?] )
+ !network-uri? ( <dev-haskell/network-2.6:=[profile?]
+ <dev-haskell/network-uri-2.6:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag network-uri network-uri)
+}
diff --git a/dev-haskell/hs3/metadata.xml b/dev-haskell/hs3/metadata.xml
index b3fea3e7e25a..10587b88ae3d 100644
--- a/dev-haskell/hs3/metadata.xml
+++ b/dev-haskell/hs3/metadata.xml
@@ -8,4 +8,7 @@
developers to reliably store and retrieve arbitrary amounts of
data from anywhere on the Internet.
</longdescription>
+ <use>
+ <flag name='network-uri'>Get Network.URI from the network-uri package.</flag>
+ </use>
</pkgmetadata>