summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2010-03-28 17:10:18 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2010-03-28 17:10:18 +0000
commitd3d15c365e83fb60e6903974e507b7c8a3bc1cf6 (patch)
treee32aea767dbf19a3ebbcfb964996420f3151b6af /dev-haskell/digest/digest-0.0.0.8.ebuild
parentAdd URL. (diff)
downloadgentoo-2-d3d15c365e83fb60e6903974e507b7c8a3bc1cf6.tar.gz
gentoo-2-d3d15c365e83fb60e6903974e507b7c8a3bc1cf6.tar.bz2
gentoo-2-d3d15c365e83fb60e6903974e507b7c8a3bc1cf6.zip
Initial version of dev-haskell/digest.
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/digest/digest-0.0.0.8.ebuild')
-rw-r--r--dev-haskell/digest/digest-0.0.0.8.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-haskell/digest/digest-0.0.0.8.ebuild b/dev-haskell/digest/digest-0.0.0.8.ebuild
new file mode 100644
index 000000000000..ab2cb12ece31
--- /dev/null
+++ b/dev-haskell/digest/digest-0.0.0.8.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/digest/digest-0.0.0.8.ebuild,v 1.1 2010/03/28 17:10:18 kolmodin Exp $
+
+CABAL_FEATURES="lib profile haddock"
+inherit haskell-cabal
+
+DESCRIPTION="Various cryptographic hashes for bytestrings; CRC32 and Adler32 for now."
+HOMEPAGE="http://hackage.haskell.org/cgi-bin/hackage-scripts/package/digest"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/ghc-6.6.1
+ >=dev-haskell/cabal-1.6
+ sys-libs/zlib"