summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-10-19 16:12:13 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-10-19 16:12:13 +0000
commitbcba28a88cfef2ff0523f921198d11d91f27f8eb (patch)
tree1cb7d2c9d3e37c2635d9c05adb49056ea74d275b /dev-games
parentRemove. Part of bug 330683. (diff)
downloadgentoo-2-bcba28a88cfef2ff0523f921198d11d91f27f8eb.tar.gz
gentoo-2-bcba28a88cfef2ff0523f921198d11d91f27f8eb.tar.bz2
gentoo-2-bcba28a88cfef2ff0523f921198d11d91f27f8eb.zip
old, part of bug 330683
(Portage version: 2.2.0_alpha69/cvs/Linux x86_64)
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/crystalspace/ChangeLog6
-rw-r--r--dev-games/crystalspace/crystalspace-1.2.1.ebuild129
-rw-r--r--dev-games/crystalspace/files/crystalspace-1.2.1-libpng14.patch13
3 files changed, 5 insertions, 143 deletions
diff --git a/dev-games/crystalspace/ChangeLog b/dev-games/crystalspace/ChangeLog
index bc219d81309c..794d917f2530 100644
--- a/dev-games/crystalspace/ChangeLog
+++ b/dev-games/crystalspace/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-games/crystalspace
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/ChangeLog,v 1.53 2011/09/09 09:25:36 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/ChangeLog,v 1.54 2011/10/19 16:12:13 ssuominen Exp $
+
+ 19 Oct 2011; Samuli Suominen <ssuominen@gentoo.org>
+ -crystalspace-1.2.1.ebuild, -files/crystalspace-1.2.1-libpng14.patch:
+ old
09 Sep 2011; Tupone Alfredo <tupone@gentoo.org> crystalspace-1.4.0.ebuild,
+files/crystalspace-1.4.0-png15.patch:
diff --git a/dev-games/crystalspace/crystalspace-1.2.1.ebuild b/dev-games/crystalspace/crystalspace-1.2.1.ebuild
deleted file mode 100644
index 89b8e39e923f..000000000000
--- a/dev-games/crystalspace/crystalspace-1.2.1.ebuild
+++ /dev/null
@@ -1,129 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/crystalspace-1.2.1.ebuild,v 1.8 2011/07/20 13:26:19 tomka Exp $
-
-EAPI=2
-inherit eutils flag-o-matic multilib wxwidgets
-
-MY_P=${PN}-src-${PV}
-DESCRIPTION="Portable 3D Game Development Kit written in C++"
-HOMEPAGE="http://crystal.sourceforge.net/"
-SRC_URI="mirror://sourceforge/crystal/${MY_P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="3ds alsa cal3d cegui cg doc javascript jpeg mng ode png python
-sdl truetype vorbis wxwidgets"
-
-RDEPEND="virtual/opengl
- cg? ( media-gfx/nvidia-cg-toolkit )
- ode? ( dev-games/ode )
- cal3d? ( >=media-libs/cal3d-0.11 )
- jpeg? ( virtual/jpeg )
- sdl? ( media-libs/libsdl )
- vorbis? ( media-libs/libogg
- media-libs/libvorbis )
- truetype? ( >=media-libs/freetype-2.1 )
- alsa? ( media-libs/alsa-lib )
- mng? ( media-libs/libmng )
- png? ( media-libs/libpng )
- wxwidgets? ( x11-libs/pango
- =x11-libs/wxGTK-2.6* )
- javascript? ( dev-lang/spidermonkey )
- cegui? ( >=dev-games/cegui-0.5.0 )
- x11-libs/libXaw
- x11-libs/libXxf86vm"
-DEPEND="${RDEPEND}
- 3ds? ( media-libs/lib3ds )
- dev-util/ftjam
- dev-lang/swig
- dev-util/pkgconfig"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- # Installing doc conflict with dodoc on src_install
- # Removing conflicting target
- sed -i \
- -e "/^InstallDoc/d" \
- Jamfile.in \
- docs/Jamfile \
- || die "sed failed"
-
- epatch "${FILESDIR}"/${P}-libpng14.patch
-}
-
-src_configure() {
- if use wxwidgets; then
- WX_GTK_VER=2.6
- need-wxwidgets gtk2
- fi
-
- # -O3 is hanging compilation of python script plugin
- # trying -O2 just in case
- replace-flags -O3 -O2
- econf --enable-cpu-specific-optimizations=no \
- --disable-separate-debug-info \
- --without-lcms \
- --without-caca \
- --without-bullet \
- --without-openal \
- --without-jackasyn \
- --without-mikmod \
- --without-perl \
- --without-java \
- --disable-make-emulation \
- $(use_with python) \
- $(use_with png) \
- $(use_with jpeg) \
- $(use_with mng) \
- $(use_with vorbis) \
- $(use_with 3ds) \
- $(use_with ode) \
- $(use_with truetype freetype2) \
- $(use_with cal3d) \
- $(use_with sdl) \
- $(use_with wxwidgets wx) \
- $(use_with cegui CEGUI) \
- $(use_with cg Cg) \
- $(use_with javascript js) \
- $(use_with alsa asound)
- #remove unwanted CFLAGS added by ./configure
- sed -i -e '/COMPILER\.CFLAGS\.optimize/d' \
- Jamconfig \
- || die "sed failed"
-}
-
-src_compile() {
- jam -q || die "compile failed"
-}
-
-src_install() {
- for installTarget in install_bin install_plugin install_lib \
- install_include install_data install_config
- do
- jam -q -s DESTDIR="${D}" ${installTarget} \
- || die "jam ${installTarget} failed"
- done
- if use doc; then
- jam -q -s DESTDIR="${D}" install_doc || die "jam install_doc failed"
- fi
- dodoc README docs/history* docs/todo_*
-
- echo "CRYSTAL_PLUGIN=/usr/$(get_libdir)/${P}" > 90crystalspace
- echo "CRYSTAL_CONFIG=/etc/${P}" >> 90crystalspace
- doenvd 90crystalspace
-}
-
-pkg_postinst() {
- elog "Examples coming with this package, need correct light calculation"
- elog "Do the following commands, with the root account, to fix that:"
- # Fill cache directory for the examples
- local dir
- for dir in castle flarge isomap parallaxtest partsys r3dtest stenciltest \
- terrain terrainf;
- do
- elog "cslight -video=null /usr/share/${PN}/data/maps/${dir}"
- done
-}
diff --git a/dev-games/crystalspace/files/crystalspace-1.2.1-libpng14.patch b/dev-games/crystalspace/files/crystalspace-1.2.1-libpng14.patch
deleted file mode 100644
index 2ee262d87d4f..000000000000
--- a/dev-games/crystalspace/files/crystalspace-1.2.1-libpng14.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-http://trac.crystalspace3d.org/trac/CS/ticket/803
-
---- plugins/video/loader/png/pngimage.cpp
-+++ plugins/video/loader/png/pngimage.cpp
-@@ -378,7 +378,7 @@
- const png_bytep iBuffer = dataSource->GetUint8();
- const size_t iSize = dataSource->GetSize();
-
-- if (!png_check_sig (iBuffer, (int)iSize))
-+ if (png_sig_cmp (iBuffer, 0, (int)iSize) != 0)
- return false;
- png = png_create_read_struct (PNG_LIBPNG_VER_STRING, 0, 0, 0);
- if (!png)