summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-03-12 13:10:54 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-03-12 13:10:54 +0000
commit844e413dd688b34eaf3ff9115e32e853f279dcd2 (patch)
treeadfff802ef89a4e53ad2aa23f41bd0bc48bcba4c /dev-games/openscenegraph
parentPartial sync from Emacs overlay, only documentation and einfo output changes. (diff)
downloadgentoo-2-844e413dd688b34eaf3ff9115e32e853f279dcd2.tar.gz
gentoo-2-844e413dd688b34eaf3ff9115e32e853f279dcd2.tar.bz2
gentoo-2-844e413dd688b34eaf3ff9115e32e853f279dcd2.zip
Enable the following USE flags: curl freetype gif jpeg png tiff xrandr
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'dev-games/openscenegraph')
-rw-r--r--dev-games/openscenegraph/ChangeLog7
-rw-r--r--dev-games/openscenegraph/files/openscenegraph-2.8.0-magicoff.patch64
-rw-r--r--dev-games/openscenegraph/metadata.xml10
-rw-r--r--dev-games/openscenegraph/openscenegraph-2.8.0.ebuild26
4 files changed, 89 insertions, 18 deletions
diff --git a/dev-games/openscenegraph/ChangeLog b/dev-games/openscenegraph/ChangeLog
index ce076cc757c4..2a184a1ad5d1 100644
--- a/dev-games/openscenegraph/ChangeLog
+++ b/dev-games/openscenegraph/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-games/openscenegraph
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/openscenegraph/ChangeLog,v 1.7 2009/03/10 15:32:07 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/openscenegraph/ChangeLog,v 1.8 2009/03/12 13:10:54 tupone Exp $
+
+ 12 Mar 2009; Alfredo Tupone <tupone@gentoo.org>
+ files/openscenegraph-2.8.0-magicoff.patch, metadata.xml,
+ openscenegraph-2.8.0.ebuild:
+ Enable the following USE flags: curl freetype gif jpeg png tiff xrandr
10 Mar 2009; Alfredo Tupone <tupone@gentoo.org>
files/openscenegraph-2.8.0-magicoff.patch, openscenegraph-2.8.0.ebuild:
diff --git a/dev-games/openscenegraph/files/openscenegraph-2.8.0-magicoff.patch b/dev-games/openscenegraph/files/openscenegraph-2.8.0-magicoff.patch
index b01393f1a3e7..42aaa05aacc5 100644
--- a/dev-games/openscenegraph/files/openscenegraph-2.8.0-magicoff.patch
+++ b/dev-games/openscenegraph/files/openscenegraph-2.8.0-magicoff.patch
@@ -1,6 +1,6 @@
---- CMakeLists.txt.old 2009-02-25 10:26:47.000000000 +0100
-+++ CMakeLists.txt 2009-02-25 10:33:07.000000000 +0100
-@@ -287,14 +287,24 @@
+--- CMakeLists.txt.old 2009-03-12 10:39:41.000000000 +0100
++++ CMakeLists.txt 2009-03-12 10:47:37.000000000 +0100
+@@ -287,22 +287,45 @@
INCLUDE(Find3rdPartyDependencies)
ENDIF(WIN32)
@@ -9,9 +9,18 @@
+OPTION(ENABLE_XINE "Enable xine plugin" ON)
+OPTION(ENABLE_JPEG2K "Enable jp2 plugin" ON)
+OPTION(ENABLE_SVG "Enable svg plugin" ON)
++OPTION(ENABLE_FREETYPE "Enable freetype plugin" ON)
++OPTION(ENABLE_CURL "Enable curl plugin" ON)
++OPTION(ENABLE_GIF "Enable gif plugin" ON)
++OPTION(ENABLE_JPEG "Enable jpeg plugin" ON)
++OPTION(ENABLE_PNG "Enable png plugin" ON)
++OPTION(ENABLE_TIFF "Enable tiff plugin" ON)
++OPTION(ENABLE_XRANDR "Enable xrandr usage" ON)
+
# Common to all platforms:
++IF(ENABLE_FREETYPE)
FIND_PACKAGE(FreeType)
++ENDIF(ENABLE_FREETYPE)
FIND_PACKAGE(Inventor)
+IF(ENABLE_JPEG2K)
FIND_PACKAGE(Jasper)
@@ -25,7 +34,9 @@
FIND_PACKAGE(OpenVRML)
FIND_PACKAGE(Performer)
FIND_PACKAGE(GDAL)
-@@ -302,7 +312,9 @@
++IF(ENABLE_CURL)
+ FIND_PACKAGE(CURL)
++ENDIF(ENABLE_CURL)
FIND_PACKAGE(ITK)
FIND_PACKAGE(LibVNCServer)
FIND_PACKAGE(OurDCMTK)
@@ -35,8 +46,8 @@
#use pkg-config to find various modues
INCLUDE(FindPkgConfig OPTIONAL)
-@@ -319,9 +331,13 @@
- KG_CHECK_MODULES(GTKGL gtkglext-x11-1.0)
+@@ -319,9 +342,13 @@
+ PKG_CHECK_MODULES(GTKGL gtkglext-x11-1.0)
ENDIF(WIN32)
+ IF(ENABLE_SVG)
@@ -48,4 +59,43 @@
+ ENDIF(ENABLE_PDF)
ENDIF(PKG_CONFIG_FOUND)
-
+
+@@ -417,10 +444,18 @@
+ # Image readers/writers depend on 3rd party libraries except for OS X which
+ # can use Quicktime.
+ IF(NOT APPLE)
++ IF(ENABLE_GIF)
+ FIND_PACKAGE(GIFLIB)
++ ENDIF(ENABLE_GIF)
++ IF(ENABLE_JPEG)
+ FIND_PACKAGE(JPEG)
++ ENDIF(ENABLE_JPEG)
++ IF(ENABLE_PNG)
+ FIND_PACKAGE(PNG)
++ ENDIF(ENABLE_PNG)
++ IF(ENABLE_TIFF)
+ FIND_PACKAGE(TIFF)
++ ENDIF(ENABLE_TIFF)
+
+ # QuickTime is required for OS X, but optional for Windows.
+ IF(WIN32)
+@@ -843,3 +878,7 @@
+ IMMEDIATE @ONLY)
+ ADD_CUSTOM_TARGET(uninstall
+ "${CMAKE_COMMAND}" -P "${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake")
++
++MESSAGE(STATUS "<<< Gentoo configuration >>>
++Build type: ${CMAKE_BUILD_TYPE}
++Install path: ${CMAKE_INSTALL_PREFIX}\n")
+--- src/osgViewer/CMakeLists.txt.old 2009-03-12 10:46:01.000000000 +0100
++++ src/osgViewer/CMakeLists.txt 2009-03-12 10:46:48.000000000 +0100
+@@ -91,7 +91,9 @@
+ INCLUDE(FindPkgConfig OPTIONAL)
+ IF (PKG_CONFIG_FOUND)
+
++ IF(ENABLE_XRANDR)
+ PKG_CHECK_MODULES(XRANDR xrandr)
++ ENDIF(ENABLE_XRANDR)
+
+ IF (XRANDR_FOUND)
+ OPTION(OSGVIEWER_USE_XRANDR "Set to ON to enable Xrandr support for GraphicsWindowX11." ON)
diff --git a/dev-games/openscenegraph/metadata.xml b/dev-games/openscenegraph/metadata.xml
index 41430b392e2a..3d082e774fc1 100644
--- a/dev-games/openscenegraph/metadata.xml
+++ b/dev-games/openscenegraph/metadata.xml
@@ -10,6 +10,14 @@
The OpenSceneGraph is an open source high performance 3D graphics toolkit, used by application developers in fields such as visual simulation, games, virtual reality, scientific visualization and modelling. Written entirely in Standard C++ and OpenGL it runs on all Windows platforms, OSX, GNU/Linux, IRIX, Solaris, HP-Ux, AIX and FreeBSD operating systems. The OpenSceneGraph is now well established as the world leading scene graph technology, used widely in the vis-sim, space, scientific, oil-gas, games and virtual reality industries.
</longdescription>
<use>
- <flag name="osgapps">Build osg applications</flag>
+ <flag name="osgapps">
+ Build osg applications
+ </flag>
+ <flag name="freetype">
+ Enable osg to use the <pkg>media-libs/freetype</pkg> based plugin
+ </flag>
+ <flag name="xrandr">
+ Enable support for the X xrandr extension
+ </flag>
</use>
</pkgmetadata>
diff --git a/dev-games/openscenegraph/openscenegraph-2.8.0.ebuild b/dev-games/openscenegraph/openscenegraph-2.8.0.ebuild
index e62efe7a3f0a..45e31ebb50ac 100644
--- a/dev-games/openscenegraph/openscenegraph-2.8.0.ebuild
+++ b/dev-games/openscenegraph/openscenegraph-2.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/openscenegraph/openscenegraph-2.8.0.ebuild,v 1.7 2009/03/10 15:32:07 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/openscenegraph/openscenegraph-2.8.0.ebuild,v 1.8 2009/03/12 13:10:54 tupone Exp $
EAPI=2
inherit eutils versionator cmake-utils
@@ -16,18 +16,19 @@ SRC_URI="http://www.openscenegraph.org/downloads/stable_releases/${MY_P_MAJOR}/s
LICENSE="wxWinLL-3 LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~sparc ~x86"
-IUSE="jpeg2k osgapps pdf svg xine xulrunner"
+IUSE="curl freetype gif jpeg jpeg2k osgapps pdf png svg tiff xine xrandr xulrunner"
RDEPEND="virtual/opengl
virtual/glu
- media-libs/libpng
- media-libs/jpeg
- media-libs/giflib
- media-libs/tiff
- media-libs/freetype
+ png? ( media-libs/libpng )
+ jpeg? ( media-libs/jpeg )
+ gif? ( media-libs/giflib )
+ tiff? ( media-libs/tiff )
+ freetype? ( media-libs/freetype )
x11-libs/libSM
- x11-libs/libXrandr
- net-misc/curl
+ x11-libs/libXext
+ xrandr? ( x11-libs/libXrandr )
+ curl? ( net-misc/curl )
xulrunner? ( net-libs/xulrunner )
svg? ( gnome-base/librsvg )
jpeg2k? ( media-libs/jasper )
@@ -59,5 +60,12 @@ src_configure() {
mycmakeargs="${mycmakeargs} $(cmake-utils_use_enable xine XINE)"
mycmakeargs="${mycmakeargs} $(cmake-utils_use_enable jpeg2k JPEG2K)"
mycmakeargs="${mycmakeargs} $(cmake-utils_use_enable svg SVG)"
+ mycmakeargs="${mycmakeargs} $(cmake-utils_use_enable freetype FREETYPE)"
+ mycmakeargs="${mycmakeargs} $(cmake-utils_use_enable curl CURL)"
+ mycmakeargs="${mycmakeargs} $(cmake-utils_use_enable gif GIF)"
+ mycmakeargs="${mycmakeargs} $(cmake-utils_use_enable png PNG)"
+ mycmakeargs="${mycmakeargs} $(cmake-utils_use_enable jpeg JPEG)"
+ mycmakeargs="${mycmakeargs} $(cmake-utils_use_enable tiff TIFF)"
+ mycmakeargs="${mycmakeargs} $(cmake-utils_use_enable xrandr XRANDR)"
cmake-utils_src_configure
}