summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-01-28 11:30:24 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-01-28 11:30:24 +0000
commit8c5d5c2d004af08f7f873373186a22921440d238 (patch)
tree5adc918aa86363d18d728d5a982526fd159be904 /dev-games/guichan
parentAdded ewarn about changes in spellchecking engine, bug #250115. (diff)
downloadgentoo-2-8c5d5c2d004af08f7f873373186a22921440d238.tar.gz
gentoo-2-8c5d5c2d004af08f7f873373186a22921440d238.tar.bz2
gentoo-2-8c5d5c2d004af08f7f873373186a22921440d238.zip
Declare dependant library to fix --as-needed bug #256443
(Portage version: 2.1.6.4/cvs/Linux 2.6.27-gentoo-r8 x86_64)
Diffstat (limited to 'dev-games/guichan')
-rw-r--r--dev-games/guichan/ChangeLog9
-rw-r--r--dev-games/guichan/files/guichan-0.8.1-as-needed.patch13
-rw-r--r--dev-games/guichan/guichan-0.8.1.ebuild13
3 files changed, 31 insertions, 4 deletions
diff --git a/dev-games/guichan/ChangeLog b/dev-games/guichan/ChangeLog
index 55375d65628d..4b89f6a51c57 100644
--- a/dev-games/guichan/ChangeLog
+++ b/dev-games/guichan/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-games/guichan
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/guichan/ChangeLog,v 1.13 2008/04/27 04:52:22 mr_bones_ Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/guichan/ChangeLog,v 1.14 2009/01/28 11:30:23 tupone Exp $
+
+ 28 Jan 2009; Alfredo Tupone <tupone@gentoo.org>
+ +files/guichan-0.8.1-as-needed.patch, guichan-0.8.1.ebuild:
+ Declare dependant library to fix --as-needed bug #256443 by Lars
+ (Polynomial-C) <polynomial-C@gmx.de>
*guichan-0.8.1 (27 Apr 2008)
diff --git a/dev-games/guichan/files/guichan-0.8.1-as-needed.patch b/dev-games/guichan/files/guichan-0.8.1-as-needed.patch
new file mode 100644
index 000000000000..3908f6956a53
--- /dev/null
+++ b/dev-games/guichan/files/guichan-0.8.1-as-needed.patch
@@ -0,0 +1,13 @@
+--- src/sdl/Makefile.am.old 2009-01-28 11:45:52.000000000 +0100
++++ src/sdl/Makefile.am 2009-01-28 11:57:39.000000000 +0100
+@@ -6,6 +6,8 @@
+
+ libguichan_sdl_la_LDFLAGS = -no-undefined -release $(LT_RELEASE)
+-version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
+
++libguichan_sdl_la_LIBADD = -lSDL_image -L$(top_srcdir)/src -lguichan
++
+ libguichan_sdl_la_SOURCES = \
+ sdl.cpp \
+ sdlgraphics.cpp \
+
diff --git a/dev-games/guichan/guichan-0.8.1.ebuild b/dev-games/guichan/guichan-0.8.1.ebuild
index d70d717226cf..2b16d7ad3996 100644
--- a/dev-games/guichan/guichan-0.8.1.ebuild
+++ b/dev-games/guichan/guichan-0.8.1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/guichan/guichan-0.8.1.ebuild,v 1.1 2008/04/27 04:52:22 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/guichan/guichan-0.8.1.ebuild,v 1.2 2009/01/28 11:30:23 tupone Exp $
+
+inherit eutils autotools
DESCRIPTION="a portable C++ GUI library designed for games using Allegro, SDL and/or OpenGL"
HOMEPAGE="http://guichan.sourceforge.net/"
@@ -18,6 +20,13 @@ DEPEND="allegro? ( media-libs/allegro )
media-libs/sdl-image
)"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+ eautoreconf
+}
+
src_compile() {
econf \
--disable-dependency-tracking \