summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-03-14 23:00:56 +0000
committerTim Harder <radhermit@gentoo.org>2011-03-14 23:00:56 +0000
commit7cd1352c1b178013745085411030bb3f7c1f3d11 (patch)
treec078e480a0b8f46dc6db77f9d366d8713c2db7d0 /dev-embedded/u-boot-tools/u-boot-tools-2010.12.ebuild
parentRemove spurious old-style virtuals. (diff)
downloadgentoo-2-7cd1352c1b178013745085411030bb3f7c1f3d11.tar.gz
gentoo-2-7cd1352c1b178013745085411030bb3f7c1f3d11.tar.bz2
gentoo-2-7cd1352c1b178013745085411030bb3f7c1f3d11.zip
Version bump (bug #355669 by Jacob Galbreath) and remove old. Update to EAPI 4 and remove unnecessary compile setup and die usage.
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'dev-embedded/u-boot-tools/u-boot-tools-2010.12.ebuild')
-rw-r--r--dev-embedded/u-boot-tools/u-boot-tools-2010.12.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-embedded/u-boot-tools/u-boot-tools-2010.12.ebuild b/dev-embedded/u-boot-tools/u-boot-tools-2010.12.ebuild
new file mode 100644
index 000000000000..8b8ef83d2eb2
--- /dev/null
+++ b/dev-embedded/u-boot-tools/u-boot-tools-2010.12.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/u-boot-tools/u-boot-tools-2010.12.ebuild,v 1.1 2011/03/14 23:00:56 radhermit Exp $
+
+EAPI=4
+
+inherit toolchain-funcs
+
+MY_P="u-boot-${PV/_/-}"
+DESCRIPTION="utilities for working with Das U-Boot"
+HOMEPAGE="http://www.denx.de/wiki/U-Boot/WebHome"
+SRC_URI="ftp://ftp.denx.de/pub/u-boot/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ emake \
+ HOSTSTRIP=echo \
+ HOSTCC="$(tc-getCC)" \
+ HOSTCFLAGS="${CFLAGS} ${CPPFLAGS}"' $(HOSTCPPFLAGS)' \
+ HOSTLDFLAGS="${LDFLAGS}" \
+ tools-all
+}
+
+src_install() {
+ cd tools
+ dobin bmp_logo gen_eth_addr img2srec mkimage
+ dobin easylogo/easylogo
+ dobin env/fw_printenv
+ dosym fw_printenv /usr/bin/fw_setenv
+ insinto /etc
+ doins env/fw_env.config
+}