summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-05-24 21:14:15 +0000
committerPacho Ramos <pacho@gentoo.org>2013-05-24 21:14:15 +0000
commitef545faa18e83dcc90762c30a0fe36d8a5509b4e (patch)
treeb9add11c68c5887a8dfae7d642a1439c3af7219f /dev-dotnet
parentenable thumb mode by default for arm targets that are using the microcontroll... (diff)
downloadgentoo-2-ef545faa18e83dcc90762c30a0fe36d8a5509b4e.tar.gz
gentoo-2-ef545faa18e83dcc90762c30a0fe36d8a5509b4e.tar.bz2
gentoo-2-ef545faa18e83dcc90762c30a0fe36d8a5509b4e.zip
Version bump for compatibility with mono-3 using the same snapshot as openSuSE, remove old
(Portage version: 2.1.12.1/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/nant/ChangeLog11
-rw-r--r--dev-dotnet/nant/nant-0.91.ebuild39
-rw-r--r--dev-dotnet/nant/nant-0.93_pre20130131.ebuild (renamed from dev-dotnet/nant/nant-0.90.ebuild)24
3 files changed, 21 insertions, 53 deletions
diff --git a/dev-dotnet/nant/ChangeLog b/dev-dotnet/nant/ChangeLog
index d76ad1e8b536..946089467bae 100644
--- a/dev-dotnet/nant/ChangeLog
+++ b/dev-dotnet/nant/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-dotnet/nant
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/nant/ChangeLog,v 1.46 2012/12/07 04:53:53 phajdan.jr Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/nant/ChangeLog,v 1.47 2013/05/24 21:14:15 pacho Exp $
+
+*nant-0.93_pre20130131 (24 May 2013)
+
+ 24 May 2013; Pacho Ramos <pacho@gentoo.org> +nant-0.93_pre20130131.ebuild,
+ -nant-0.90.ebuild, -nant-0.91.ebuild:
+ Version bump for compatibility with mono-3 using the same snapshot as
+ openSuSE, remove old
07 Dec 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> nant-0.92.ebuild:
x86 stable wrt bug #435202
diff --git a/dev-dotnet/nant/nant-0.91.ebuild b/dev-dotnet/nant/nant-0.91.ebuild
deleted file mode 100644
index 0b75dd91ceff..000000000000
--- a/dev-dotnet/nant/nant-0.91.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/nant/nant-0.91.ebuild,v 1.5 2012/08/18 12:26:23 xmw Exp $
-
-EAPI="4"
-
-inherit mono multilib eutils
-
-DESCRIPTION=".NET build tool"
-HOMEPAGE="http://nant.sourceforge.net/"
-SRC_URI="mirror://sourceforge/nant/${P/_/-}-src.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE=""
-
-RDEPEND=">=dev-lang/mono-2.0"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-# This build is not parallel build friendly
-MAKEOPTS="${MAKEOPTS} -j1"
-
-S="${WORKDIR}/${P/_/-}"
-
-src_install() {
- emake prefix="${ED}/usr" install
-
- # Fix ${ED} showing up in the nant wrapper script, as well as silencing
- # warnings related to the log4net library
- sed -i \
- -e "s:${ED}::" \
- -e "2iexport MONO_SILENT_WARNING=1" \
- -e "s:${ED}::" \
- "${ED}"/usr/bin/nant || die "Sed nant failed"
-
- dodoc README.txt
-}
diff --git a/dev-dotnet/nant/nant-0.90.ebuild b/dev-dotnet/nant/nant-0.93_pre20130131.ebuild
index 045fd5e87b60..a339a113e29d 100644
--- a/dev-dotnet/nant/nant-0.90.ebuild
+++ b/dev-dotnet/nant/nant-0.93_pre20130131.ebuild
@@ -1,35 +1,35 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/nant/nant-0.90.ebuild,v 1.5 2012/05/04 03:56:56 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/nant/nant-0.93_pre20130131.ebuild,v 1.1 2013/05/24 21:14:15 pacho Exp $
-EAPI="3"
-
-inherit mono multilib eutils
+EAPI=5
+inherit mono-env eutils
DESCRIPTION=".NET build tool"
HOMEPAGE="http://nant.sourceforge.net/"
-SRC_URI="mirror://sourceforge/nant/${P/_/-}-src.tar.gz"
+SRC_URI="http://dev.gentoo.org/~pacho/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 ppc x86"
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
RDEPEND=">=dev-lang/mono-2.0"
DEPEND="${RDEPEND}
- virtual/pkgconfig"
+ virtual/pkgconfig
+"
# This build is not parallel build friendly
MAKEOPTS="${MAKEOPTS} -j1"
-S="${WORKDIR}/${P/_/-}"
+S="${WORKDIR}/${PN}"
src_compile() {
- emake || die
+ emake TARGET=mono-4.5 MCS="gmcs -sdk:4"
}
src_install() {
- emake prefix="${ED}/usr" install || die "install failed"
+ emake prefix="${ED}/usr" TARGET=mono-4.5 MCS="gmcs -sdk:4" install
# Fix ${ED} showing up in the nant wrapper script, as well as silencing
# warnings related to the log4net library
@@ -39,5 +39,5 @@ src_install() {
-e "s:${ED}::" \
"${ED}"/usr/bin/nant || die "Sed nant failed"
- dodoc README.txt || die
+ dodoc README.txt
}