summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Tindal <urilith@gentoo.org>2005-05-11 10:13:50 +0000
committerMichael Tindal <urilith@gentoo.org>2005-05-11 10:13:50 +0000
commit481be18a1d6a66f886b5a5046a2a07273337d1fc (patch)
tree56d7f7598f374aede67aa45139c4e775467e0a72 /dev-dotnet/ndoc
parentChanging dep on ghc to virtual - thanks kosmikus :) (diff)
downloadgentoo-2-481be18a1d6a66f886b5a5046a2a07273337d1fc.tar.gz
gentoo-2-481be18a1d6a66f886b5a5046a2a07273337d1fc.tar.bz2
gentoo-2-481be18a1d6a66f886b5a5046a2a07273337d1fc.zip
Fixed some warnings which were treated as errors causing the build to bail.
(Portage version: 1.589-cvs)
Diffstat (limited to 'dev-dotnet/ndoc')
-rw-r--r--dev-dotnet/ndoc/ChangeLog7
-rw-r--r--dev-dotnet/ndoc/Manifest4
-rw-r--r--dev-dotnet/ndoc/files/digest-ndoc-1.3.1-r21
-rw-r--r--dev-dotnet/ndoc/ndoc-1.3.1-r2.ebuild57
4 files changed, 67 insertions, 2 deletions
diff --git a/dev-dotnet/ndoc/ChangeLog b/dev-dotnet/ndoc/ChangeLog
index c1c71050c55d..57e33b02983f 100644
--- a/dev-dotnet/ndoc/ChangeLog
+++ b/dev-dotnet/ndoc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-dotnet/ndoc
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/ndoc/ChangeLog,v 1.4 2005/04/03 07:35:39 urilith Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/ndoc/ChangeLog,v 1.5 2005/05/11 10:13:50 urilith Exp $
+
+*ndoc-1.3.1-r2 (11 May 2005)
+
+ 11 May 2005; <urilith@gentoo.org> +ndoc-1.3.1-r2.ebuild:
+ Fixed some warnings showing up as errors.
*ndoc-1.3.1-r1 (03 Apr 2005)
diff --git a/dev-dotnet/ndoc/Manifest b/dev-dotnet/ndoc/Manifest
index edcf6a7d7e80..666d6c9ca2a7 100644
--- a/dev-dotnet/ndoc/Manifest
+++ b/dev-dotnet/ndoc/Manifest
@@ -1,4 +1,6 @@
MD5 a9554d7d428c1df87fd7d7ca0d7b1fc5 ChangeLog 673
-MD5 bfc14dd28bb0f41de04a2033315163d8 ndoc-1.3.1-r1.ebuild 1289
+MD5 712551200beb3cf5c4ac8d40870dd2fe ndoc-1.3.1-r2.ebuild 1452
MD5 443435c45ff66780ef8a6d478be74f1c metadata.xml 256
+MD5 bfc14dd28bb0f41de04a2033315163d8 ndoc-1.3.1-r1.ebuild 1289
MD5 366ef05b58498d63fc6125c49e269c24 files/digest-ndoc-1.3.1-r1 67
+MD5 366ef05b58498d63fc6125c49e269c24 files/digest-ndoc-1.3.1-r2 67
diff --git a/dev-dotnet/ndoc/files/digest-ndoc-1.3.1-r2 b/dev-dotnet/ndoc/files/digest-ndoc-1.3.1-r2
new file mode 100644
index 000000000000..b0adff51c54f
--- /dev/null
+++ b/dev-dotnet/ndoc/files/digest-ndoc-1.3.1-r2
@@ -0,0 +1 @@
+MD5 8950a53dd3c379e41781ba7f1834e948 ndoc-devel-v1.3.1.zip 3896669
diff --git a/dev-dotnet/ndoc/ndoc-1.3.1-r2.ebuild b/dev-dotnet/ndoc/ndoc-1.3.1-r2.ebuild
new file mode 100644
index 000000000000..7cc67b1639cc
--- /dev/null
+++ b/dev-dotnet/ndoc/ndoc-1.3.1-r2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/ndoc/ndoc-1.3.1-r2.ebuild,v 1.1 2005/05/11 10:13:50 urilith Exp $
+
+inherit mono
+
+DESCRIPTION=".NET Documentation Tool"
+HOMEPAGE="http://ndoc.sourceforge.net/"
+
+SRC_URI="mirror://sourceforge/${PN}/${PN}-devel-v${PV}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~x86"
+IUSE="debug doc"
+DEPEND=">=dev-lang/mono-1.0
+ >=dev-dotnet/nant-0.85_rc2"
+RDEPEND=">=dev-lang/mono-1.0"
+
+S=${WORKDIR}
+
+src_compile() {
+ # Workaround some unused private warnings which the buildfiles are treating as errors
+ find ${S} -name '*.build' -exec sed -e 's@warnaserror="true"@@g' -i {} \;
+
+ nant -t:mono-1.0 || die
+}
+
+DLL_FILES="NDoc.Core.dll NDoc.Documenter.JavaDoc.dll NDoc.Documenter.Latex.dll NDoc.Documenter.LinearHtml.dll NDoc.Documenter.Msdn.dll NDoc.Documenter.Msdn2.dll NDoc.Documenter.Xml.dll NDoc.ExtendedUI.dll NDoc.VisualStudio.dll"
+
+src_install() {
+ cd ${S}/bin/mono/1.0
+
+ # This installs all of the dll files with the exe file
+ # directory.
+ insinto /usr/share/ndoc
+ for dll in $DLL_FILES; do
+ doins $dll || die "Failed to install $dll."
+ done
+
+ DEBUG_VAR=""
+
+ use debug && DEBUG_VAR="--debug"
+
+ cat > ndoc <<- EOF
+ #!/bin/bash
+
+ mono $DEBUG_VAR /usr/share/ndoc/NDocConsole.exe "\$@"
+ EOF
+
+ insinto /usr/share/ndoc/
+ doins NDocConsole.exe
+ dobin ndoc
+
+ use doc && dohtml -a gif,html,css,js -r ${S}/doc/sdk/
+}