summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorJauhien Piatlicki <jauhien@gentoo.org>2014-05-09 22:06:24 +0000
committerJauhien Piatlicki <jauhien@gentoo.org>2014-05-09 22:06:24 +0000
commit8420b5ee9264257b107a1ed3681cbe6d33356c57 (patch)
tree95e168ae1a8b9ac31470ab9152cf2411c014b2b3 /dev-db
parentversion bump / add me as maintainer (diff)
downloadgentoo-2-8420b5ee9264257b107a1ed3681cbe6d33356c57.tar.gz
gentoo-2-8420b5ee9264257b107a1ed3681cbe6d33356c57.tar.bz2
gentoo-2-8420b5ee9264257b107a1ed3681cbe6d33356c57.zip
Import from sunrise, closing bug #156506
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB2EFA1D4)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/soci/ChangeLog9
-rw-r--r--dev-db/soci/metadata.xml12
-rw-r--r--dev-db/soci/soci-3.2.2.ebuild47
3 files changed, 68 insertions, 0 deletions
diff --git a/dev-db/soci/ChangeLog b/dev-db/soci/ChangeLog
new file mode 100644
index 000000000000..7223bf078f4d
--- /dev/null
+++ b/dev-db/soci/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-db/soci
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/soci/ChangeLog,v 1.1 2014/05/09 22:06:24 jauhien Exp $
+
+*soci-3.2.2 (09 May 2014)
+
+ 09 May 2014; Jauhien Piatlicki <jauhien@gentoo.org> +metadata.xml,
+ +soci-3.2.2.ebuild:
+ Import from sunrise, closing bug #156506
diff --git a/dev-db/soci/metadata.xml b/dev-db/soci/metadata.xml
new file mode 100644
index 000000000000..a87bd7dd7a64
--- /dev/null
+++ b/dev-db/soci/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>jauhien@gentoo.org</email>
+ <name>Jauhien Piatlicki</name>
+ </maintainer>
+ <use>
+ <flag name="boost">Enable boost support</flag>
+ <flag name="empty">Build the sample backend called Empty</flag>
+ </use>
+</pkgmetadata>
diff --git a/dev-db/soci/soci-3.2.2.ebuild b/dev-db/soci/soci-3.2.2.ebuild
new file mode 100644
index 000000000000..75ac182006f3
--- /dev/null
+++ b/dev-db/soci/soci-3.2.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/soci/soci-3.2.2.ebuild,v 1.1 2014/05/09 22:06:24 jauhien Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="A db access library for C++ that makes the illusion of embedding SQL queries in the regular C++ code"
+HOMEPAGE="http://soci.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
+LICENSE="Boost-1.0"
+SLOT="0"
+IUSE="boost doc +empty firebird mysql odbc oracle postgres sqlite"
+
+DEPEND="boost? ( dev-libs/boost )
+ firebird? ( dev-db/firebird )
+ mysql? ( virtual/mysql )
+ odbc? ( dev-db/unixODBC )
+ oracle? ( dev-db/oracle-instantclient-basic )
+ postgres? ( dev-db/postgresql-base )
+ sqlite? ( dev-db/sqlite:3 )
+"
+RDEPEND=${DEPEND}
+
+src_configure() {
+ local mycmakeargs="$(cmake-utils_use_with boost )
+ $(cmake-utils_use empty SOCI_EMPTY)
+ $(cmake-utils_use_with firebird FIREBIRD)
+ $(cmake-utils_use_with mysql MYSQL)
+ $(cmake-utils_use_with odbc ODBC)
+ $(cmake-utils_use_with oracle ORACLE)
+ $(cmake-utils_use_with postgres POSTGRESQL)
+ $(cmake-utils_use_with sqlite SQLITE3)
+ -DWITH_DB2=OFF" #use MYCMAKEARGS if you want enable IBM DB2 support
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc AUTHORS CHANGES
+ if use doc; then
+ dohtml -r doc/*
+ fi
+}