summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-05-24 08:35:19 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-05-24 08:35:19 +0000
commit70f84b92a0b8ed2b185dc13f94cce801eb9d655b (patch)
tree1636fbca63b52274f3578072c05f92432eb1782e /dev-db
parentAdd py3 support, adjust test phase accordingly (diff)
downloadgentoo-2-70f84b92a0b8ed2b185dc13f94cce801eb9d655b.tar.gz
gentoo-2-70f84b92a0b8ed2b185dc13f94cce801eb9d655b.tar.bz2
gentoo-2-70f84b92a0b8ed2b185dc13f94cce801eb9d655b.zip
Fix python use #471134
(Portage version: 2.2.0_alpha176/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/barman/ChangeLog5
-rw-r--r--dev-db/barman/barman-1.2.0.ebuild8
2 files changed, 11 insertions, 2 deletions
diff --git a/dev-db/barman/ChangeLog b/dev-db/barman/ChangeLog
index 9d64b2f4a668..76bf8277f957 100644
--- a/dev-db/barman/ChangeLog
+++ b/dev-db/barman/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-db/barman
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/barman/ChangeLog,v 1.5 2013/02/06 08:43:32 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/barman/ChangeLog,v 1.6 2013/05/24 08:35:19 patrick Exp $
+
+ 24 May 2013; Patrick Lauer <patrick@gentoo.org> barman-1.2.0.ebuild:
+ Fix python use #471134
*barman-1.2.0 (06 Feb 2013)
diff --git a/dev-db/barman/barman-1.2.0.ebuild b/dev-db/barman/barman-1.2.0.ebuild
index 970aef402ca1..9b101927d40d 100644
--- a/dev-db/barman/barman-1.2.0.ebuild
+++ b/dev-db/barman/barman-1.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/barman/barman-1.2.0.ebuild,v 1.1 2013/02/06 08:43:32 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/barman/barman-1.2.0.ebuild,v 1.2 2013/05/24 08:35:19 patrick Exp $
EAPI=4
inherit distutils
@@ -21,3 +21,9 @@ RDEPEND="dev-python/argh
net-misc/rsync
dev-db/postgresql-server"
DEPEND=""
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+