summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2014-05-06 02:58:30 +0000
committerBrian Evans <grknight@gentoo.org>2014-05-06 02:58:30 +0000
commit0cb59513eb0b24b36f4e2eb5f9ef8d1ef0f03d1b (patch)
treee5f0c9a437212d023f2f3f210fa47020121b5825 /dev-db
parentProperly drop old versions, drop py-2.6 compatibility to match ssl-fetch (diff)
downloadgentoo-2-0cb59513eb0b24b36f4e2eb5f9ef8d1ef0f03d1b.tar.gz
gentoo-2-0cb59513eb0b24b36f4e2eb5f9ef8d1ef0f03d1b.tar.bz2
gentoo-2-0cb59513eb0b24b36f4e2eb5f9ef8d1ef0f03d1b.zip
Remove old
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 67C78E1D)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/mysql++/ChangeLog8
-rw-r--r--dev-db/mysql++/files/mysql++-signed-char-fix-try2.diff51
-rw-r--r--dev-db/mysql++/mysql++-2.2.2-r1.ebuild56
3 files changed, 6 insertions, 109 deletions
diff --git a/dev-db/mysql++/ChangeLog b/dev-db/mysql++/ChangeLog
index b52c7c4faa92..2a708c602f1a 100644
--- a/dev-db/mysql++/ChangeLog
+++ b/dev-db/mysql++/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/mysql++
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql++/ChangeLog,v 1.69 2013/05/25 07:42:38 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql++/ChangeLog,v 1.70 2014/05/06 02:58:29 grknight Exp $
+
+ 06 May 2014; Brian Evans <grknight@gentoo.org>
+ -files/mysql++-signed-char-fix-try2.diff, -mysql++-2.2.2-r1.ebuild:
+ Remove old
25 May 2013; Agostino Sarubbo <ago@gentoo.org> mysql++-3.1.0.ebuild:
Stable for sparc, wrt bug #464420
diff --git a/dev-db/mysql++/files/mysql++-signed-char-fix-try2.diff b/dev-db/mysql++/files/mysql++-signed-char-fix-try2.diff
deleted file mode 100644
index 2b14a39f66ab..000000000000
--- a/dev-db/mysql++/files/mysql++-signed-char-fix-try2.diff
+++ /dev/null
@@ -1,51 +0,0 @@
-diff -ru mysql++-2.1.1.orig/lib/qparms.h mysql++-2.1.1/lib/qparms.h
---- mysql++-2.1.1.orig/lib/qparms.h 2006-04-05 06:44:49.000000000 +0200
-+++ mysql++-2.1.1/lib/qparms.h 2006-11-28 21:40:36.000000000 +0100
-@@ -232,7 +232,7 @@
- /// \param b the 'before' value
- /// \param o the 'option' value
- /// \param n the 'num' value
-- SQLParseElement(std::string b, char o, char n) :
-+ SQLParseElement(std::string b, char o, signed char n) :
- before(b),
- option(o),
- num(n)
-@@ -241,7 +241,7 @@
-
- std::string before; ///< string inserted before the parameter
- char option; ///< the parameter option, or blank if none
-- char num; ///< the parameter position to use
-+ signed char num; ///< the parameter position to use
- };
-
- } // end namespace mysqlpp
-diff -ru mysql++-2.1.1.orig/lib/query.cpp mysql++-2.1.1/lib/query.cpp
---- mysql++-2.1.1.orig/lib/query.cpp 2006-04-05 06:44:49.000000000 +0200
-+++ mysql++-2.1.1/lib/query.cpp 2006-11-28 21:40:52.000000000 +0100
-@@ -185,7 +185,7 @@
- else {
- num[1] = 0;
- }
-- short int n = atoi(num);
-+ signed char n = atoi(num);
-
- // Look for option character following position value.
- char option = ' ';
-@@ -220,7 +220,7 @@
- }
-
- // Finished parsing parameter; save it.
-- parse_elems_.push_back(SQLParseElement(str, option, char(n)));
-+ parse_elems_.push_back(SQLParseElement(str, option, n));
- str = "";
- name = "";
- }
-@@ -304,7 +304,7 @@
- {
- sbuffer_.str("");
-
-- char num;
-+ signed char num;
- SQLString* ss;
- SQLQueryParms* c;
-
diff --git a/dev-db/mysql++/mysql++-2.2.2-r1.ebuild b/dev-db/mysql++/mysql++-2.2.2-r1.ebuild
deleted file mode 100644
index f509b015fb98..000000000000
--- a/dev-db/mysql++/mysql++-2.2.2-r1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql++/mysql++-2.2.2-r1.ebuild,v 1.9 2008/11/14 02:22:25 robbat2 Exp $
-
-inherit eutils
-
-DESCRIPTION="C++ API interface to the MySQL database"
-# This is the download page but includes links to other places
-HOMEPAGE="http://www.mysql.org/downloads/api-mysql++.html"
-SRC_URI="http://www.tangentsoft.net/mysql++/releases/${P}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ~mips ppc sparc x86"
-IUSE=""
-
-RDEPEND=">=virtual/mysql-4.0"
-DEPEND="${RDEPEND}
- >=sys-devel/gcc-3"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- for i in "${S}"/lib/*.h ; do
- sed -i \
- -e '/#include </s,mysql.h,mysql/mysql.h,g' \
- -e '/#include </s,mysql_version.h,mysql/mysql_version.h,g' \
- "${i}" || die "Failed to sed ${i} for fixing MySQL includes"
- done
-}
-
-src_compile() {
- local myconf
- # we want C++ exceptions turned on
- myconf="--enable-exceptions"
- # give threads a try
- myconf="${myconf} --enable-thread-check"
- # not including the directives to where MySQL is because it seems to
- # find it just fine without
-
- # force the cflags into place otherwise they get totally ignored by
- # configure
- CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" \
- econf ${myconf} || die "econf failed"
-
- emake || die "unable to make"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die
- # install the docs and HTML pages
- dodoc README* CREDITS ChangeLog HACKERS Wishlist
- dodoc doc/*
- cp -ra doc/html "${D}"/usr/share/doc/${PF}/html
- prepalldocs
-}