summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2006-12-02 17:55:52 +0000
committerLuca Longinotti <chtekk@gentoo.org>2006-12-02 17:55:52 +0000
commit1ea9bd14d47f498a5234368fe94d38586d92dbdf (patch)
tree794772a863f94c4318393f49966b7557854bdfb4 /dev-db/unixODBC
parentFix dep: add automake wrt bug #151349. (diff)
downloadgentoo-2-1ea9bd14d47f498a5234368fe94d38586d92dbdf.tar.gz
gentoo-2-1ea9bd14d47f498a5234368fe94d38586d92dbdf.tar.bz2
gentoo-2-1ea9bd14d47f498a5234368fe94d38586d92dbdf.zip
Fix bug #151555.
(Portage version: 2.1.2_rc2-r2)
Diffstat (limited to 'dev-db/unixODBC')
-rw-r--r--dev-db/unixODBC/ChangeLog6
-rw-r--r--dev-db/unixODBC/unixODBC-2.2.11-r1.ebuild16
2 files changed, 15 insertions, 7 deletions
diff --git a/dev-db/unixODBC/ChangeLog b/dev-db/unixODBC/ChangeLog
index d40c7d37b58a..cf907781ee79 100644
--- a/dev-db/unixODBC/ChangeLog
+++ b/dev-db/unixODBC/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/unixODBC
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/ChangeLog,v 1.60 2006/12/01 16:51:11 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/ChangeLog,v 1.61 2006/12/02 17:55:52 chtekk Exp $
+
+ 02 Dec 2006; Luca Longinotti <chtekk@gentoo.org>
+ unixODBC-2.2.11-r1.ebuild:
+ Fix bug #151555.
01 Dec 2006; Luca Longinotti <chtekk@gentoo.org>
-files/unixODBC-2.2.6-configure.in.patch, -files/gentoo-yac.diff,
diff --git a/dev-db/unixODBC/unixODBC-2.2.11-r1.ebuild b/dev-db/unixODBC/unixODBC-2.2.11-r1.ebuild
index e737b526077f..a063772226b2 100644
--- a/dev-db/unixODBC/unixODBC-2.2.11-r1.ebuild
+++ b/dev-db/unixODBC/unixODBC-2.2.11-r1.ebuild
@@ -1,8 +1,11 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.2.11-r1.ebuild,v 1.16 2006/12/01 16:51:11 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.2.11-r1.ebuild,v 1.17 2006/12/02 17:55:52 chtekk Exp $
-inherit eutils multilib
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit eutils multilib autotools
KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
@@ -28,8 +31,9 @@ src_unpack() {
# braindead check in configure fails - hackish approach
epatch "${FILESDIR}/${P}-configure.in.patch"
epatch "${FILESDIR}/${P}-Makefile.am.patch"
- aclocal && \
- libtoolize -c -f && \
+ autotools_set_versions
+ aclocal --force && \
+ libtoolize --copy --force && \
automake && \
autoconf || die "autotools failed"
}
@@ -38,13 +42,13 @@ src_compile() {
local myconf
if use qt3 && ! use mips ; then
- myconf="--enable-gui=yes --x-libraries=/usr/lib"
+ myconf="--enable-gui=yes --x-libraries=/usr/$(get_libdir)"
else
myconf="--enable-gui=no"
fi
econf --prefix=/usr \
- --sysconfdir=/etc/unixODBC \
+ --sysconfdir=/etc/${PN} \
--libdir=/usr/$(get_libdir) \
${myconf} || die "econf failed"