summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2006-09-20 08:17:11 +0000
committerFabian Groffen <grobian@gentoo.org>2006-09-20 08:17:11 +0000
commit8c45f3a6e4075db775fffaada321958335aac9ce (patch)
tree50f1f0f7069c76c9f5b8fa0a1a879ffd7298a191 /dev-db/monetdb
parentgcc4 patch from vapier to fix bug #136252 (diff)
downloadgentoo-2-8c45f3a6e4075db775fffaada321958335aac9ce.tar.gz
gentoo-2-8c45f3a6e4075db775fffaada321958335aac9ce.tar.bz2
gentoo-2-8c45f3a6e4075db775fffaada321958335aac9ce.zip
Force configure not to inject all kinds of -Werror crap (bug #148230)
(Portage version: 2.1.1)
Diffstat (limited to 'dev-db/monetdb')
-rw-r--r--dev-db/monetdb/monetdb-4.10.2.ebuild16
-rw-r--r--dev-db/monetdb/monetdb-4.12.0.ebuild16
2 files changed, 14 insertions, 18 deletions
diff --git a/dev-db/monetdb/monetdb-4.10.2.ebuild b/dev-db/monetdb/monetdb-4.10.2.ebuild
index f58375461ab5..5db982faaab2 100644
--- a/dev-db/monetdb/monetdb-4.10.2.ebuild
+++ b/dev-db/monetdb/monetdb-4.10.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/monetdb/monetdb-4.10.2.ebuild,v 1.5 2006/06/17 18:23:43 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/monetdb/monetdb-4.10.2.ebuild,v 1.6 2006/09/20 08:17:11 grobian Exp $
inherit flag-o-matic eutils
@@ -68,14 +68,11 @@ src_compile() {
# The tar has capitals, the ebuild doesn't...
cd "${WORKDIR}/MonetDB-${PV_M}"
- local myconf=""
-
- if use debug;
- then
- myconf="${myconf} --enable-debug"
- else
- myconf="${myconf} --enable-optimize --disable-assert"
- fi
+ # setting these respects the user's CFLAGS and disables -Werror etc.
+ local myconf="--disable-optimize --disable-debug"
+ sed -i \
+ -e 's|CFLAGS="\$CFLAGS \\\$(X_CFLAGS)"||' \
+ configure || die "failed fixing configure"
# Gentoo's amd64 doesn't allow 32-bits monetdb to compile, hence we switch
# to 64-bits Mserver here. Note that this also gives 64-bits OIDs.
@@ -83,6 +80,7 @@ src_compile() {
myconf="${myconf} $(use_with java)"
myconf="${myconf} $(use_with readline)"
+ myconf="${myconf} $(use_enable debug assert)"
econf ${myconf} || die "econf monetdb failed"
diff --git a/dev-db/monetdb/monetdb-4.12.0.ebuild b/dev-db/monetdb/monetdb-4.12.0.ebuild
index ce7653af22d9..b9db1386e4aa 100644
--- a/dev-db/monetdb/monetdb-4.12.0.ebuild
+++ b/dev-db/monetdb/monetdb-4.12.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/monetdb/monetdb-4.12.0.ebuild,v 1.1 2006/06/23 19:40:07 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/monetdb/monetdb-4.12.0.ebuild,v 1.2 2006/09/20 08:17:11 grobian Exp $
inherit flag-o-matic eutils
@@ -68,21 +68,19 @@ src_compile() {
# The tar has capitals, the ebuild doesn't...
cd "${WORKDIR}/MonetDB-${PV_M}"
- local myconf=""
+ # setting these respects the user's CFLAGS and disables -Werror etc.
+ local myconf="--disable-optimize --disable-debug"
+ sed -i \
+ -e 's|CFLAGS="\$CFLAGS \\\$(X_CFLAGS)"||' \
+ configure || die "failed fixing configure"
# Gentoo's amd64 doesn't allow 32-bits monetdb to compile, hence we switch
# to 64-bits Mserver here. Note that this also gives 64-bits OIDs.
use amd64 && myconf="${myconf} --enable-bits=64"
- if use debug;
- then
- myconf="${myconf} --disable-optimize --enable-assert --enable-debug"
- else
- myconf="${myconf} --enable-optimize --disable-assert --disable-debug"
- fi
-
myconf="${myconf} $(use_with java)"
myconf="${myconf} $(use_with readline)"
+ myconf="${myconf} $(use_enable debug assert)"
econf ${myconf} || die "econf monetdb failed"