summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2015-03-06 05:03:55 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2015-03-06 05:03:55 +0000
commitc26d120c41105d087f65bd780059aef0f024d313 (patch)
treecb847040aa4e9232aa1b19236f846cdd5c122595 /dev-cpp
parentAdd multilib support. (diff)
downloadgentoo-2-c26d120c41105d087f65bd780059aef0f024d313.tar.gz
gentoo-2-c26d120c41105d087f65bd780059aef0f024d313.tar.bz2
gentoo-2-c26d120c41105d087f65bd780059aef0f024d313.zip
Add multilib support, update license, install docs where other *mm packages expect them (bug #443950)
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x18E5B6F2D8D5EC8D)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/cairomm/ChangeLog11
-rw-r--r--dev-cpp/cairomm/cairomm-1.10.0-r1.ebuild56
-rw-r--r--dev-cpp/cairomm/cairomm-1.10.0.ebuild6
3 files changed, 68 insertions, 5 deletions
diff --git a/dev-cpp/cairomm/ChangeLog b/dev-cpp/cairomm/ChangeLog
index 2a23cd4a68a0..4cfd8575d85a 100644
--- a/dev-cpp/cairomm/ChangeLog
+++ b/dev-cpp/cairomm/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-cpp/cairomm
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/cairomm/ChangeLog,v 1.63 2013/09/29 11:05:31 pacho Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/cairomm/ChangeLog,v 1.64 2015/03/06 05:03:55 tetromino Exp $
+
+*cairomm-1.10.0-r1 (06 Mar 2015)
+
+ 06 Mar 2015; Alexandre Rostovtsev <tetromino@gentoo.org>
+ cairomm-1.10.0.ebuild, +cairomm-1.10.0-r1.ebuild:
+ Add multilib support, update license, install docs where other *mm packages
+ expect them (bug #443950)
29 Sep 2013; Pacho Ramos <pacho@gentoo.org> cairomm-1.10.0.ebuild:
Fix docs installation patch, #443950 by Chris Mayo
diff --git a/dev-cpp/cairomm/cairomm-1.10.0-r1.ebuild b/dev-cpp/cairomm/cairomm-1.10.0-r1.ebuild
new file mode 100644
index 000000000000..8fd23327e477
--- /dev/null
+++ b/dev-cpp/cairomm/cairomm-1.10.0-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/cairomm/cairomm-1.10.0-r1.ebuild,v 1.1 2015/03/06 05:03:55 tetromino Exp $
+
+EAPI=5
+GCONF_DEBUG="no"
+
+inherit eutils gnome2 multilib-minimal
+
+DESCRIPTION="C++ bindings for the Cairo vector graphics library"
+HOMEPAGE="http://cairographics.org/cairomm"
+SRC_URI="http://cairographics.org/releases/${P}.tar.gz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="doc +svg"
+
+# FIXME: svg support is automagic
+COMMON_DEPEND="
+ >=x11-libs/cairo-1.12.10[svg?,${MULTILIB_USEDEP}]
+ >=dev-libs/libsigc++-2.3.2:2[${MULTILIB_USEDEP}]
+"
+RDEPEND="${COMMON_DEPEND}
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-gtkmmlibs-20140508
+ !app-emulation/emul-linux-x86-gtkmmlibs[-abi_x86_32(-)] )
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen
+ dev-libs/libxslt
+ media-gfx/graphviz )
+"
+
+src_prepare() {
+ # don't waste time building examples because they are marked as "noinst"
+ sed -i 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' Makefile.in || die
+
+ # don't waste time building tests
+ # they require the boost Unit Testing framework, that's not in base boost
+ sed -i 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' Makefile.in || die
+
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" gnome2_src_configure \
+ --disable-tests \
+ $(multilib_native_use_enable doc documentation)
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
diff --git a/dev-cpp/cairomm/cairomm-1.10.0.ebuild b/dev-cpp/cairomm/cairomm-1.10.0.ebuild
index 7db9ef924522..1a5c841dee44 100644
--- a/dev-cpp/cairomm/cairomm-1.10.0.ebuild
+++ b/dev-cpp/cairomm/cairomm-1.10.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/cairomm/cairomm-1.10.0.ebuild,v 1.9 2013/09/29 11:05:31 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/cairomm/cairomm-1.10.0.ebuild,v 1.10 2015/03/06 05:03:55 tetromino Exp $
EAPI=5
GCONF_DEBUG="no"
@@ -11,7 +11,7 @@ DESCRIPTION="C++ bindings for the Cairo vector graphics library"
HOMEPAGE="http://cairographics.org/cairomm"
SRC_URI="http://cairographics.org/releases/${P}.tar.gz"
-LICENSE="LGPL-2"
+LICENSE="LGPL-2+"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
IUSE="doc +svg"