summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2012-07-08 19:56:24 +0000
committerNaohiro Aota <naota@gentoo.org>2012-07-08 19:56:24 +0000
commit53f7a8f6bf347492815f98dd08110e7fe97e819b (patch)
treeebca6dd7d16c9c54851824552588006a6fc1d3fd /dev-cpp
parentDowngrade netkit-tftp masking to non-removal. (diff)
downloadgentoo-2-53f7a8f6bf347492815f98dd08110e7fe97e819b.tar.gz
gentoo-2-53f7a8f6bf347492815f98dd08110e7fe97e819b.tar.bz2
gentoo-2-53f7a8f6bf347492815f98dd08110e7fe97e819b.zip
Add upstream patch to build on gcc-4.7. #422761
(Portage version: 2.2.0_alpha114/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/pficommon/ChangeLog9
-rw-r--r--dev-cpp/pficommon/files/pficommon-1.3.1.0-gcc-4.7.patch50
-rw-r--r--dev-cpp/pficommon/pficommon-1.3.1.0.ebuild7
3 files changed, 60 insertions, 6 deletions
diff --git a/dev-cpp/pficommon/ChangeLog b/dev-cpp/pficommon/ChangeLog
index 73eac1ddb2c2..a1b246b934fd 100644
--- a/dev-cpp/pficommon/ChangeLog
+++ b/dev-cpp/pficommon/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-cpp/pficommon
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/pficommon/ChangeLog,v 1.1 2011/11/12 23:55:49 naota Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/pficommon/ChangeLog,v 1.2 2012/07/08 19:56:24 naota Exp $
+
+ 08 Jul 2012; Naohiro Aota <naota@gentoo.org>
+ +files/pficommon-1.3.1.0-gcc-4.7.patch, pficommon-1.3.1.0.ebuild:
+ Add upstream patch to build on gcc-4.7. #422761
*pficommon-1.3.1.0 (12 Nov 2011)
@@ -9,4 +13,3 @@
+files/pficommon-1.3.1.0-postgresql.patch,
+files/pficommon-1.3.1.0-soname.patch, +metadata.xml:
New package dev-cpp/pficommon. ebuild written by me.
-
diff --git a/dev-cpp/pficommon/files/pficommon-1.3.1.0-gcc-4.7.patch b/dev-cpp/pficommon/files/pficommon-1.3.1.0-gcc-4.7.patch
new file mode 100644
index 000000000000..283ef2d7da90
--- /dev/null
+++ b/dev-cpp/pficommon/files/pficommon-1.3.1.0-gcc-4.7.patch
@@ -0,0 +1,50 @@
+From 5669e7ea665323ee774eda9c77206102fa499453 Mon Sep 17 00:00:00 2001
+From: Hideyuki Tanaka <tanaka.hideyuki@gmail.com>
+Date: Mon, 21 May 2012 17:21:34 +0900
+Subject: [PATCH] add include <unistd.h> (for gcc-4.7.0)
+
+---
+ src/network/socket.cpp | 1 +
+ src/system/mmapper.cpp | 1 +
+ tools/genrpc/main.cpp | 1 +
+ 3 files changed, 3 insertions(+)
+
+diff --git a/src/network/socket.cpp b/src/network/socket.cpp
+index b5c50e4..1fba6e6 100644
+--- a/src/network/socket.cpp
++++ b/src/network/socket.cpp
+@@ -40,6 +40,7 @@
+ #include <netinet/in.h>
+ #include <netinet/tcp.h>
+ #include <arpa/inet.h>
++#include <unistd.h>
+
+ #include "dns.h"
+ #include "../system/syscall.h"
+diff --git a/src/system/mmapper.cpp b/src/system/mmapper.cpp
+index 90eb7b8..e963fd8 100644
+--- a/src/system/mmapper.cpp
++++ b/src/system/mmapper.cpp
+@@ -35,6 +35,7 @@
+ #include <sys/stat.h>
+ #include <fcntl.h>
+ #include <sys/mman.h>
++#include <unistd.h>
+
+ #include "syscall.h"
+
+diff --git a/tools/genrpc/main.cpp b/tools/genrpc/main.cpp
+index 100ea4e..3e5ef16 100644
+--- a/tools/genrpc/main.cpp
++++ b/tools/genrpc/main.cpp
+@@ -4,6 +4,7 @@
+ #include <cctype>
+ #include <cstring>
+ #include <cstdio>
++#include <unistd.h>
+ using namespace std;
+
+ #include "../../src/lang/shared_ptr.h"
+--
+1.7.10
+
diff --git a/dev-cpp/pficommon/pficommon-1.3.1.0.ebuild b/dev-cpp/pficommon/pficommon-1.3.1.0.ebuild
index d7f74377b5db..f63e5c2d02a8 100644
--- a/dev-cpp/pficommon/pficommon-1.3.1.0.ebuild
+++ b/dev-cpp/pficommon/pficommon-1.3.1.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/pficommon/pficommon-1.3.1.0.ebuild,v 1.1 2011/11/12 23:55:49 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/pficommon/pficommon-1.3.1.0.ebuild,v 1.2 2012/07/08 19:56:24 naota Exp $
EAPI=4
@@ -36,7 +36,8 @@ src_unpack() {
src_prepare() {
epatch "${FILESDIR}"/${P}-libdir.patch \
"${FILESDIR}"/${P}-soname.patch \
- "${FILESDIR}"/${P}-postgresql.patch
+ "${FILESDIR}"/${P}-postgresql.patch \
+ "${FILESDIR}"/${P}-gcc-4.7.patch
}
src_configure() {