summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-07-02 14:58:54 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-07-02 14:58:54 +0000
commit72b4e8bedd8ed45a9e315acd5b9b732d630bdb7b (patch)
tree08af870b2915ba72d1ecc660eb2c11663eaefee0 /dev-cpp/asio/asio-1.4.5.ebuild
parentold, none of which doesn't compile with gcc44 (diff)
downloadgentoo-2-72b4e8bedd8ed45a9e315acd5b9b732d630bdb7b.tar.gz
gentoo-2-72b4e8bedd8ed45a9e315acd5b9b732d630bdb7b.tar.bz2
gentoo-2-72b4e8bedd8ed45a9e315acd5b9b732d630bdb7b.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp/asio/asio-1.4.5.ebuild')
-rw-r--r--dev-cpp/asio/asio-1.4.5.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-cpp/asio/asio-1.4.5.ebuild b/dev-cpp/asio/asio-1.4.5.ebuild
new file mode 100644
index 000000000000..da448f0bea45
--- /dev/null
+++ b/dev-cpp/asio/asio-1.4.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/asio/asio-1.4.5.ebuild,v 1.1 2010/07/02 14:58:54 ssuominen Exp $
+
+EAPI=2
+
+DESCRIPTION="Asynchronous Network Library"
+HOMEPAGE="http://asio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~sparc ~x86"
+IUSE="doc examples ssl test"
+
+DEPEND="ssl? ( dev-libs/openssl )
+ >=dev-libs/boost-1.35.0"
+
+src_prepare() {
+ if ! use test; then
+ # Don't build nor install any examples or unittests
+ # since we don't have a script to run them
+ cat > src/Makefile.in <<-EOF
+all:
+
+install:
+ EOF
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc README
+
+ if use doc; then
+ dohtml -r doc/*
+ fi
+
+ if use examples; then
+ if use test; then
+ # Get rid of the object files
+ emake clean || die
+ fi
+ insinto /usr/share/doc/${PF}
+ doins -r src/examples
+ fi
+}