summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2008-05-20 09:32:07 +0000
committerGeorge Shapovalov <george@gentoo.org>2008-05-20 09:32:07 +0000
commit6f9076bacbaf1af46ff0a43aedbfedd433cf2480 (patch)
treef6b4c3d01833309e72501e2e0a4e850eeb0ba8f6 /dev-ada
parentRestore USE jack. (diff)
downloadgentoo-2-6f9076bacbaf1af46ff0a43aedbfedd433cf2480.tar.gz
gentoo-2-6f9076bacbaf1af46ff0a43aedbfedd433cf2480.tar.bz2
gentoo-2-6f9076bacbaf1af46ff0a43aedbfedd433cf2480.zip
added qtada - Ada bindings to qt
(Portage version: 2.1.5)
Diffstat (limited to 'dev-ada')
-rw-r--r--dev-ada/qtada/ChangeLog10
-rw-r--r--dev-ada/qtada/Manifest4
-rw-r--r--dev-ada/qtada/metadata.xml6
-rw-r--r--dev-ada/qtada/qtada-1.0.3.ebuild85
4 files changed, 105 insertions, 0 deletions
diff --git a/dev-ada/qtada/ChangeLog b/dev-ada/qtada/ChangeLog
new file mode 100644
index 000000000000..5b1de8a9db44
--- /dev/null
+++ b/dev-ada/qtada/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ada/qtada
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ada/qtada/ChangeLog,v 1.1 2008/05/20 09:32:07 george Exp $
+
+*qtada-1.0.3 (20 May 2008)
+
+ 20 May 2008; George Shapovalov <george@gentoo.org> +qtada-1.0.3.ebuild:
+ added qtada - Ada bindings to qt. Thanks to Maxim Reznik for some input at
+ early stages (bug #143226).
+
diff --git a/dev-ada/qtada/Manifest b/dev-ada/qtada/Manifest
new file mode 100644
index 000000000000..b4e645d80c40
--- /dev/null
+++ b/dev-ada/qtada/Manifest
@@ -0,0 +1,4 @@
+DIST qtada-gpl-1.0.3.tar.gz 1618503 RMD160 01999348a0adae324f9102ed25cdc15172c7211d SHA1 8a5cde5bc74c1526456daadc279c988458c468df SHA256 01f283b388d050415dcad773b91e6486e4f376e87c70f1fd28e9a388d682060e
+EBUILD qtada-1.0.3.ebuild 2691 RMD160 ad1f73c89e8270626c9e5c8314710e03870e8639 SHA1 5289c02fc03b78fcca776f89cee9282db70b4efc SHA256 aba08e1dad2ad7d34dd5097c5972168d514cbac6a58011f4e776cae0645dac1c
+MISC ChangeLog 325 RMD160 330317a9bd275a0ef10e364118637471e086ba48 SHA1 5fe111c875fe26c95cb6c76073e2280dd631b0d1 SHA256 a2abd388d430c099451f12d8180640c3528b65f2f56ad612ffd4de1de2b8986b
+MISC metadata.xml 938 RMD160 d56fe21a5d0e3476dea7db8c325618f6ec007502 SHA1 47efe6a2dbcf0f11b04f1bd9d144e018ace7579d SHA256 2f009a0f62b8fc89cc7188d5bedfcd8cea774d70456f69454ad2ec6cd544a377
diff --git a/dev-ada/qtada/metadata.xml b/dev-ada/qtada/metadata.xml
new file mode 100644
index 000000000000..66f2f1fc397f
--- /dev/null
+++ b/dev-ada/qtada/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ada</herd>
+<longdescription>XML/Ada includes a complete XML parser that fully supports the XML 1.0 specifications, including DTDs, entity resolution, external entities,attribute normalization, and conditional sections. XML/Ada also supports the SAX 2.0 standard. Through an object-oriented Ada interface, the XML/Ada SAX implementation provides an extremely efficient way to convert XML streams to application-specific data representations. XML/Ada includes full support for the core part of DOM 2.0. In addition to this XML support, XML/Ada includes an extensive set of packages to read, manipulate and write Unicode streams, in various encodings like UTF-8, UTF-16 and UTF-32. It provides a conversion mechanism between Unicode and encodings such as Latin-1, Latin-2, etc.</longdescription>
+</pkgmetadata>
diff --git a/dev-ada/qtada/qtada-1.0.3.ebuild b/dev-ada/qtada/qtada-1.0.3.ebuild
new file mode 100644
index 000000000000..57f58b512a62
--- /dev/null
+++ b/dev-ada/qtada/qtada-1.0.3.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ada/qtada/qtada-1.0.3.ebuild,v 1.1 2008/05/20 09:32:07 george Exp $
+
+# We only need gnat.eclass for a few vars and helper functions.
+# We will not use src_* functions though.
+inherit eutils multilib gnat
+
+IUSE=""
+
+DESCRIPTION="Ada bindings for Qt library"
+HOMEPAGE="http://www.qtada.com/"
+SRC_URI="mirror://sourceforge/qtada/${PN}-gpl-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+# qtada is quite picky atm. For example this version will only compile with
+# the specified gnat, not even gnat-gcc-4.3.0 for example.
+RDEPEND="=dev-lang/gnat-gpl-4.1*
+ dev-ada/asis-gpl
+ >=x11-libs/qt-4.2.0"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}-gpl-${PV}"
+
+#LIBDIR=/usr/lib/ada/i686-pc-linux-gnu-gnat-gpl-4.1/qtada
+
+pkg_setup() {
+ local ActiveGnat=$(get_active_profile)
+ if [[ ! ${ActiveGnat} =~ "gnat-gpl-4.1" ]]; then
+ ewarn "This version of qtada can only be compiled with gnat-gpl-4.1"
+ die "Please switch to gnat-gpl-4.1 and try again"
+ fi
+ if ! built_with_use ">=x11-libs/qt-4.0" accessibility ; then
+ die "Rebuild qt-4 with USE=accessibility"
+ fi
+}
+
+
+# As this version of qtada only compiles with gnat-gpl-4.1 and we already
+# verified that it is active, we do not switch profiles or do any majic here.
+# We simplt run build once, just need to set some path appropriately.
+src_compile() {
+ econf --datadir=${AdalibDataDir}/${PN} \
+ --includedir=${AdalibSpecsDir}/${PN} \
+ --libdir=${AdalibLibTop}/$(get_active_profile)/${PN} || die "econf failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ # set common part of the path
+ local InstTop=${AdalibLibTop}/$(get_active_profile)
+
+ # run upstream setup
+ einstall \
+ libdir=${D}/${InstTop}/${PN} \
+ bindir=${D}/${InstTop}/bin \
+ includedir=${D}/${AdalibSpecsDir} || die "install failed"
+
+ # move .ali file together with .so's
+ mv "${D}"/${InstTop}/${PN}/${PN}/*.ali "${D}"/${InstTop}/${PN}/
+ rmdir "${D}"/${InstTop}/${PN}/${PN}/
+
+ # arrange and fix gpr files
+ mv "${D}"/${InstTop}/${PN}/gnat "${D}"/${InstTop}/gpr
+ sed -i -e "s:/usr/include:${AdalibSpecsDir}:" \
+ -e "s:/usr/lib:${InstTop}/${PN}:" \
+ -e "s:${PN}/${PN}:${PN}" "${D}"/${InstTop}/gpr/*.gpr
+
+ # Create an environment file
+ local SpecFile="${D}/usr/share/gnat/eselect/${PN}/$(get_active_profile)"
+ dodir /usr/share/gnat/eselect/${PN}/
+ echo "PATH=${InstTop}/bin" > "${SpecFile}"
+ echo "ADA_INCLUDE_PATH=${AdalibSpecsDir}/${PN}/core" >> "${SpecFile}"
+ echo "ADA_OBJECTS_PATH=${InstTop}/${PN}" >> "${SpecFile}"
+ echo "ADA_PROJECT_PATH=${InstTop}/gpr" >> "${SpecFile}"
+
+ # install docs
+ dodoc AUTHORS NEWS README
+ mv "${D}"/usr/examples/${PN} "${D}"/usr/share/doc/${PF}/examples
+ rmdir "${D}"/usr/examples/
+}