summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-09-20 14:12:28 +0000
committerAli Polatel <hawking@gentoo.org>2008-09-20 14:12:28 +0000
commit4d9997665ce8b8f7115eeb24e30e5e1e91deb777 (patch)
tree2433452aaeab3e05e28c09c11d88f8bcbd40c46a /app-vim/cream
parentVersion bump. Quoting. (diff)
downloadgentoo-2-4d9997665ce8b8f7115eeb24e30e5e1e91deb777.tar.gz
gentoo-2-4d9997665ce8b8f7115eeb24e30e5e1e91deb777.tar.bz2
gentoo-2-4d9997665ce8b8f7115eeb24e30e5e1e91deb777.zip
Version bump. Quoting. Drop old.
(Portage version: -svn/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'app-vim/cream')
-rw-r--r--app-vim/cream/ChangeLog10
-rw-r--r--app-vim/cream/cream-0.32.ebuild18
-rw-r--r--app-vim/cream/cream-0.34.ebuild18
-rw-r--r--app-vim/cream/cream-0.41.ebuild (renamed from app-vim/cream/cream-0.36.ebuild)24
4 files changed, 37 insertions, 33 deletions
diff --git a/app-vim/cream/ChangeLog b/app-vim/cream/ChangeLog
index 5d9b89bde8b8..48fdf81ba9f1 100644
--- a/app-vim/cream/ChangeLog
+++ b/app-vim/cream/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-vim/cream
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/cream/ChangeLog,v 1.39 2007/04/18 20:20:07 gustavoz Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/cream/ChangeLog,v 1.40 2008/09/20 14:12:28 hawking Exp $
+
+*cream-0.41 (20 Sep 2008)
+
+ 20 Sep 2008; Ali Polatel <hawking@gentoo.org> cream-0.32.ebuild,
+ cream-0.34.ebuild, -cream-0.36.ebuild, +cream-0.41.ebuild:
+ Version bump. Quoting. Drop old.
18 Apr 2007; Gustavo Zacarias <gustavoz@gentoo.org> cream-0.34.ebuild:
Stable on sparc
diff --git a/app-vim/cream/cream-0.32.ebuild b/app-vim/cream/cream-0.32.ebuild
index 85f64dc1190f..a5cd8657dc41 100644
--- a/app-vim/cream/cream-0.32.ebuild
+++ b/app-vim/cream/cream-0.32.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/cream/cream-0.32.ebuild,v 1.12 2007/07/11 05:14:08 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/cream/cream-0.32.ebuild,v 1.13 2008/09/20 14:12:28 hawking Exp $
inherit vim-plugin eutils
@@ -45,22 +45,22 @@ file://${ROOT}usr/share/doc/${PF}/html/keyboardshortcuts.html
file://${ROOT}usr/share/doc/${PF}/html/faq.html"
src_unpack() {
- mkdir -p ${S}/spelldicts
+ mkdir -p "${S}"/spelldicts
# install spell dictionaries into ${S}/spelldicts
local my_a
for my_a in ${A} ; do
if [ -z ${my_a/*spell-dict*/} ] ; then
- cd ${S}/spelldicts
+ cd "${S}"/spelldicts
unpack ${my_a}
else
- cd ${WORKDIR}
+ cd "${WORKDIR}"
unpack ${my_a}
fi
done
# change installation path + fix the wrapper command (disable plugins)
- cd ${S}
+ cd "${S}"
cat >cream <<EOF
#!/bin/sh
gvim --noplugin -U NONE -u "\\\$VIM/cream/creamrc" "\$@"
@@ -68,7 +68,7 @@ EOF
sed -i "/let \$CREAM/s:VIMRUNTIME:VIM:" creamrc || die "sed #1 broke"
# make taglist ebuild aware, bug #66052
- epatch ${FILESDIR}/${PN}-0.30-ebuilds.patch
+ epatch "${FILESDIR}"/${PN}-0.30-ebuilds.patch
}
src_install() {
@@ -84,10 +84,10 @@ src_install() {
doins *.vim creamrc
local dir
for dir in addons bitmaps spelldicts filetypes ; do
- cp -R ${dir} ${D}/usr/share/vim/cream
+ cp -R ${dir} "${D}"/usr/share/vim/cream
done
dodir /usr/share/vim/vimfiles
- cp -R help ${D}/usr/share/vim/vimfiles/doc
+ cp -R help "${D}"/usr/share/vim/vimfiles/doc
# install docs
dodoc docs/*
diff --git a/app-vim/cream/cream-0.34.ebuild b/app-vim/cream/cream-0.34.ebuild
index 1bfbecc0fc2e..6d8ca15a5a72 100644
--- a/app-vim/cream/cream-0.34.ebuild
+++ b/app-vim/cream/cream-0.34.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/cream/cream-0.34.ebuild,v 1.10 2007/05/16 10:58:12 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/cream/cream-0.34.ebuild,v 1.11 2008/09/20 14:12:28 hawking Exp $
inherit vim-plugin eutils fdo-mime
@@ -62,22 +62,22 @@ prefix_help_file() {
}
src_unpack() {
- mkdir -p ${S}/spelldicts
+ mkdir -p "${S}"/spelldicts
# install spell dictionaries into ${S}/spelldicts
local my_a
for my_a in ${A} ; do
if [ -z ${my_a/*spell-dict*/} ] ; then
- cd ${S}/spelldicts
+ cd "${S}"/spelldicts
unpack ${my_a}
else
- cd ${WORKDIR}
+ cd "${WORKDIR}"
unpack ${my_a}
fi
done
# change installation path + fix the wrapper command (disable plugins)
- cd ${S}
+ cd "${S}"
cat >cream <<EOF
#!/bin/sh
gvim --noplugin -U NONE -u "\\\$VIM/cream/creamrc" "\$@"
@@ -85,11 +85,11 @@ EOF
sed -i "/let \$CREAM/s:VIMRUNTIME:VIM:" creamrc || die "sed #1 broke"
# make taglist ebuild aware, bug #66052
- epatch ${FILESDIR}/${PN}-0.30-ebuilds.patch
+ epatch "${FILESDIR}"/${PN}-0.30-ebuilds.patch
# more filetypes for EnhancedCommentify, including the Gentoo ones
- epatch ${FILESDIR}/enhancedcommentify-2.1-gentooisms.patch
- epatch ${FILESDIR}/enhancedcommentify-2.1-extra-ft-support.patch
+ epatch "${FILESDIR}"/enhancedcommentify-2.1-gentooisms.patch
+ epatch "${FILESDIR}"/enhancedcommentify-2.1-extra-ft-support.patch
# rename vim help files to avoid conflicts with other vim packages
prefix_help_file cream help/EnhancedCommentify.txt \
diff --git a/app-vim/cream/cream-0.36.ebuild b/app-vim/cream/cream-0.41.ebuild
index a96b62d788fa..399eb981d8d4 100644
--- a/app-vim/cream/cream-0.36.ebuild
+++ b/app-vim/cream/cream-0.41.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/cream/cream-0.36.ebuild,v 1.3 2007/05/16 10:58:12 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/cream/cream-0.41.ebuild,v 1.1 2008/09/20 14:12:28 hawking Exp $
inherit vim-plugin eutils fdo-mime
@@ -24,10 +24,10 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
DEPEND="
- >=app-editors/gvim-6.4
+ >=app-editors/gvim-7.0
app-arch/unzip"
RDEPEND="
- >=app-editors/gvim-6.4
+ >=app-editors/gvim-7.0
dev-util/ctags"
VIM_PLUGIN_HELPTEXT=\
@@ -62,22 +62,22 @@ prefix_help_file() {
}
src_unpack() {
- mkdir -p ${S}/spelldicts
+ mkdir -p "${S}"/spelldicts
# install spell dictionaries into ${S}/spelldicts
local my_a
for my_a in ${A} ; do
if [ -z ${my_a/*spell-dict*/} ] ; then
- cd ${S}/spelldicts
+ cd "${S}"/spelldicts
unpack ${my_a}
else
- cd ${WORKDIR}
+ cd "${WORKDIR}"
unpack ${my_a}
fi
done
# change installation path + fix the wrapper command (disable plugins)
- cd ${S}
+ cd "${S}"
cat >cream <<EOF
#!/bin/sh
gvim --noplugin -U NONE -u "\\\$VIM/cream/creamrc" "\$@"
@@ -85,17 +85,15 @@ EOF
sed -i "/let \$CREAM/s:VIMRUNTIME:VIM:" creamrc || die "sed #1 broke"
# make taglist ebuild aware, bug #66052
- epatch ${FILESDIR}/${PN}-0.30-ebuilds.patch
+ epatch "${FILESDIR}"/${PN}-0.30-ebuilds.patch
# more filetypes for EnhancedCommentify, including the Gentoo ones
- epatch ${FILESDIR}/enhancedcommentify-2.1-gentooisms.patch
- epatch ${FILESDIR}/enhancedcommentify-2.1-extra-ft-support.patch
+ epatch "${FILESDIR}"/enhancedcommentify-2.1-gentooisms.patch
+ epatch "${FILESDIR}"/enhancedcommentify-2.1-extra-ft-support.patch
# rename vim help files to avoid conflicts with other vim packages
prefix_help_file cream help/EnhancedCommentify.txt \
'EnhancedCommentify' 'EnhComm-[a-zA-Z]\+'
- prefix_help_file cream help/opsplorer.txt \
- 'opsplorer\.txt' 'opsplorer_[a-z_]\+'
}
src_install() {