summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-09-22 21:52:35 +0000
committerTim Harder <radhermit@gentoo.org>2011-09-22 21:52:35 +0000
commit37987795667749fa6afbc18b82e4b9f830096f9c (patch)
tree2c2ae2808ec0fa8163f26405b1052b8c096537a2 /app-vim/cream/cream-0.43.ebuild
parentAdded missing soprano dependency, bug 382245 (diff)
downloadgentoo-2-37987795667749fa6afbc18b82e4b9f830096f9c.tar.gz
gentoo-2-37987795667749fa6afbc18b82e4b9f830096f9c.tar.bz2
gentoo-2-37987795667749fa6afbc18b82e4b9f830096f9c.zip
Update to EAPI 4.
(Portage version: 2.2.0_alpha58/cvs/Linux x86_64)
Diffstat (limited to 'app-vim/cream/cream-0.43.ebuild')
-rw-r--r--app-vim/cream/cream-0.43.ebuild58
1 files changed, 30 insertions, 28 deletions
diff --git a/app-vim/cream/cream-0.43.ebuild b/app-vim/cream/cream-0.43.ebuild
index cc683ca31979..f1e760155aba 100644
--- a/app-vim/cream/cream-0.43.ebuild
+++ b/app-vim/cream/cream-0.43.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/cream/cream-0.43.ebuild,v 1.2 2011/09/22 21:34:47 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/cream/cream-0.43.ebuild,v 1.3 2011/09/22 21:52:35 radhermit Exp $
+
+EAPI=4
inherit vim-plugin eutils fdo-mime
@@ -61,6 +63,25 @@ prefix_help_file() {
|| die "Failed to rename \"${helpfile}\""
}
+pkg_setup() {
+ elog "Cream comes with several dictionaries for spell checking. In"
+ elog "all cases, at least a small English dictionary will be installed."
+ elog
+ elog "To specify which optional dictionaries are installed, set the"
+ elog "LINGUAS variable in /etc/make.conf. For example, to install full"
+ elog "English and French dictionaries, use:"
+ elog " LINGUAS=\"en fr\""
+ elog
+ elog "Available dictionaries are:"
+ for dict in "English en" "French fr" "German de" "Spanish es" ; do
+ # portage bug: shouldn't get a QA notice for linguas stuff...
+ elog " ${dict% *} \t(${dict#* }) $( ( \
+ use linguas_${dict#* } &>/dev/null && \
+ echo '(Will be installed)' ) || echo '(Will not be installed)' )"
+ done
+ elog
+}
+
src_unpack() {
mkdir -p "${S}"/spelldicts
@@ -75,14 +96,16 @@ src_unpack() {
unpack ${my_a}
fi
done
+}
+src_prepare() {
# change installation path + fix the wrapper command (disable plugins)
- cd "${S}"
- cat >cream <<EOF
-#!/bin/sh
-gvim --servername CREAM --noplugin -U NONE -u "\\\$VIM/cream/creamrc" "\$@"
-EOF
- sed -i "/let \$CREAM/s:VIMRUNTIME:VIM:" creamrc || die "sed #1 broke"
+ cat > cream <<-EOF
+ #!/bin/sh
+ gvim --servername CREAM --noplugin -U NONE -u "\\\$VIM/cream/creamrc" "\$@"
+ EOF
+
+ sed -i "/let \$CREAM/s:VIMRUNTIME:VIM:" creamrc || die
# make taglist ebuild aware, bug #66052
epatch "${FILESDIR}"/${PN}-0.30-ebuilds.patch
@@ -127,27 +150,6 @@ src_install() {
dosym ../../doc/${PF}/html /usr/share/vim/cream/docs-html
}
-pkg_setup() {
- elog "Cream comes with several dictionaries for spell checking. In"
- elog "all cases, at least a small English dictionary will be installed."
- elog
- elog "To specify which optional dictionaries are installed, set the"
- elog "LINGUAS variable in /etc/make.conf. For example, to install full"
- elog "English and French dictionaries, use:"
- elog " LINGUAS=\"en fr\""
- elog
- elog "Available dictionaries are:"
- for dict in "English en" "French fr" "German de" "Spanish es" ; do
- # portage bug: shouldn't get a QA notice for linguas stuff...
- elog " ${dict% *} \t(${dict#* }) $( ( \
- use linguas_${dict#* } &>/dev/null && \
- echo '(Will be installed)' ) || echo '(Will not be installed)' )"
- done
- elog
- # give the user time to cancel if necessary
- epause
-}
-
pkg_postinst() {
fdo-mime_desktop_database_update
vim-plugin_pkg_postinst