summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-07 09:02:38 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-07 09:02:38 +0000
commit7e140020206c2c4c5b03df86435dec0366cd3c07 (patch)
tree70f982369a1c29ea4dca256435ab6698edaaeb9a /app-text
parentVersion bump. Fix building with GCC 4.4+ and GLIBC 2.10+ wrt #277315. (diff)
downloadgentoo-2-7e140020206c2c4c5b03df86435dec0366cd3c07.tar.gz
gentoo-2-7e140020206c2c4c5b03df86435dec0366cd3c07.tar.bz2
gentoo-2-7e140020206c2c4c5b03df86435dec0366cd3c07.zip
Fix building with GCC 4.4+ and GLIBC 2.10+ wrt #276847. Remove .desktop entry from invalid location. Remove invalid aRts depend.
(Portage version: 2.2_rc36/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/kbedic/ChangeLog8
-rw-r--r--app-text/kbedic/files/kbedic-3.1-gcc3.diff84
-rw-r--r--app-text/kbedic/files/kbedic-3.1-location.diff32
-rw-r--r--app-text/kbedic/files/kbedic-4.0-gcc44.patch21
-rw-r--r--app-text/kbedic/files/kbedic.desktop11
-rw-r--r--app-text/kbedic/kbedic-4.0.ebuild17
6 files changed, 34 insertions, 139 deletions
diff --git a/app-text/kbedic/ChangeLog b/app-text/kbedic/ChangeLog
index 19a5317b694d..7f08d98f9e01 100644
--- a/app-text/kbedic/ChangeLog
+++ b/app-text/kbedic/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/kbedic
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/kbedic/ChangeLog,v 1.22 2009/05/27 11:52:19 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/kbedic/ChangeLog,v 1.23 2009/08/07 09:02:38 ssuominen Exp $
+
+ 07 Aug 2009; Samuli Suominen <ssuominen@gentoo.org>
+ -files/kbedic-3.1-gcc3.diff, -files/kbedic-3.1-location.diff,
+ kbedic-4.0.ebuild, +files/kbedic-4.0-gcc44.patch, -files/kbedic.desktop:
+ Fix building with GCC 4.4+ and GLIBC 2.10+ wrt #276847. Remove .desktop
+ entry from invalid location. Remove invalid aRts depend.
27 May 2009; Theo Chatzimichos <tampakrap@gentoo.org> kbedic-4.0.ebuild:
Fix typo in deps, bug 213432
diff --git a/app-text/kbedic/files/kbedic-3.1-gcc3.diff b/app-text/kbedic/files/kbedic-3.1-gcc3.diff
deleted file mode 100644
index 281f30b1d80d..000000000000
--- a/app-text/kbedic/files/kbedic-3.1-gcc3.diff
+++ /dev/null
@@ -1,84 +0,0 @@
---- src/registry.cpp Wed Aug 14 17:24:43 2002
-+++ src/registry.cpp Wed Sep 11 20:22:43 2002
-@@ -79,7 +79,7 @@
- //=== Get String =========================================================
- // Return the value of key, if missed return default value
- //========================================================================
--char *Registry::getString(const char *property, const char *defaultValue = "") {
-+char *Registry::getString(const char *property, const char *defaultValue) {
- bool found = false;
- char *ret = NULL;
- FILE *f;
-@@ -113,7 +113,7 @@
- //=== Get Int ============================================================
- // Return the value of key, if missed return default value
- //========================================================================
--int Registry::getInt(const char *property, const int defaultValue = 0) {
-+int Registry::getInt(const char *property, const int defaultValue) {
- int ret = defaultValue;
- char *p;
- p = getString(property);
-@@ -141,7 +141,7 @@
- //=== Get Bool ===========================================================
- // Return the value of key, if missed return default value
- //========================================================================
--bool Registry::getBool(const char *property, const bool defaultValue = false) {
-+bool Registry::getBool(const char *property, const bool defaultValue) {
- bool ret = defaultValue;
- char *p;
- p = getString(property);
---- src/database.cpp Wed Aug 14 17:24:43 2002
-+++ src/database.cpp Wed Sep 11 20:30:55 2002
-109c109
-< bool Database::createDictionary(const char *fileName, const long fixedLastWordPointer = 0) {
----
-> bool Database::createDictionary(const char *fileName, const long fixedLastWordPointer) {
---- src/translator.cpp Wed Aug 14 17:24:43 2002
-+++ src/translator.cpp Wed Sep 11 20:30:55 2002
-@@ -119,7 +119,7 @@
- // Real construcor
- // Call the same method of Database, and return same result
- //========================================================================
--bool Translator::createDictionary(const char *fileName, const int dictionary, const long fixedLastWordPointer = 0) {
-+bool Translator::createDictionary(const char *fileName, const int dictionary, const long fixedLastWordPointer) {
- bool ret = false;
- switch (dictionary) {
- case ENG_BUL:
-@@ -275,7 +275,7 @@
- // Return true if passed word is legal bulgarian word as LATIN_INPUT
- // Return pointer to new word that is legal dictionary word
- //========================================================================
--bool Translator::isLatinInput(const char *word, char *buf, const bool ignoreSpace = false) {
-+bool Translator::isLatinInput(const char *word, char *buf, const bool ignoreSpace) {
- int i = 0;
- char *p;
- while (word[i] != '\0') {
-@@ -304,7 +304,7 @@
- // to a normal latin output
- // Change buffer and return pointer to new word
- //========================================================================
--char *Translator::toLatin(const char *word, char *buf, const bool legalLatinInput = true) {
-+char *Translator::toLatin(const char *word, char *buf, const bool legalLatinInput) {
- int i = 0;
- int j = 0;
- char *p;
-@@ -348,7 +348,7 @@
- // Call the same method of Database, and return same result
- // But perform some operations
- //========================================================================
--char *Translator::getWord(const bool lowerCase = true, const bool legalLatinInput = true) {
-+char *Translator::getWord(const bool lowerCase, const bool legalLatinInput) {
- char *ret = NULL;
- switch (currentDictionary) {
- case ENG_BUL:
---- src/win.cpp Wed Aug 14 17:24:43 2002
-+++ src/win.cpp Wed Sep 11 21:27:21 2002
-@@ -214,7 +214,7 @@
- // Create GUI
- // Init objects and set default variables
- //========================================================================
--Win::Win(QWidget *parent = 0, const char *name = 0):QMainWindow(parent, name) {
-+Win::Win(QWidget *parent, const char *name):QMainWindow(parent, name) {
-
- // Init some variables
- fromSystemHighlighted = false;
diff --git a/app-text/kbedic/files/kbedic-3.1-location.diff b/app-text/kbedic/files/kbedic-3.1-location.diff
deleted file mode 100644
index 08c71f6298ff..000000000000
--- a/app-text/kbedic/files/kbedic-3.1-location.diff
+++ /dev/null
@@ -1,32 +0,0 @@
-diff -ur kbedic-3.1.orig/data/Makefile.in kbedic-3.1/data/Makefile.in
---- data/Makefile.in Wed Aug 14 17:24:36 2002
-+++ data/Makefile.in Wed Sep 11 22:00:11 2002
-@@ -115,12 +115,12 @@
- uninstall-info-am:
- install-dataDATA: $(data_DATA)
- @$(NORMAL_INSTALL)
-- $(mkinstalldirs) $(DESTDIR)$(datadir)
-+ $(mkinstalldirs) $(DESTDIR)$(pkgdatadir)
- @list='$(data_DATA)'; for p in $$list; do \
- if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
- f="`echo $$p | sed -e 's|^.*/||'`"; \
-- echo " $(INSTALL_DATA) $$d$$p $(DESTDIR)$(datadir)/$$f"; \
-- $(INSTALL_DATA) $$d$$p $(DESTDIR)$(datadir)/$$f; \
-+ echo " $(INSTALL_DATA) $$d$$p $(DESTDIR)$(pkgdatadir)/$$f"; \
-+ $(INSTALL_DATA) $$d$$p $(DESTDIR)$(pkgdatadir)/$$f; \
- done
-
- uninstall-dataDATA:
-diff -ur kbedic-3.1.orig/src/config.h.in kbedic-3.1/src/config.h.in
---- src/config.h.in Wed Aug 14 17:24:43 2002
-+++ src/config.h.in Wed Sep 11 22:00:24 2002
-@@ -8,7 +8,7 @@
-
-
- // Path to Database
--#define ENG_BUL_DAT_CONFIG "@DATA_DIR@/engbul.dat"
--#define BUL_ENG_DAT_CONFIG "@DATA_DIR@/buleng.dat"
-+#define ENG_BUL_DAT_CONFIG "@DATA_DIR@/kbedic/engbul.dat"
-+#define BUL_ENG_DAT_CONFIG "@DATA_DIR@/kbedic/buleng.dat"
-
- #endif
diff --git a/app-text/kbedic/files/kbedic-4.0-gcc44.patch b/app-text/kbedic/files/kbedic-4.0-gcc44.patch
new file mode 100644
index 000000000000..e81b375c0d01
--- /dev/null
+++ b/app-text/kbedic/files/kbedic-4.0-gcc44.patch
@@ -0,0 +1,21 @@
+diff -ur kbedic-4.0.orig/src/translator.cpp kbedic-4.0/src/translator.cpp
+--- kbedic-4.0.orig/src/translator.cpp 2003-06-30 14:48:17.000000000 +0300
++++ kbedic-4.0/src/translator.cpp 2009-08-07 12:00:02.000000000 +0300
+@@ -291,7 +291,7 @@
+ //========================================================================
+ bool Translator::isLatinInput(const char *word, char *buf, const bool ignoreSpace) {
+ int i = 0;
+- char *p;
++ const char *p;
+ while (word[i] != '\0') {
+ if ((ignoreSpace) && (word[i] == ' ')) {
+ buf[i] = word[i];
+@@ -321,7 +321,7 @@
+ char *Translator::toLatin(const char *word, char *buf, const bool legalLatinInput) {
+ int i = 0;
+ int j = 0;
+- char *p;
++ const char *p;
+ char c;
+ while ((c = word[i]) != '\0') {
+ if (legalLatinInput) {
diff --git a/app-text/kbedic/files/kbedic.desktop b/app-text/kbedic/files/kbedic.desktop
deleted file mode 100644
index cc3d2f6bd36a..000000000000
--- a/app-text/kbedic/files/kbedic.desktop
+++ /dev/null
@@ -1,11 +0,0 @@
-[KDE Desktop Entry]
-Encoding=UTF-8
-Type=Application
-Exec=kbedic
-Icon=/usr/share/kbedic/kbedic_icon_mini.xpm
-Name=KBEDic
-GenericName=English - Bulgarian Dictionary
-GenericName[bg]=Българско-Английски Речник
-Comment=An English - Bulgarian Dictionary
-Comment[bg]=Българско-Английски Речник
-Categories=Qt;KDE;Utility
diff --git a/app-text/kbedic/kbedic-4.0.ebuild b/app-text/kbedic/kbedic-4.0.ebuild
index bb11e5d95e81..37126c7f3c98 100644
--- a/app-text/kbedic/kbedic-4.0.ebuild
+++ b/app-text/kbedic/kbedic-4.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/kbedic/kbedic-4.0.ebuild,v 1.15 2009/05/27 11:52:19 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/kbedic/kbedic-4.0.ebuild,v 1.16 2009/08/07 09:02:38 ssuominen Exp $
+
+ARTS_REQUIRED="never"
inherit kde eutils
@@ -8,8 +10,8 @@ DESCRIPTION="English <-> Bulgarian Dictionary"
HOMEPAGE="http://kbedic.sourceforge.net"
SRC_URI="mirror://sourceforge/kbedic/$P.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="kde"
@@ -20,7 +22,8 @@ RDEPEND="${DEPEND}"
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}/kbedic-4.0-dont-filter-cflags.patch"
+ epatch "${FILESDIR}"/${P}-dont-filter-cflags.patch \
+ "${FILESDIR}"/${P}-gcc44.patch
eautoreconf
}
@@ -33,11 +36,3 @@ src_compile() {
use kde && kde_src_compile myconf
kde_src_compile configure make
}
-
-src_install() {
- kde_src_install
- if use kde; then
- insinto /usr/share/applnk/Utilities/kbedic.desktop
- doins "${FILESDIR}/kbedic.desktop"
- fi
-}