summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-12-13 22:31:09 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-12-13 22:31:09 +0000
commit7521730ef6ef35f6a41031660142c842444bb78b (patch)
tree25742942d780d48fbe7d6fc262203d87640dac4c /app-text
parentAdded ~mips, bug 276652 (diff)
downloadgentoo-2-7521730ef6ef35f6a41031660142c842444bb78b.tar.gz
gentoo-2-7521730ef6ef35f6a41031660142c842444bb78b.tar.bz2
gentoo-2-7521730ef6ef35f6a41031660142c842444bb78b.zip
Version bump. Drop old revision.
(Portage version: 2.2.0_alpha7/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/iso-codes/ChangeLog8
-rw-r--r--app-text/iso-codes/iso-codes-3.10.ebuild26
-rw-r--r--app-text/iso-codes/iso-codes-3.23.ebuild52
3 files changed, 59 insertions, 27 deletions
diff --git a/app-text/iso-codes/ChangeLog b/app-text/iso-codes/ChangeLog
index 0233e3e918d8..165607750160 100644
--- a/app-text/iso-codes/ChangeLog
+++ b/app-text/iso-codes/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/iso-codes
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/ChangeLog,v 1.96 2010/10/29 03:20:52 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/ChangeLog,v 1.97 2010/12/13 22:31:09 eva Exp $
+
+*iso-codes-3.23 (13 Dec 2010)
+
+ 13 Dec 2010; Gilles Dartiguelongue <eva@gentoo.org> -iso-codes-3.10.ebuild,
+ +iso-codes-3.23.ebuild:
+ Version bump. Drop old revision.
29 Oct 2010; Jeroen Roovers <jer@gentoo.org> iso-codes-3.19.ebuild:
Stable for HPPA (bug #339778).
diff --git a/app-text/iso-codes/iso-codes-3.10.ebuild b/app-text/iso-codes/iso-codes-3.10.ebuild
deleted file mode 100644
index a7517b1ef149..000000000000
--- a/app-text/iso-codes/iso-codes-3.10.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/iso-codes-3.10.ebuild,v 1.7 2009/12/10 15:46:17 jer Exp $
-
-EAPI="2"
-
-DESCRIPTION="Provides the list of country and language names"
-HOMEPAGE="http://alioth.debian.org/projects/pkg-isocodes/"
-SRC_URI="ftp://pkg-isocodes.alioth.debian.org/pub/pkg-isocodes/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sh sparc x86 ~x86-fbsd"
-IUSE=""
-
-RDEPEND=""
-DEPEND="sys-devel/gettext
- || (
- >=dev-lang/python-2.3[-build,xml]
- dev-python/pyxml )"
-
-src_install() {
- emake DESTDIR="${D}" install || die "Installation failed"
-
- dodoc ChangeLog README TODO
-}
diff --git a/app-text/iso-codes/iso-codes-3.23.ebuild b/app-text/iso-codes/iso-codes-3.23.ebuild
new file mode 100644
index 000000000000..ad2bef2949ed
--- /dev/null
+++ b/app-text/iso-codes/iso-codes-3.23.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/iso-codes-3.23.ebuild,v 1.1 2010/12/13 22:31:09 eva Exp $
+
+EAPI="3"
+
+inherit eutils
+
+DESCRIPTION="Provides the list of country and language names"
+HOMEPAGE="http://alioth.debian.org/projects/pkg-isocodes/"
+SRC_URI="ftp://pkg-isocodes.alioth.debian.org/pub/pkg-isocodes/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND="sys-devel/gettext"
+
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+
+src_prepare() {
+ local linguas_bak=${LINGUAS}
+ local mylinguas=""
+
+ for norm in iso_15924 iso_3166 iso_3166_2 iso_4217 iso_639 iso_639_3; do
+ einfo "Preparing ${norm}"
+
+ mylinguas=""
+ LINGUAS=${linguas_bak}
+ strip-linguas -i "${S}/${norm}"
+
+ for loc in ${LINGUAS}; do
+ mylinguas="${mylinguas} ${loc}.po"
+ done
+
+ if [ -n "${mylinguas}" ]; then
+ sed -e "s:pofiles =.*:pofiles = ${mylinguas}:" \
+ -e "s:mofiles =.*:mofiles = ${mylinguas//.po/.mo}:" \
+ -i "${S}/${norm}/Makefile.am" "${S}/${norm}/Makefile.in" \
+ || die "sed in ${norm} folder failed"
+ fi
+ done
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+
+ dodoc ChangeLog README TODO || die "dodoc failed"
+}