summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-12-01 12:24:32 +0000
committerJeroen Roovers <jer@gentoo.org>2014-12-01 12:24:32 +0000
commit65a5560ab857c352e2db48dfe8ac725897fc7af1 (patch)
treee9f8a1be2deb2d9e14ae01661d042c1205f71712 /app-text
parentRemove m-n tag as there are two herds already. Remove short <longdescription>. (diff)
downloadgentoo-2-65a5560ab857c352e2db48dfe8ac725897fc7af1.tar.gz
gentoo-2-65a5560ab857c352e2db48dfe8ac725897fc7af1.tar.bz2
gentoo-2-65a5560ab857c352e2db48dfe8ac725897fc7af1.zip
Try eautoreconf instead of autogen.sh.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/pinfo/ChangeLog7
-rw-r--r--app-text/pinfo/pinfo-0.6.10-r5.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/app-text/pinfo/ChangeLog b/app-text/pinfo/ChangeLog
index 097b771c08d5..6c523db95787 100644
--- a/app-text/pinfo/ChangeLog
+++ b/app-text/pinfo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/pinfo
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pinfo/ChangeLog,v 1.78 2014/06/08 23:21:34 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pinfo/ChangeLog,v 1.79 2014/12/01 12:24:32 jer Exp $
+
+*pinfo-0.6.10-r5 (01 Dec 2014)
+
+ 01 Dec 2014; Jeroen Roovers <jer@gentoo.org> +pinfo-0.6.10-r5.ebuild:
+ Try eautoreconf instead of autogen.sh.
08 Jun 2014; Jeroen Roovers <jer@gentoo.org> pinfo-0.6.10-r4.ebuild,
+files/pinfo-0.6.10-gettext-0.19.patch:
diff --git a/app-text/pinfo/pinfo-0.6.10-r5.ebuild b/app-text/pinfo/pinfo-0.6.10-r5.ebuild
new file mode 100644
index 000000000000..c773e4ab8407
--- /dev/null
+++ b/app-text/pinfo/pinfo-0.6.10-r5.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pinfo/pinfo-0.6.10-r5.ebuild,v 1.1 2014/12/01 12:24:32 jer Exp $
+
+EAPI=5
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="Hypertext info and man viewer based on (n)curses"
+HOMEPAGE="http://pinfo.alioth.debian.org/"
+SRC_URI="https://alioth.debian.org/frs/download.php/3351/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="nls readline"
+
+RDEPEND="
+ sys-libs/ncurses
+ sys-libs/readline
+ nls? ( virtual/libintl )
+"
+
+DEPEND="
+ ${RDEPEND}
+ sys-devel/bison
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-0.6.9-as-needed.patch \
+ "${FILESDIR}"/${PN}-0.6.9-GROFF_NO_SGR.patch \
+ "${FILESDIR}"/${PN}-0.6.9-lzma-xz.patch \
+ "${FILESDIR}"/${PN}-0.6.10-version.patch \
+ "${FILESDIR}"/${PN}-0.6.10-info-suffix.patch \
+ "${FILESDIR}"/${PN}-0.6.10-dir-file.patch \
+ "${FILESDIR}"/${PN}-0.6.10-tinfo.patch \
+ "${FILESDIR}"/${PN}-0.6.10-gettext-0.19.patch
+
+ eautoreconf
+
+ append-cflags -D_BSD_SOURCE # sbrk()
+}
+
+src_configure() {
+ econf \
+ $(use_with readline) \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" sysconfdir=/etc install
+}