summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevin F. Quinn <kevquinn@gentoo.org>2006-11-30 20:16:51 +0000
committerKevin F. Quinn <kevquinn@gentoo.org>2006-11-30 20:16:51 +0000
commit25d947de704788850597ee46fedfed04a1fb00ec (patch)
tree95fbaf4e410fe44ea42f59358c0fb601c2823bb4 /app-text
parentCleaning up and using improved ebuild from bug #95845 thanks to Sebastien Fabbro (diff)
downloadgentoo-2-25d947de704788850597ee46fedfed04a1fb00ec.tar.gz
gentoo-2-25d947de704788850597ee46fedfed04a1fb00ec.tar.bz2
gentoo-2-25d947de704788850597ee46fedfed04a1fb00ec.zip
Set aspell-0.6 to block aspell-en-0.5 - bug #96794
(Portage version: 2.1.2_rc2-r1)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/aspell/ChangeLog14
-rw-r--r--app-text/aspell/aspell-0.60.3-r1.ebuild71
-rw-r--r--app-text/aspell/aspell-0.60.4-r1.ebuild86
-rw-r--r--app-text/aspell/files/digest-aspell-0.60.3-r13
-rw-r--r--app-text/aspell/files/digest-aspell-0.60.4-r13
5 files changed, 176 insertions, 1 deletions
diff --git a/app-text/aspell/ChangeLog b/app-text/aspell/ChangeLog
index c51b7f520592..767b836b2667 100644
--- a/app-text/aspell/ChangeLog
+++ b/app-text/aspell/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for app-text/aspell
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/ChangeLog,v 1.80 2006/04/28 01:58:33 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/ChangeLog,v 1.81 2006/11/30 20:16:51 kevquinn Exp $
+
+*aspell-0.60.4-r1 (30 Nov 2006)
+*aspell-0.60.3-r1 (30 Nov 2006)
+
+ 30 Nov 2006; Kevin F. Quinn <kevquinn@gentoo.org>
+ +aspell-0.60.3-r1.ebuild, +aspell-0.60.4-r1.ebuild:
+ Add blocker on aspell-en-0.5 - bumped so that any existing users with
+ aspell-en-0.5 installed will be prompted to deal with it. Bug #96794
+
+ 30 Nov 2006; Kevin F. Quinn <kevquinn@gentoo.org> aspell-0.60.4.ebuild:
+ Set WANT_AUTOMAKE to get correct dependencies for autotools,
+ for bug #156654
28 Apr 2006; Luca Barbato <lu_zero@gentoo.org> aspell-0.60.4.ebuild:
Make absolutely sure altivec is disable
diff --git a/app-text/aspell/aspell-0.60.3-r1.ebuild b/app-text/aspell/aspell-0.60.3-r1.ebuild
new file mode 100644
index 000000000000..9dffc34d874e
--- /dev/null
+++ b/app-text/aspell/aspell-0.60.3-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/aspell-0.60.3-r1.ebuild,v 1.1 2006/11/30 20:16:51 kevquinn Exp $
+
+inherit libtool eutils flag-o-matic
+
+DESCRIPTION="A spell checker replacement for ispell"
+HOMEPAGE="http://aspell.net/"
+SRC_URI="mirror://gnu/aspell/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc-macos ~s390 ~sh ~sparc ~x86"
+IUSE="gpm"
+# Note; app-text/aspell-0.6 and app-dicts/aspell-en-0.6 must go stable together
+
+DEPEND=">=sys-libs/ncurses-5.2
+ gpm? ( sys-libs/gpm )
+ !=app-dicts/aspell-en-0.5*"
+# English dictionary 0.5 is incompatible with aspell-0.6
+
+src_unpack() {
+ unpack ${A}; cd ${S}
+ epatch ${FILESDIR}/${P}-templateinstantiations.patch
+}
+
+src_compile() {
+ [ "${ARCH}" == "ppc" ] && append-flags -O2 -fsigned-char
+ use gpm && append-ldflags -lgpm
+ filter-flags -fno-rtti
+ filter-flags -fvisibility=hidden #77109
+ elibtoolize --reverse-deps
+
+ econf \
+ --disable-static \
+ --sysconfdir=/etc/aspell \
+ --enable-docdir=/usr/share/doc/${PF} || die
+
+ emake || die
+}
+
+src_install() {
+ dodoc README* TODO
+
+ make DESTDIR="${D}" install || die
+ mv ${D}/usr/share/doc/${PF}/man-html ${D}/usr/share/doc/${PF}/html
+ mv ${D}/usr/share/doc/${PF}/man-text ${D}/usr/share/doc/${PF}/text
+
+ # install ispell/aspell compatibility scripts
+ exeinto /usr/bin
+ newexe scripts/ispell ispell-aspell
+ newexe scripts/spell spell-aspell
+
+ cd examples
+ make clean || die
+ docinto examples
+ dodoc ${S}/examples/*
+}
+
+pkg_postinst() {
+ einfo "You will need to install a dictionary now. Please choose an"
+ einfo "aspell-<LANG> dictionary from the app-dicts category"
+ einfo "After installing an aspell dictionary for your language(s),"
+ einfo "You may use the aspell-import utility to import your personal"
+ einfo "dictionaries from ispell, pspell and the older aspell"
+
+ ewarn ""
+ ewarn "Please re-emerge ALL your aspell-LANG dictionaries"
+ ewarn ""
+ ebeep 5
+}
diff --git a/app-text/aspell/aspell-0.60.4-r1.ebuild b/app-text/aspell/aspell-0.60.4-r1.ebuild
new file mode 100644
index 000000000000..398a5eb099de
--- /dev/null
+++ b/app-text/aspell/aspell-0.60.4-r1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/aspell-0.60.4-r1.ebuild,v 1.1 2006/11/30 20:16:51 kevquinn Exp $
+
+# N.B. This is before inherit of autotools, as autotools.eclass adds the
+# relevant dependencies to DEPEND.
+WANT_AUTOMAKE="1.9"
+
+inherit libtool eutils flag-o-matic autotools
+
+DESCRIPTION="A spell checker replacement for ispell"
+HOMEPAGE="http://aspell.net/"
+SRC_URI="mirror://gnu/aspell/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="gpm nls"
+# Note; app-text/aspell-0.6 and app-dicts/aspell-en-0.6 must go stable together
+
+RDEPEND=">=sys-libs/ncurses-5.2
+ gpm? ( sys-libs/gpm )
+ nls? ( virtual/libintl )
+ !=app-dicts/aspell-en-0.5*"
+# English dictionary 0.5 is incompatible with aspell-0.6
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/aspell-0.60.3-templateinstantiations.patch
+ epatch "${FILESDIR}"/aspell-0.60.4-gcc-4.1-fix.patch
+ epatch "${FILESDIR}/${P}-nls.patch"
+
+ eautomake
+ elibtoolize --reverse-deps
+}
+
+src_compile() {
+ use gpm && append-ldflags -lgpm
+ filter-flags -fno-rtti
+ filter-flags -fvisibility=hidden #77109
+ filter-flags -maltivec -mabi=altivec
+ use ppc && append-flags -mno-altivec
+
+ econf \
+ $(use_enable nls) \
+ --disable-static \
+ --sysconfdir=/etc/aspell \
+ --enable-docdir=/usr/share/doc/${PF} || die
+
+ emake || die
+}
+
+src_install() {
+ dodoc README* TODO
+
+ make DESTDIR="${D}" install || die
+ mv "${D}"/usr/share/doc/${PF}/man-html "${D}"/usr/share/doc/${PF}/html
+ mv "${D}"/usr/share/doc/${PF}/man-text "${D}"/usr/share/doc/${PF}/text
+
+ # install ispell/aspell compatibility scripts
+ exeinto /usr/bin
+ newexe scripts/ispell ispell-aspell
+ newexe scripts/spell spell-aspell
+
+ cd examples
+ make clean || die
+ docinto examples
+ dodoc ${S}/examples/*
+}
+
+pkg_postinst() {
+ einfo "You will need to install a dictionary now. Please choose an"
+ einfo "aspell-<LANG> dictionary from the app-dicts category"
+ einfo "After installing an aspell dictionary for your language(s),"
+ einfo "You may use the aspell-import utility to import your personal"
+ einfo "dictionaries from ispell, pspell and the older aspell"
+
+ ewarn ""
+ ewarn "Please re-emerge ALL your aspell-LANG dictionaries"
+ ewarn ""
+ ebeep 5
+}
diff --git a/app-text/aspell/files/digest-aspell-0.60.3-r1 b/app-text/aspell/files/digest-aspell-0.60.3-r1
new file mode 100644
index 000000000000..6d2305a29844
--- /dev/null
+++ b/app-text/aspell/files/digest-aspell-0.60.3-r1
@@ -0,0 +1,3 @@
+MD5 ca44ac2fcfdc7213e03d3b5610ce141a aspell-0.60.3.tar.gz 1635824
+RMD160 92e0dd8e271a48f73407e23c2d0246f2827e1789 aspell-0.60.3.tar.gz 1635824
+SHA256 0403ee33f680325aacf200a967062010a959bfd0c35ab55e0049dfec57e9d21c aspell-0.60.3.tar.gz 1635824
diff --git a/app-text/aspell/files/digest-aspell-0.60.4-r1 b/app-text/aspell/files/digest-aspell-0.60.4-r1
new file mode 100644
index 000000000000..b06cd5ec9fa6
--- /dev/null
+++ b/app-text/aspell/files/digest-aspell-0.60.4-r1
@@ -0,0 +1,3 @@
+MD5 4f1737e726d66476b9c7388831305510 aspell-0.60.4.tar.gz 1676825
+RMD160 e0408acd4f3304c957aeea0b17a28d0c44e11064 aspell-0.60.4.tar.gz 1676825
+SHA256 8931d8644da9a71fdd970cafe9d6c20d796ad1d8ef2aaf89a801171104e426e4 aspell-0.60.4.tar.gz 1676825