summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriele Giorgetti <stroke@gentoo.org>2002-07-28 16:48:26 +0000
committerGabriele Giorgetti <stroke@gentoo.org>2002-07-28 16:48:26 +0000
commit22e087236066aa0a949a1b6df26b3b0fc2787b1b (patch)
treedc9fa718189898acb7da158c0ae28afcc1363133 /app-text
parentNew ebuild due to bugfixes upstream. (diff)
downloadgentoo-2-22e087236066aa0a949a1b6df26b3b0fc2787b1b.tar.gz
gentoo-2-22e087236066aa0a949a1b6df26b3b0fc2787b1b.tar.bz2
gentoo-2-22e087236066aa0a949a1b6df26b3b0fc2787b1b.zip
New Package: GtkSpell is a spell library fro GTK2. (Needed by pan >=0.12.91)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/gtkspell/ChangeLog10
-rw-r--r--app-text/gtkspell/files/digest-gtkspell-2.0.01
-rw-r--r--app-text/gtkspell/gtkspell-2.0.0.ebuild49
3 files changed, 60 insertions, 0 deletions
diff --git a/app-text/gtkspell/ChangeLog b/app-text/gtkspell/ChangeLog
new file mode 100644
index 000000000000..1d48df6e62b0
--- /dev/null
+++ b/app-text/gtkspell/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-text/gtkspell
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-text/gtkspell/ChangeLog,v 1.1 2002/07/28 16:48:26 stroke Exp $
+
+*gtkspell-2.0.0 (28 Jul 2002)
+
+ 28 Jul 2002; Gabriele Giorgetti <stroke@gentoo.org> gtkspell-2.0.0.ebuild :
+
+ GtkSpell is a spell library fro GTK2
+ Initial CVS import.
diff --git a/app-text/gtkspell/files/digest-gtkspell-2.0.0 b/app-text/gtkspell/files/digest-gtkspell-2.0.0
new file mode 100644
index 000000000000..541cb25ff696
--- /dev/null
+++ b/app-text/gtkspell/files/digest-gtkspell-2.0.0
@@ -0,0 +1 @@
+MD5 a1ae5eb2bf7d176da5fab1c9f349dd04 gtkspell-2.0.0.tar.gz 182782
diff --git a/app-text/gtkspell/gtkspell-2.0.0.ebuild b/app-text/gtkspell/gtkspell-2.0.0.ebuild
new file mode 100644
index 000000000000..059311bb3485
--- /dev/null
+++ b/app-text/gtkspell/gtkspell-2.0.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-text/gtkspell/gtkspell-2.0.0.ebuild,v 1.1 2002/07/28 16:48:26 stroke Exp $
+
+DESCRIPTION="GtkSpell is a spell library for GTK2"
+
+SRC_URI="http://gtkspell.sourceforge.net/download/${P}.tar.gz"
+# SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://gtkspell.sourceforge.net/"
+
+LICENSE="GPL-2"
+KEYWORDS="x86"
+SLOT="0"
+
+RDEPEND=">=dev-libs/glib-2.0.4
+ >=x11-libs/gtk+-2.0.5
+ >=app-text/pspell-0.12.2-r3"
+
+DEPEND="$RDEPEND"
+
+src_compile() {
+
+ local myconf
+ use nls || myconf="--disable-nls"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --localstatedir=/var/lib \
+ --enable-debug=yes \
+ ${myconf} || die "configure failure"
+
+ emake || die "compile failure"
+}
+
+src_install() {
+ emake prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ localstatedir=${D}/var/lib \
+ install || die "installation failed"
+
+ dodoc AUTHORS ChangeLog COPYING INSTALL NEWS README
+}
+
+