summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-01-16 10:56:11 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-01-16 10:56:11 +0000
commita6b3b3a33a1919f354b4c70f9389faca7e89e6a3 (patch)
tree93dd4c684aaadc6ed1502ff2cdd3502c24760618 /app-text/winefish
parentFix HOMEPAGE and missing pkg-config dep wrt #206025. (diff)
downloadgentoo-2-a6b3b3a33a1919f354b4c70f9389faca7e89e6a3.tar.gz
gentoo-2-a6b3b3a33a1919f354b4c70f9389faca7e89e6a3.tar.bz2
gentoo-2-a6b3b3a33a1919f354b4c70f9389faca7e89e6a3.zip
add missing pkgconfig dep, bug #206029, dont prestrip files, bug #199539
(Portage version: 2.1.4)
Diffstat (limited to 'app-text/winefish')
-rw-r--r--app-text/winefish/ChangeLog8
-rw-r--r--app-text/winefish/files/winefish-1.3.3-nostrip.patch13
-rw-r--r--app-text/winefish/winefish-1.3.3.ebuild17
3 files changed, 30 insertions, 8 deletions
diff --git a/app-text/winefish/ChangeLog b/app-text/winefish/ChangeLog
index 7d12e51d690b..964e734df03b 100644
--- a/app-text/winefish/ChangeLog
+++ b/app-text/winefish/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/winefish
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/winefish/ChangeLog,v 1.7 2007/09/14 18:36:36 nixnut Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/winefish/ChangeLog,v 1.8 2008/01/16 10:56:10 aballier Exp $
+
+ 16 Jan 2008; Alexis Ballier <aballier@gentoo.org>
+ +files/winefish-1.3.3-nostrip.patch, winefish-1.3.3.ebuild:
+ add missing pkgconfig dep, bug #206029, dont prestrip files, bug #199539
14 Sep 2007; nixnut <nixnut@gentoo.org> winefish-1.3.3.ebuild:
Added ~ppc wrt bug 192008
diff --git a/app-text/winefish/files/winefish-1.3.3-nostrip.patch b/app-text/winefish/files/winefish-1.3.3-nostrip.patch
new file mode 100644
index 000000000000..b1118ebfc4d4
--- /dev/null
+++ b/app-text/winefish/files/winefish-1.3.3-nostrip.patch
@@ -0,0 +1,13 @@
+Index: winefish-1.3.3/src/Makefile.in
+===================================================================
+--- winefish-1.3.3.orig/src/Makefile.in
++++ winefish-1.3.3/src/Makefile.in
+@@ -37,7 +37,7 @@ LDFLAGS = @LDFLAGS@
+ LIBS = @LIBS@
+ INSTALL = @INSTALL@
+ INSTALL_DIR = $(INSTALL) -d -m 755
+-INSTALL_PROGRAM = $(INSTALL) -s -m 755
++INSTALL_PROGRAM = $(INSTALL) -m 755
+ DEFS = -DLOCALEDIR=\"$(localedir)\" -DGNULOCALEDIR=\"$(gnulocaledir)\" \
+ -DLOCALE_ALIAS_PATH=\"$(aliaspath)\" -DPKGDATADIR=\"$(pkgdatadir)\" @DEFS@
+
diff --git a/app-text/winefish/winefish-1.3.3.ebuild b/app-text/winefish/winefish-1.3.3.ebuild
index 5207007f4d9f..4f5823e0edd0 100644
--- a/app-text/winefish/winefish-1.3.3.ebuild
+++ b/app-text/winefish/winefish-1.3.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/winefish/winefish-1.3.3.ebuild,v 1.7 2007/09/14 18:36:36 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/winefish/winefish-1.3.3.ebuild,v 1.8 2008/01/16 10:56:10 aballier Exp $
inherit eutils fdo-mime
@@ -15,19 +15,24 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE="spell"
-DEPEND=">=x11-libs/gtk+-2.4
+RDEPEND=">=x11-libs/gtk+-2.4
>=dev-libs/libpcre-6.3
spell? ( virtual/aspell-dict )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
-#S=${WORKDIR}/${PN}-${MY_PV}
-
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-nostrip.patch"
+}
src_compile() {
econf --disable-update-databases || die
emake || die
}
src_install() {
- make install DESTDIR="${D}" || die "make install failed"
+ emake install DESTDIR="${D}" || die "make install failed"
dodoc AUTHORS CHANGES README ROADMAP THANKS TODO
}