summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-01-15 07:06:20 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-01-15 07:06:20 +0000
commitf5547973726a38cc8e135202aff38d0110883dea (patch)
tree12c97fefa5855cbbcb41c6a6ec030d38bafa30bd /app-text/pdfjam/pdfjam-1.20-r1.ebuild
parentClean up configure patch. Do not strip (bug #251981). Do not call autoconf di... (diff)
downloadgentoo-2-f5547973726a38cc8e135202aff38d0110883dea.tar.gz
gentoo-2-f5547973726a38cc8e135202aff38d0110883dea.tar.bz2
gentoo-2-f5547973726a38cc8e135202aff38d0110883dea.zip
Security fixes by Martin Väth for bug #252734
(Portage version: 2.2_rc22/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'app-text/pdfjam/pdfjam-1.20-r1.ebuild')
-rw-r--r--app-text/pdfjam/pdfjam-1.20-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-text/pdfjam/pdfjam-1.20-r1.ebuild b/app-text/pdfjam/pdfjam-1.20-r1.ebuild
new file mode 100644
index 000000000000..3229afbdfc62
--- /dev/null
+++ b/app-text/pdfjam/pdfjam-1.20-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pdfjam/pdfjam-1.20-r1.ebuild,v 1.1 2009/01/15 07:06:20 aballier Exp $
+
+inherit eutils
+
+DESCRIPTION="pdfnup, pdfjoin and pdf90"
+HOMEPAGE="http://www.warwick.ac.uk/go/pdfjam"
+SRC_URI="http://www2.warwick.ac.uk/fac/sci/statistics/staff/academic/firth/software/pdfjam/${P/-/_}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+S=${WORKDIR}/${PN}
+
+DEPEND="virtual/latex-base"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-security.patch"
+}
+
+src_compile() {
+ for i in pdf90 pdfjoin pdfnup; do
+ cp scripts/$i scripts/$i.orig
+ sed -e 's,^pdflatex="/usr/local/bin/pdflatex",pdflatex="/usr/bin/pdflatex",' scripts/$i.orig >scripts/$i
+ done
+}
+
+src_install() {
+ dobin scripts/pdf90 scripts/pdfjoin scripts/pdfnup || die
+ dodoc PDFjam-README.html || die
+ doman man1/pdf90.1 man1/pdfjoin.1 man1/pdfnup.1 || die
+}