summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2006-02-22 21:22:20 +0000
committerAaron Walker <ka0ttic@gentoo.org>2006-02-22 21:22:20 +0000
commit99f459ca9d8847d405c4926100d4bad5006d0232 (patch)
tree3cd607c99e1805ef98d6df62b0ef1b18f00888dd /app-text/multitail/multitail-3.8.6.ebuild
parentMarked ppc-macos stable (bug #123333) (diff)
downloadgentoo-2-99f459ca9d8847d405c4926100d4bad5006d0232.tar.gz
gentoo-2-99f459ca9d8847d405c4926100d4bad5006d0232.tar.bz2
gentoo-2-99f459ca9d8847d405c4926100d4bad5006d0232.zip
Version bump.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'app-text/multitail/multitail-3.8.6.ebuild')
-rw-r--r--app-text/multitail/multitail-3.8.6.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-text/multitail/multitail-3.8.6.ebuild b/app-text/multitail/multitail-3.8.6.ebuild
new file mode 100644
index 000000000000..6fbb6c59ff43
--- /dev/null
+++ b/app-text/multitail/multitail-3.8.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/multitail/multitail-3.8.6.ebuild,v 1.1 2006/02/22 21:22:20 ka0ttic Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Tail with multiple windows."
+HOMEPAGE="http://www.vanheusden.com/multitail/index.html"
+SRC_URI="http://www.vanheusden.com/multitail/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="debug"
+
+DEPEND="virtual/libc
+ sys-libs/ncurses"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # tail: '-100lf' option is obsolete; use '-f-n 100'
+ # since this will be removed in the future
+ sed -i 's/-%dlf/-fn%d/' mt.c || die "sed mt.c failed"
+}
+
+src_compile() {
+ append-flags "-D$(uname) -DVERSION=\\\"${PV}\\\""
+ use debug && append-flags "-g -D_DEBUG"
+ make all CFLAGS="${CFLAGS}" || die "make failed"
+}
+
+src_install () {
+ dobin multitail
+ insinto /etc
+ doins multitail.conf
+ dodoc Changes INSTALL license.txt readme.txt
+ dohtml manual.html
+ doman multitail.1
+}