summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Varner <fuzzyray@gentoo.org>2007-02-19 22:25:17 +0000
committerPaul Varner <fuzzyray@gentoo.org>2007-02-19 22:25:17 +0000
commit3b8e94b9652b171123280efc713dacdca2b1ed2a (patch)
treedc47c01795cbb843b24a230ff32063af263699bb /app-text/manedit/manedit-0.8.1.ebuild
parentFix 3D apps running in Wine. (Bug #163973, riku) (diff)
downloadgentoo-2-3b8e94b9652b171123280efc713dacdca2b1ed2a.tar.gz
gentoo-2-3b8e94b9652b171123280efc713dacdca2b1ed2a.tar.bz2
gentoo-2-3b8e94b9652b171123280efc713dacdca2b1ed2a.zip
Add manedit-0.8.1, remove manedit-0.6.1
Diffstat (limited to 'app-text/manedit/manedit-0.8.1.ebuild')
-rw-r--r--app-text/manedit/manedit-0.8.1.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/app-text/manedit/manedit-0.8.1.ebuild b/app-text/manedit/manedit-0.8.1.ebuild
new file mode 100644
index 000000000000..3453a22911c9
--- /dev/null
+++ b/app-text/manedit/manedit-0.8.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/manedit/manedit-0.8.1.ebuild,v 1.1 2007/02/19 22:25:17 fuzzyray Exp $
+
+inherit eutils
+
+DESCRIPTION="Man page editor using XML tags"
+HOMEPAGE="http://wolfpack.twu.net/ManEdit/"
+SRC_URI="ftp://wolfpack.twu.net/users/wolfpack/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="=x11-libs/gtk+-1*
+ sys-libs/zlib
+ app-arch/bzip2
+ || ( ( x11-libs/libXi
+ )
+ virtual/x11
+ )"
+
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ # Patch to fix QA warnings and to generate man page
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PF}-gentoo.patch
+}
+
+src_compile() {
+ # It autodetects x86 processors and adds the -march option itself
+ # but we don't actually want that.
+ env CFLAGS="${CFLAGS}" \
+ ./configure Linux \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --datadir=/usr/share \
+ --enable=bzip2 \
+ --enable=zlib \
+ --disable="arch-i486" \
+ --disable="arch-i586" \
+ --disable="arch-i686" \
+ --disable="arch-pentiumpro" || die "Bad Configure"
+ emake || die "Compile Error"
+}
+
+src_install() {
+ # fix strip error (tries to strip a shell script)
+ cp manedit/Makefile.install.UNIX{,.orig}
+ sed -e '/INST.*FLAGS.*-s$/s:-s::' \
+ manedit/Makefile.install.UNIX.orig > manedit/Makefile.install.UNIX
+
+ # set man dir too or FHS is violated (/usr/man)
+ make \
+ PREFIX=${D}/usr \
+ MAN_DIR=${D}/usr/share/man/man1 \
+ ICONS_DIR=${D}/usr/share/pixmaps \
+ install || die "make install failed."
+
+ dodoc AUTHORS LICENSE README
+}