summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2014-05-06 12:35:08 +0000
committerMichael Palimaka <kensington@gentoo.org>2014-05-06 12:35:08 +0000
commitbc39e1a44f0b4cb04a44d1cab09e623cb5036cf0 (patch)
treec06254c4d23175b1932a24af09e2931d0dc2555f /app-text/kchmviewer
parentRevision bump adds patch to find the correct version libboost_python outside ... (diff)
downloadgentoo-2-bc39e1a44f0b4cb04a44d1cab09e623cb5036cf0.tar.gz
gentoo-2-bc39e1a44f0b4cb04a44d1cab09e623cb5036cf0.tar.bz2
gentoo-2-bc39e1a44f0b4cb04a44d1cab09e623cb5036cf0.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x06B1F38DCA45A1EC!)
Diffstat (limited to 'app-text/kchmviewer')
-rw-r--r--app-text/kchmviewer/ChangeLog9
-rw-r--r--app-text/kchmviewer/kchmviewer-6.1.ebuild96
2 files changed, 103 insertions, 2 deletions
diff --git a/app-text/kchmviewer/ChangeLog b/app-text/kchmviewer/ChangeLog
index a90f995248ba..6e6911b11fc0 100644
--- a/app-text/kchmviewer/ChangeLog
+++ b/app-text/kchmviewer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/kchmviewer
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/kchmviewer/ChangeLog,v 1.56 2013/03/27 06:23:12 kensington Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/kchmviewer/ChangeLog,v 1.57 2014/05/06 12:35:08 kensington Exp $
+
+*kchmviewer-6.1 (06 May 2014)
+
+ 06 May 2014; Michael Palimaka <kensington@gentoo.org> +kchmviewer-6.1.ebuild:
+ Version bump.
27 Mar 2013; Michael Palimaka <kensington@gentoo.org> -kchmviewer-6.0.ebuild:
Remove old.
diff --git a/app-text/kchmviewer/kchmviewer-6.1.ebuild b/app-text/kchmviewer/kchmviewer-6.1.ebuild
new file mode 100644
index 000000000000..f0b9ab8a23db
--- /dev/null
+++ b/app-text/kchmviewer/kchmviewer-6.1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/kchmviewer/kchmviewer-6.1.ebuild,v 1.1 2014/05/06 12:35:07 kensington Exp $
+
+EAPI=5
+
+KDE_REQUIRED="optional"
+KDE_LINGUAS="cs fr hu it nl pt_BR ru sv tr uk zh_CN zh_TW"
+inherit eutils fdo-mime kde4-base qmake-utils
+
+DESCRIPTION="A feature rich chm file viewer, based on Qt"
+HOMEPAGE="http://www.kchmviewer.net/"
+SRC_URI="mirror://sourceforge/kchmviewer/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug kde"
+
+RDEPEND="
+ dev-libs/chmlib
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ dev-qt/qtwebkit:4
+ kde? (
+ $(add_kdebase_dep kdelibs)
+ !kde-base/okular[chm]
+ )
+"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ use kde && kde4-base_pkg_setup
+}
+
+src_prepare() {
+ # Don't try to build a file that no longer exists
+ sed -e "/keyeventfilter.cpp/d" -i src/CMakeLists.txt || die
+
+ # Remove deprecated key
+ sed -e "/Encoding=UTF-8/d" -i packages/kchmviewer.desktop || die
+
+ local lang
+ for lang in ${KDE_LINGUAS} ; do
+ if ! use linguas_${lang} ; then
+ rm po/${PN}_${lang}.po
+ fi
+ done
+}
+
+src_configure() {
+ if use kde; then
+ kde4-base_src_configure
+ else
+ eqmake4
+ fi
+}
+
+src_compile() {
+ if use kde; then
+ kde4-base_src_compile
+ else
+ default
+ fi
+}
+
+src_install() {
+ dodoc DBUS-bindings FAQ
+ doicon packages/kchmviewer.png
+
+ if use kde; then
+ kde4-base_src_install
+ else
+ dobin bin/kchmviewer
+ domenu packages/kchmviewer.desktop
+ dodoc ChangeLog README
+ fi
+
+}
+
+pkg_postinst() {
+ if use kde; then
+ kde4-base_pkg_postinst
+ else
+ fdo-mime_desktop_database_update
+ fi
+}
+
+pkg_postrm() {
+ if use kde; then
+ kde4-base_pkg_postrm
+ else
+ fdo-mime_desktop_database_update
+ fi
+}