summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-06-21 07:29:23 +0000
committerSamuli Suominen <drac@gentoo.org>2008-06-21 07:29:23 +0000
commit8121f1dc5919fd1a4fe316656bd370aea2ac6543 (patch)
tree6bfa7b7246932ad8a6954eab6d0e6a6a3cdb317f /app-text/gv
parentwhitespace (diff)
downloadgentoo-2-8121f1dc5919fd1a4fe316656bd370aea2ac6543.tar.gz
gentoo-2-8121f1dc5919fd1a4fe316656bd370aea2ac6543.tar.bz2
gentoo-2-8121f1dc5919fd1a4fe316656bd370aea2ac6543.zip
Version bump.
(Portage version: 2.2_rc1/cvs/Linux 2.6.26-rc3 x86_64)
Diffstat (limited to 'app-text/gv')
-rw-r--r--app-text/gv/ChangeLog9
-rw-r--r--app-text/gv/gv-3.6.4.ebuild50
2 files changed, 57 insertions, 2 deletions
diff --git a/app-text/gv/ChangeLog b/app-text/gv/ChangeLog
index 5cb5f6f94e26..2211ca606ae2 100644
--- a/app-text/gv/ChangeLog
+++ b/app-text/gv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/gv
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/gv/ChangeLog,v 1.75 2007/11/18 20:45:11 genstef Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/gv/ChangeLog,v 1.76 2008/06/21 07:29:23 drac Exp $
+
+*gv-3.6.4 (21 Jun 2008)
+
+ 21 Jun 2008; Samuli Suominen <drac@gentoo.org> +gv-3.6.4.ebuild:
+ Version bump.
18 Nov 2007; Stefan Schweizer <genstef@gentoo.org>
-files/gv-3.6.1-fixedmedia.patch, -files/gv-30_config.patch,
diff --git a/app-text/gv/gv-3.6.4.ebuild b/app-text/gv/gv-3.6.4.ebuild
new file mode 100644
index 000000000000..1d5a70b1e457
--- /dev/null
+++ b/app-text/gv/gv-3.6.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/gv/gv-3.6.4.ebuild,v 1.1 2008/06/21 07:29:23 drac Exp $
+
+inherit autotools eutils
+
+DESCRIPTION="gv is used to view PostScript and PDF documents using Ghostscript"
+HOMEPAGE="http://www.gnu.org/software/gv/"
+SRC_URI="mirror://gnu/gv/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-libs/Xaw3d
+ virtual/ghostscript
+ x11-libs/libXt"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/gv-3.6.1-a0.patch
+
+ # Make font render nicely even with gs-8, bug 135354
+ sed -i \
+ -e "s:-dGraphicsAlphaBits=2:\0 -dAlignToPixels=0:" \
+ src/{gv_{class,user,system}.ad,Makefile.am} || die "sed failed."
+
+ eautoreconf
+}
+
+src_compile() {
+ econf --disable-dependency-tracking \
+ --enable-scrollbar-code || die "econf failed."
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ doicon src/gv_icon.xbm
+ make_desktop_entry gv "GhostView" /usr/share/pixmaps/gv_icon.xbm "Graphics;Viewer;"
+ dodoc AUTHORS ChangeLog README
+}