summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-23 17:52:07 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-23 17:52:07 +0000
commitf4549b3f18e982272304950ea1386dda9dcbb01f (patch)
tree57d84205efffe761791f89221b8f275eee631c80 /app-text/gtkspell
parentgtkspell against new aspell masked (diff)
downloadgentoo-2-f4549b3f18e982272304950ea1386dda9dcbb01f.tar.gz
gentoo-2-f4549b3f18e982272304950ea1386dda9dcbb01f.tar.bz2
gentoo-2-f4549b3f18e982272304950ea1386dda9dcbb01f.zip
compile against new aspell
Diffstat (limited to 'app-text/gtkspell')
-rw-r--r--app-text/gtkspell/ChangeLog9
-rw-r--r--app-text/gtkspell/files/digest-gtkspell-2.0.0-r1 (renamed from app-text/gtkspell/files/digest-gtkspell-2.0.0)0
-rw-r--r--app-text/gtkspell/gtkspell-2.0.0-r1.ebuild36
3 files changed, 44 insertions, 1 deletions
diff --git a/app-text/gtkspell/ChangeLog b/app-text/gtkspell/ChangeLog
index 1d48df6e62b0..b4ae9aa45942 100644
--- a/app-text/gtkspell/ChangeLog
+++ b/app-text/gtkspell/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/gtkspell
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-text/gtkspell/ChangeLog,v 1.1 2002/07/28 16:48:26 stroke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/gtkspell/ChangeLog,v 1.2 2002/08/23 17:52:07 seemant Exp $
+
+*gtkspell-2.0.0-r1 (23 Aug 2002)
+
+ 23 Aug 2002; Seemant Kulleen <seemant@gentoo.org> gtkspell-2.0.0-r1.ebuild
+ files/digest-gtkspell-2.0.0-r1 :
+
+ Compile against the new aspell instead of pspell.
*gtkspell-2.0.0 (28 Jul 2002)
diff --git a/app-text/gtkspell/files/digest-gtkspell-2.0.0 b/app-text/gtkspell/files/digest-gtkspell-2.0.0-r1
index 541cb25ff696..541cb25ff696 100644
--- a/app-text/gtkspell/files/digest-gtkspell-2.0.0
+++ b/app-text/gtkspell/files/digest-gtkspell-2.0.0-r1
diff --git a/app-text/gtkspell/gtkspell-2.0.0-r1.ebuild b/app-text/gtkspell/gtkspell-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..13369c783672
--- /dev/null
+++ b/app-text/gtkspell/gtkspell-2.0.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-text/gtkspell/gtkspell-2.0.0-r1.ebuild,v 1.1 2002/08/23 17:52:07 seemant Exp $
+
+DESCRIPTION="GtkSpell is a spell library for GTK2"
+
+SRC_URI="http://gtkspell.sourceforge.net/download/${P}.tar.gz"
+HOMEPAGE="http://gtkspell.sourceforge.net/"
+
+LICENSE="GPL-2"
+KEYWORDS="x86 sparc sparc64"
+SLOT="0"
+
+RDEPEND=">=dev-libs/glib-2.0.4
+ >=x11-libs/gtk+-2.0.5
+ >=app-text/aspell-0.50"
+
+DEPEND="$RDEPEND"
+
+src_compile() {
+
+ local myconf
+ use nls || myconf="--disable-nls"
+
+ econf \
+ --enable-debug=yes \
+ ${myconf} || die "configure failure"
+
+ emake || die "compile failure"
+}
+
+src_install() {
+ einstall || die "installation failed"
+
+ dodoc AUTHORS ChangeLog COPYING INSTALL NEWS README
+}