summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-09-06 10:35:16 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-09-06 10:35:16 +0000
commitfd037e1d534c8721dfe07b0e621f4bffe31e308f (patch)
tree6ee85d9d7ca69e844047946dfd3f4174e4b1241e /app-text/epstool
parentStable for sparc, wrt bug #450534 (diff)
downloadgentoo-2-fd037e1d534c8721dfe07b0e621f4bffe31e308f.tar.gz
gentoo-2-fd037e1d534c8721dfe07b0e621f4bffe31e308f.tar.bz2
gentoo-2-fd037e1d534c8721dfe07b0e621f4bffe31e308f.zip
Revision bump: EAPI 5, epatch_user, respect CC, wrt bug #475256. Thanks to Agostino Sarubbo for discovering this issue
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'app-text/epstool')
-rw-r--r--app-text/epstool/ChangeLog8
-rw-r--r--app-text/epstool/epstool-3.08-r1.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/app-text/epstool/ChangeLog b/app-text/epstool/ChangeLog
index 4fa838ab3a4b..23f35022f4a2 100644
--- a/app-text/epstool/ChangeLog
+++ b/app-text/epstool/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/epstool
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/epstool/ChangeLog,v 1.31 2013/07/21 09:33:22 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/epstool/ChangeLog,v 1.32 2013/09/06 10:35:16 pinkbyte Exp $
+
+*epstool-3.08-r1 (06 Sep 2013)
+
+ 06 Sep 2013; Sergey Popov <pinkbyte@gentoo.org> +epstool-3.08-r1.ebuild:
+ Revision bump: EAPI 5, epatch_user, respect CC, wrt bug #475256. Thanks to
+ Agostino Sarubbo for discovering this issue
21 Jul 2013; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Cleanup due #473480
diff --git a/app-text/epstool/epstool-3.08-r1.ebuild b/app-text/epstool/epstool-3.08-r1.ebuild
new file mode 100644
index 000000000000..202d72cdc348
--- /dev/null
+++ b/app-text/epstool/epstool-3.08-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/epstool/epstool-3.08-r1.ebuild,v 1.1 2013/09/06 10:35:16 pinkbyte Exp $
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Creates or extracts preview images in EPS files, fixes bounding boxes,converts to bitmaps."
+HOMEPAGE="http://www.cs.wisc.edu/~ghost/gsview/epstool.htm"
+SRC_URI="ftp://mirror.cs.wisc.edu/pub/mirrors/ghost/ghostgum/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+DEPEND="app-text/ghostscript-gpl"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/gcc43.patch"
+
+ sed -i \
+ -e '/^CC/s/=/?=/' \
+ -e '/^CLINK/s/gcc/$(CC)/' \
+ src/unixcom.mak || die 'sed on src/unixcom.mak failed'
+ tc-export CC
+
+ epatch_user
+}
+
+src_compile() {
+ emake epstool
+}
+
+src_install() {
+ dobin bin/epstool
+ doman doc/epstool.1
+ dohtml doc/epstool.htm doc/gsview.css
+}