summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-03-20 19:34:55 +0000
committerFabian Groffen <grobian@gentoo.org>2010-03-20 19:34:55 +0000
commit97a2e2288f99e2dc767827d50ab938f4cbcf6b40 (patch)
tree39a93ac583ea916e56bc215e72ae7b662066a85e /app-text/dos2unix
parentImprove usage of python eclass (bug 308301): use PYTHON_DEPEND, set active py... (diff)
downloadgentoo-2-97a2e2288f99e2dc767827d50ab938f4cbcf6b40.tar.gz
gentoo-2-97a2e2288f99e2dc767827d50ab938f4cbcf6b40.tar.bz2
gentoo-2-97a2e2288f99e2dc767827d50ab938f4cbcf6b40.zip
Fix USE=nls for platforms that do not have libintl in libc, fix for Prefix
(Portage version: 2.2.00.15838-prefix/cvs/Darwin powerpc)
Diffstat (limited to 'app-text/dos2unix')
-rw-r--r--app-text/dos2unix/ChangeLog5
-rw-r--r--app-text/dos2unix/dos2unix-5.0.ebuild22
2 files changed, 23 insertions, 4 deletions
diff --git a/app-text/dos2unix/ChangeLog b/app-text/dos2unix/ChangeLog
index af398fe652f1..d57d9a04a310 100644
--- a/app-text/dos2unix/ChangeLog
+++ b/app-text/dos2unix/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/dos2unix
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/dos2unix/ChangeLog,v 1.41 2010/03/20 16:07:47 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/dos2unix/ChangeLog,v 1.42 2010/03/20 19:34:55 grobian Exp $
+
+ 20 Mar 2010; Fabian Groffen <grobian@gentoo.org> dos2unix-5.0.ebuild:
+ Fix USE=nls for platforms that do not have libintl in libc, fix for Prefix
*dos2unix-5.0 (20 Mar 2010)
diff --git a/app-text/dos2unix/dos2unix-5.0.ebuild b/app-text/dos2unix/dos2unix-5.0.ebuild
index 0aafcc6e4f40..9606bf6c4bac 100644
--- a/app-text/dos2unix/dos2unix-5.0.ebuild
+++ b/app-text/dos2unix/dos2unix-5.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/dos2unix/dos2unix-5.0.ebuild,v 1.1 2010/03/20 16:07:47 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/dos2unix/dos2unix-5.0.ebuild,v 1.2 2010/03/20 19:34:55 grobian Exp $
-EAPI="2"
+EAPI="3"
inherit toolchain-funcs
@@ -17,7 +17,9 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris"
IUSE="nls"
+DEPEND="virtual/libintl"
RDEPEND="
+ ${DEPEND}
!app-text/hd2u
!app-text/unix2dos"
@@ -25,11 +27,25 @@ src_prepare() {
sed \
-e '/^LDFLAGS/s|=|+=|' \
-e '/^CC/s|=|?=|' \
+ -e '/CFLAGS_OS \+=/d' \
+ -e '/LDFLAGS_EXTRA \+=/d' \
-i "${S}"/Makefile
tc-export CC
}
+lintl() {
+ # same logic as from virtual/libintl
+ use !elibc_glibc? && use !elibc_uclibc? && echo "-lintl"
+}
+
+src_compile() {
+ emake prefix="${EPREFIX}"/usr \
+ $(use nls && echo "LDFLAGS_EXTRA=$(lintl)" || echo "ENABLE_NLS=") \
+ || die
+}
+
src_install() {
- emake DESTDIR="${D}" $(use nls || echo "ENABLE_NLS=") install \
+ emake DESTDIR="${D}" prefix="${EPREFIX}"/usr \
+ $(use nls || echo "ENABLE_NLS=") install \
|| die "emake install failed"
}