summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-04-18 09:54:09 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-04-18 09:54:09 +0000
commit66ea5483580454dbbad33aed7c29c272e5732ae0 (patch)
treedbbef14744a680023c625b4e7b2b2f7246010cf1 /app-text/dos2unix
parentAdd ruby21. (diff)
downloadgentoo-2-66ea5483580454dbbad33aed7c29c272e5732ae0.tar.gz
gentoo-2-66ea5483580454dbbad33aed7c29c272e5732ae0.tar.bz2
gentoo-2-66ea5483580454dbbad33aed7c29c272e5732ae0.zip
Version bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'app-text/dos2unix')
-rw-r--r--app-text/dos2unix/ChangeLog7
-rw-r--r--app-text/dos2unix/dos2unix-6.0.5.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/app-text/dos2unix/ChangeLog b/app-text/dos2unix/ChangeLog
index d5e0071aaf48..ce64ce75e90e 100644
--- a/app-text/dos2unix/ChangeLog
+++ b/app-text/dos2unix/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/dos2unix
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/dos2unix/ChangeLog,v 1.136 2014/01/08 18:40:39 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/dos2unix/ChangeLog,v 1.137 2014/04/18 09:54:09 polynomial-c Exp $
+
+*dos2unix-6.0.5 (18 Apr 2014)
+
+ 18 Apr 2014; Lars Wendler <polynomial-c@gentoo.org> +dos2unix-6.0.5.ebuild:
+ Version bump.
08 Jan 2014; Lars Wendler <polynomial-c@gentoo.org> dos2unix-6.0.4.ebuild,
+files/dos2unix-6.0.4-pod-encoding.patch:
diff --git a/app-text/dos2unix/dos2unix-6.0.5.ebuild b/app-text/dos2unix/dos2unix-6.0.5.ebuild
new file mode 100644
index 000000000000..bafd509fa719
--- /dev/null
+++ b/app-text/dos2unix/dos2unix-6.0.5.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/dos2unix/dos2unix-6.0.5.ebuild,v 1.1 2014/04/18 09:54:09 polynomial-c Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Convert DOS or MAC text files to UNIX format or vice versa"
+HOMEPAGE="http://www.xs4all.nl/~waterlan/dos2unix.html http://sourceforge.net/projects/dos2unix/"
+SRC_URI="
+ http://www.xs4all.nl/~waterlan/${PN}/${P}.tar.gz
+ mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris"
+IUSE="debug nls"
+
+RDEPEND="
+ !app-text/hd2u
+ !app-text/unix2dos
+ virtual/libintl"
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+ dev-lang/perl"
+
+src_prepare() {
+ sed \
+ -e '/^LDFLAGS/s|=|+=|' \
+ -e '/CFLAGS_OS \+=/d' \
+ -e '/LDFLAGS_EXTRA \+=/d' \
+ -e "/^CFLAGS/s|-O2|${CFLAGS}|" \
+ -i Makefile || die
+
+ if use debug ; then
+ sed -e "/^DEBUG/s:0:1:" \
+ -e "/EXTRA_CFLAGS +=/s:-g::" \
+ -i Makefile || die
+ fi
+
+ tc-export CC
+}
+
+lintl() {
+ # same logic as from virtual/libintl
+ use !elibc_glibc && use !elibc_uclibc && echo "-lintl"
+}
+
+src_compile() {
+ emake prefix="${EPREFIX}/usr" \
+ $(usex nls "LDFLAGS_EXTRA=$(lintl)" "ENABLE_NLS=")
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}/usr" \
+ $(usex nls "" "ENABLE_NLS=") install
+}