summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2011-06-28 10:22:15 +0000
committerPeter Volkov <pva@gentoo.org>2011-06-28 10:22:15 +0000
commitfeced9b68b4b98f5f7601255d0374800e27e834b (patch)
treeb59d0711863da8661a4cc8560c1b4673ac35d5d8 /app-text/dictd
parentVersion bump, bug #372531 thank Kent Fredric for report. (diff)
downloadgentoo-2-feced9b68b4b98f5f7601255d0374800e27e834b.tar.gz
gentoo-2-feced9b68b4b98f5f7601255d0374800e27e834b.tar.bz2
gentoo-2-feced9b68b4b98f5f7601255d0374800e27e834b.zip
Version bump, bug #372531 thank Kent Fredric for report.
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'app-text/dictd')
-rw-r--r--app-text/dictd/ChangeLog9
-rw-r--r--app-text/dictd/dictd-1.12.0.ebuild100
2 files changed, 107 insertions, 2 deletions
diff --git a/app-text/dictd/ChangeLog b/app-text/dictd/ChangeLog
index e83cf2052cc7..218958c25d11 100644
--- a/app-text/dictd/ChangeLog
+++ b/app-text/dictd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/dictd
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/dictd/ChangeLog,v 1.87 2010/08/01 10:48:21 pva Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/dictd/ChangeLog,v 1.88 2011/06/28 10:22:14 pva Exp $
+
+*dictd-1.12.0 (28 Jun 2011)
+
+ 28 Jun 2011; Peter Volkov <pva@gentoo.org> +dictd-1.12.0.ebuild:
+ Version bump, bug #372531 thank Kent Fredric for report.
01 Aug 2010; Peter Volkov <pva@gentoo.org> files/1.10.11/dictd.initd:
Do not use non-posix pushd/popd inside init script, bug #330679, thank
diff --git a/app-text/dictd/dictd-1.12.0.ebuild b/app-text/dictd/dictd-1.12.0.ebuild
new file mode 100644
index 000000000000..1e39df902efa
--- /dev/null
+++ b/app-text/dictd/dictd-1.12.0.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/dictd/dictd-1.12.0.ebuild,v 1.1 2011/06/28 10:22:15 pva Exp $
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="Dictionary Client/Server for the DICT protocol"
+HOMEPAGE="http://www.dict.org/"
+SRC_URI="mirror://sourceforge/dict/${P}.tar.gz"
+
+SLOT="0"
+# We install rfc so - ISOC-rfc
+LICENSE="GPL-2 ISOC-rfc"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE="dbi judy minimal"
+
+# <gawk-3.1.6 makes tests fail.
+DEPEND="sys-apps/coreutils
+ sys-libs/zlib
+ dev-libs/libmaa
+ dbi? ( dev-db/libdbi )
+ judy? ( dev-libs/judy )
+ >=sys-apps/coreutils-6.10"
+RDEPEND="${DEPEND}
+ >=sys-apps/gawk-3.1.6"
+
+pkg_setup() {
+ enewgroup dictd # used in src_test()
+ enewuser dictd -1 -1 -1 dictd
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/dictd-1.10.11-colorit-nopp-fix.patch"
+
+ [[ ${CHOST} == *-darwin* ]] && \
+ sed -i -e 's:libtool:glibtool:g' Makefile.in
+}
+
+src_configure() {
+ econf \
+ $(use_with dbi plugin-dbi) \
+ $(use_with judy plugin-judy) \
+ --sysconfdir="${EPREFIX}"/etc/dict
+}
+
+src_compile() {
+ if use minimal; then
+ emake dictfmt dictzip dictzip
+ else
+ emake
+ fi
+}
+
+src_test() {
+ use minimal && return 0 # All tests are for dictd which we don't build...
+ if [[ ${EUID} -eq 0 ]]; then
+ # If dictd is run as root user (-userpriv) it drops its privileges to
+ # dictd user and group. Give dictd group write access to test directory.
+ chown :dictd "${WORKDIR}" "${S}/test"
+ chmod 770 "${WORKDIR}" "${S}/test"
+ fi
+ emake test
+}
+
+src_install() {
+ if use minimal; then
+ emake DESTDIR="${D}" install.dictzip install.dict install.dictfmt
+ else
+ emake DESTDIR="${D}" install
+
+ dodoc doc/{dicf.ms,rfc.ms,rfc.sh,rfc2229.txt}
+ dodoc doc/{security.doc,toc.ms}
+
+ # conf files. For dict.conf see below.
+ insinto /etc/dict
+ for f in dictd.conf site.info colorit.conf; do
+ doins "${FILESDIR}/1.10.11/${f}"
+ done
+
+ # startups for dictd
+ newinitd "${FILESDIR}/1.10.11/dictd.initd" dictd
+ newconfd "${FILESDIR}/1.10.11/dictd.confd" dictd
+ fi
+
+ insinto /etc/dict
+ doins "${FILESDIR}/1.10.11/dict.conf"
+ # Install docs
+ dodoc README TODO ChangeLog ANNOUNCE NEWS
+}
+
+pkg_postinst() {
+ echo
+ elog "To start and use ${PN} you need to emerge at least one dictionary from"
+ elog "the app-dicts category with the package name starting with 'dictd-'."
+ elog "To install all available dictionaries, emerge app-dicts/dictd-dicts."
+ elog "${PN} will NOT start without at least one dictionary."
+ echo
+}