summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-12-15 00:54:33 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-12-15 00:54:33 +0000
commit00ffa4fb5c62397c66afd954cddc7945f7b60e92 (patch)
treec583970af8a9678e4c4b938632175083405a9af1 /app-text/dictd
parentNew version (diff)
downloadgentoo-2-00ffa4fb5c62397c66afd954cddc7945f7b60e92.tar.gz
gentoo-2-00ffa4fb5c62397c66afd954cddc7945f7b60e92.tar.bz2
gentoo-2-00ffa4fb5c62397c66afd954cddc7945f7b60e92.zip
version bump
Diffstat (limited to 'app-text/dictd')
-rw-r--r--app-text/dictd/ChangeLog13
-rw-r--r--app-text/dictd/dictd-1.8.0.ebuild56
-rw-r--r--app-text/dictd/files/1.8.0/dict.conf6
-rw-r--r--app-text/dictd/files/1.8.0/dictd72
-rw-r--r--app-text/dictd/files/1.8.0/dictd.conf22
-rw-r--r--app-text/dictd/files/1.8.0/dictd.confd7
-rw-r--r--app-text/dictd/files/1.8.0/site.info6
-rw-r--r--app-text/dictd/files/digest-dictd-1.8.01
8 files changed, 180 insertions, 3 deletions
diff --git a/app-text/dictd/ChangeLog b/app-text/dictd/ChangeLog
index 5a0d63554f7d..3c4a3351da50 100644
--- a/app-text/dictd/ChangeLog
+++ b/app-text/dictd/ChangeLog
@@ -1,11 +1,18 @@
# ChangeLog for app-text/dictd
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-text/dictd/ChangeLog,v 1.3 2002/12/13 10:56:19 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/dictd/ChangeLog,v 1.4 2002/12/15 00:54:33 seemant Exp $
+
+*dictd-1.8.0 (14 Dec 2002)
+
+ 14 Dec 2002; Seemant Kulleen <seemant@gentoo.org> dictd-1.8.0.ebuild
+ files/digest-dictd-1.8.0 files/1.8.0/* :
+
+ Version bump, thanks to: absinthe@pobox.com (Dylan Carlson) in bug #12113
- 06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
-
*dictd-1.5.5-r6 (1 Feb 2002)
+ 06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
+
1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
Added initial ChangeLog which should be updated whenever the package is
diff --git a/app-text/dictd/dictd-1.8.0.ebuild b/app-text/dictd/dictd-1.8.0.ebuild
new file mode 100644
index 000000000000..63828d0a4e93
--- /dev/null
+++ b/app-text/dictd/dictd-1.8.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Michael Conrad Tilstra <michael@gentoo.org> <tadpol@tadpol.org>
+# $Header: /var/cvsroot/gentoo-x86/app-text/dictd/dictd-1.8.0.ebuild,v 1.1 2002/12/15 00:54:33 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Dictionary Client/Server for the DICT protocol"
+SRC_URI="ftp://ftp.dict.org/pub/dict/${P}.tar.gz"
+HOMEPAGE="http://www.dict.org"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+
+ econf \
+ --with-etcdir=/etc/dict
+ make || die
+}
+
+src_install () {
+ # gotta set up the dirs for it....
+ dodir /usr/bin
+ dodir /usr/sbin
+ dodir /usr/share/man/man1
+ dodir /usr/share/man/man8
+
+ # Now install it.
+ make \
+ prefix=${D}/usr \
+ man1_prefix=${D}/usr/share/man/man1 \
+ man8_prefix=${D}/usr/share/man/man8 \
+ conf=${D}/etc/dict \
+ install || die
+
+ # Install docs
+ dodoc README TODO COPYING ChangeLog ANNOUNCE
+ dodoc doc/dicf.ms doc/rfc.ms doc/rfc.sh doc/rfc2229.txt
+ dodoc doc/security.doc doc/toc.ms
+
+ # conf files.
+ dodir /etc/dict
+ insinto /etc/dict
+ doins ${FILESDIR}/${PVR}/dict.conf
+ doins ${FILESDIR}/${PVR}/dictd.conf
+ doins ${FILESDIR}/${PVR}/site.info
+
+ # startups for dictd
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/${PVR}/dictd dictd
+ insinto /etc/conf.d
+ newins ${FILESDIR}/${PVR}/dictd.confd dictd
+}
diff --git a/app-text/dictd/files/1.8.0/dict.conf b/app-text/dictd/files/1.8.0/dict.conf
new file mode 100644
index 000000000000..e06c3d296ec3
--- /dev/null
+++ b/app-text/dictd/files/1.8.0/dict.conf
@@ -0,0 +1,6 @@
+# This is the configuration file for dict.
+# Usually all you will ever need here is the server keywords.
+# Refer to the dict manpage for other options.
+# It will only check the second server if the first fails
+server localhost
+server dict.org
diff --git a/app-text/dictd/files/1.8.0/dictd b/app-text/dictd/files/1.8.0/dictd
new file mode 100644
index 000000000000..5aef8b767901
--- /dev/null
+++ b/app-text/dictd/files/1.8.0/dictd
@@ -0,0 +1,72 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-text/dictd/files/1.8.0/dictd,v 1.1 2002/12/15 00:54:33 seemant Exp $
+
+# NB: Config is in /etc/conf.d/dictd
+
+
+prepconfig() {
+ if [ ! -e ${DICTDCONF} ]
+ then
+ eerror "dictd not started. Config file not found."
+ return 1
+ fi
+ # if no dictionaries, skip startup.
+
+ # The new way of doing this is to scan /usr/lib/dict and tweek the conf
+ einfo "Scanning for dictionaries..."
+ if [ ! -d "${DLIBDIR}" ]; then
+ eerror "${DLIBDIR} doesn't exist, no dictionaries found."
+ return 1
+ fi
+ pushd ${DLIBDIR} >/dev/null
+ INDEXFILES=`ls *.index`
+ if [ -z "$INDEXFILES" ]; then
+ eerror "No dictionaries installed."
+ return 1
+ fi
+
+ cat $DICTDCONF | sed -e '/^#LASTLINE/,$d' > $TMPCONF
+ echo "#LASTLINE" >> $TMPCONF
+
+ CNT=0
+ for i in $INDEXFILES
+ do
+ DNAME=`echo $i | awk -F . '{print $1;}'`
+ #two possible names for a matching dictionary, check which is there.
+ if [ -f ${DNAME}.dict.dz ]; then
+ DICT=${DNAME}.dict.dz
+ elif [ -f ${DNAME}.dict ];then
+ DICT=${DNAME}.dict
+ else
+ einfo "Index $i has no matching dictionaray..."
+ fi
+
+ #ok, go an index, and a dixtionary, append.
+ echo "database $DNAME { data \"${DLIBDIR}/${DICT}\"" >> $TMPCONF
+ echo " index \"${DLIBDIR}/$i\" }" >> $TMPCONF
+
+ CNT=`expr $CNT + 1`
+ done
+ popd >/dev/null
+ mv ${TMPCONF} ${DICTDCONF}
+ einfo "Done, $CNT dictionary indexes found."
+}
+
+depend() {
+ need localmount
+}
+
+start() {
+ ebegin "Starting dictd"
+ prepconfig || return 1
+ start-stop-daemon --start --quiet --exec /usr/sbin/dictd -- $EARGS
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping dictd"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/dictd
+ eend $?
+}
diff --git a/app-text/dictd/files/1.8.0/dictd.conf b/app-text/dictd/files/1.8.0/dictd.conf
new file mode 100644
index 000000000000..4cded974f973
--- /dev/null
+++ b/app-text/dictd/files/1.8.0/dictd.conf
@@ -0,0 +1,22 @@
+# dictd configuration file.
+# whipped up by michael conrad tilstra <michael@gentoo.org>
+
+# Informational message
+site site.info
+
+# who's allowed. You might want to change this.
+access {
+ allow *
+}
+
+# Dictionaries are listed below.
+# The initrc script scans /usr/lib/dict and adds all of the dictionaries
+# it finds here.
+#
+# The initrc script will delete everything after the the last line and
+# replace it with what it finds. So add all of your things above.
+#
+# If this is a problem for people, contact me and
+# we can work out a different method.
+#
+#LASTLINE
diff --git a/app-text/dictd/files/1.8.0/dictd.confd b/app-text/dictd/files/1.8.0/dictd.confd
new file mode 100644
index 000000000000..91b9d43884bc
--- /dev/null
+++ b/app-text/dictd/files/1.8.0/dictd.confd
@@ -0,0 +1,7 @@
+# Config file for /etc/init.d/dictd
+
+EARGS="-s "
+DICTDCONF=/etc/dict/dictd.conf
+DLIBDIR=/usr/lib/dict
+TMPCONF=/etc/dict/dictd.conf.$$
+
diff --git a/app-text/dictd/files/1.8.0/site.info b/app-text/dictd/files/1.8.0/site.info
new file mode 100644
index 000000000000..23bfdeb61102
--- /dev/null
+++ b/app-text/dictd/files/1.8.0/site.info
@@ -0,0 +1,6 @@
+Welcome to your dictionary server dictd!
+
+This is an example site information file. It should contain information
+about any restricted databases and how users can obtain access. If may
+also contain other random data as you see fit.
+
diff --git a/app-text/dictd/files/digest-dictd-1.8.0 b/app-text/dictd/files/digest-dictd-1.8.0
new file mode 100644
index 000000000000..42c664aed390
--- /dev/null
+++ b/app-text/dictd/files/digest-dictd-1.8.0
@@ -0,0 +1 @@
+MD5 ce54a5ea05429954e2f743ee0fa661b5 dictd-1.8.0.tar.gz 574796