summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-11-29 04:12:46 +0000
committerMike Frysinger <vapier@gentoo.org>2005-11-29 04:12:46 +0000
commit5cbacad0f52586fe9ab4ddc6051d6c56bc4f9ebf (patch)
treeb0652705a958f9eafd4e093e3bbcb26ee0bbd65d /app-shells
parentmanifest rebuild (diff)
downloadgentoo-2-5cbacad0f52586fe9ab4ddc6051d6c56bc4f9ebf.tar.gz
gentoo-2-5cbacad0f52586fe9ab4ddc6051d6c56bc4f9ebf.tar.bz2
gentoo-2-5cbacad0f52586fe9ab4ddc6051d6c56bc4f9ebf.zip
old
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/bash-2.05b-r9.ebuild121
-rw-r--r--app-shells/bash/files/bash30-01432
-rw-r--r--app-shells/bash/files/digest-bash-2.05b-r98
3 files changed, 0 insertions, 161 deletions
diff --git a/app-shells/bash/bash-2.05b-r9.ebuild b/app-shells/bash/bash-2.05b-r9.ebuild
deleted file mode 100644
index ef6b3c1249bf..000000000000
--- a/app-shells/bash/bash-2.05b-r9.ebuild
+++ /dev/null
@@ -1,121 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-2.05b-r9.ebuild,v 1.29 2005/05/03 02:53:27 vapier Exp $
-
-inherit eutils flag-o-matic toolchain-funcs
-
-# Official patches
-PLEVEL="x002 x003 x004 x005 x006 x007"
-
-DESCRIPTION="The standard GNU Bourne again shell"
-HOMEPAGE="http://cnswww.cns.cwru.edu/~chet/bash/bashtop.html"
-SRC_URI="mirror://gnu/bash/${P}.tar.gz
- mirror://gentoo/${P}-gentoo.diff.bz2
- ${PLEVEL//x/mirror://gnu/bash/bash-${PV}-patches/bash${PV/\.}-}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
-IUSE="nls build minimal"
-
-# we link statically with ncurses
-DEPEND=">=sys-libs/ncurses-5.2-r2"
-RDEPEND=""
-
-src_unpack() {
- unpack ${P}.tar.gz
-
- cd ${S}
- epatch ${DISTDIR}/${P}-gentoo.diff.bz2
-
- for x in ${PLEVEL//x}
- do
- epatch ${DISTDIR}/${PN}${PV/\.}-${x}
- done
-
- # Remove autoconf dependency
- sed -i -e "/&& autoconf/d" Makefile.in
-
- # Readline is slow with multibyte locale, bug #19762
- epatch ${FILESDIR}/${P}-multibyte-locale.patch
- # Segfault on empty herestring
- epatch ${FILESDIR}/${P}-empty-herestring.patch
- # Fix broken rbash functionality
- epatch ${FILESDIR}/${P}-rbash.patch
- # Fix parallel make, bug #41002.
- epatch ${FILESDIR}/${P}-parallel-build.patch
- # Fix using bash with post-20040808 glibc ebuilds (from fedora)
- epatch ${FILESDIR}/${P}-jobs.patch
-
- # Enable SSH_SOURCE_BASHRC (#24762)
- sed -e 's:^.*\(#define SSH_SOURCE_BASHRC\).*$:\1:' \
- -i config-top.h
-
- # Force pgrp synchronization
- # (https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=81653)
- #
- # The session will hang cases where you 'su' (not 'su -') and
- # then run a piped command in emacs.
- # This problem seem to happen due to scheduler changes kernel
- # side - although reproduceble with later 2.4 kernels, it is
- # especially easy with 2.6 kernels.
- echo '#define PGRP_PIPE 1' >> config-bot.h
-
- sed -i 's:-lcurses:-lncurses:' configure || die "sed configure"
-}
-
-src_compile() {
- filter-flags -malign-double
-
- local myconf=
-
- # Always use the buildin readline, else if we update readline
- # bash gets borked as readline is usually not binary compadible
- # between minor versions.
- #
- # Martin Schlemmer <azarah@gentoo.org> (1 Sep 2002)
- #use readline && myconf="--with-installed-readline"
-
- # Don't even think about building this statically without
- # reading Bug 7714 first. If you still build it statically,
- # don't come crying to use with bugs ;).
- #use static && export LDFLAGS="${LDFLAGS} -static"
- use nls || myconf="${myconf} --disable-nls"
-
- echo 'int main(){}' > ${T}/term-test.c
- if ! $(tc-getCC) -static -lncurses ${T}/term-test.c 2> /dev/null ; then
- export bash_cv_termcap_lib=gnutermcap
- else
- export bash_cv_termcap_lib=libcurses
- myconf="${myconf} --with-ncurses"
- fi
-
- econf \
- --disable-profiling \
- --without-gnu-malloc \
- ${myconf} || die
- # Make sure we always link statically with ncurses
- sed -i "/^TERMCAP_LIB/s:-lncurses:-Wl,-Bstatic -lncurses -Wl,-Bdynamic:" Makefile || die "sed failed"
- emake || die "make failed"
-}
-
-src_install() {
- einstall || die
-
- dodir /bin
- mv ${D}/usr/bin/bash ${D}/bin
- dosym bash /bin/sh
- dosym bash /bin/rbash
-
- use minimal && rm -f ${D}/usr/bin/bashbug ${D}/usr/share/man*/bashbug*
-
- use build \
- && rm -rf ${D}/usr \
- || ( \
- doman doc/*.1
- dodoc README NEWS AUTHORS CHANGES COMPAT Y2K
- dodoc doc/FAQ doc/INTRO
-
- dosym bash.info.gz /usr/share/info/bashref.info.gz
- )
-}
diff --git a/app-shells/bash/files/bash30-014 b/app-shells/bash/files/bash30-014
deleted file mode 100644
index 58c69c41d815..000000000000
--- a/app-shells/bash/files/bash30-014
+++ /dev/null
@@ -1,32 +0,0 @@
-> Machine Type: i686-pc-linux-gnu
->
-> Bash Version: 3.0
-> Patch Level: 13
-> Release Status: release
->
-> Description:
-> Brace expansion is broken in some cases when it follows quoted
-> text.
-
-*** ../bash-3.0-patched/braces.c Wed Sep 8 11:07:53 2004
---- braces.c Fri Sep 17 18:42:36 2004
-***************
-*** 403,407 ****
- pass_next = 1;
- i++;
-! level++;
- continue;
- }
---- 403,408 ----
- pass_next = 1;
- i++;
-! if (quoted == 0)
-! level++;
- continue;
- }
-
---
-``The lyf so short, the craft so long to lerne.'' - Chaucer
-( ``Discere est Dolere'' -- chet )
- Live...Laugh...Love
-Chet Ramey, ITS, CWRU chet@po.cwru.edu http://tiswww.tis.cwru.edu/~chet/
diff --git a/app-shells/bash/files/digest-bash-2.05b-r9 b/app-shells/bash/files/digest-bash-2.05b-r9
deleted file mode 100644
index cda4481c8b5e..000000000000
--- a/app-shells/bash/files/digest-bash-2.05b-r9
+++ /dev/null
@@ -1,8 +0,0 @@
-MD5 5238251b4926d778dfe162f6ce729733 bash-2.05b.tar.gz 1956216
-MD5 acac0949285525a5920d80f2aa4668de bash-2.05b-gentoo.diff.bz2 2744
-MD5 2957bbe5f6db1830d649d1071baba63c bash205b-002 755
-MD5 2828e78563927b806246e2b4806ee0f5 bash205b-003 2356
-MD5 6bf89831209ba6d208943d2ebaa7fe3a bash205b-004 1110
-MD5 311b7f0e3dabec51767bfabe6afd4ded bash205b-005 2217
-MD5 f8a86d0a66b51080f3fbc5cc34ef1a06 bash205b-006 3155
-MD5 37d2acecc9146883f9b331c03b274f21 bash205b-007 1072