summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-06-26 16:52:05 +0000
committerRoy Marples <uberlord@gentoo.org>2007-06-26 16:52:05 +0000
commit41e04127579cb719cc444b19fb87f090909d85c0 (patch)
tree4557a6aaa30261b83b8d96777a42eb268f327ea1 /app-shells
parent- version bump. bug #179762 thanks PaX Team (diff)
downloadgentoo-2-41e04127579cb719cc444b19fb87f090909d85c0.tar.gz
gentoo-2-41e04127579cb719cc444b19fb87f090909d85c0.tar.bz2
gentoo-2-41e04127579cb719cc444b19fb87f090909d85c0.zip
Use new debian patchset.
Add patch from Harald van Dijk to fix reading certain line lengths. (Portage version: 2.1.3_rc5)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/dash/ChangeLog9
-rw-r--r--app-shells/dash/dash-0.5.3.8.ebuild64
-rw-r--r--app-shells/dash/files/dash-0.5.3-read-length.patch13
-rw-r--r--app-shells/dash/files/digest-dash-0.5.3.86
4 files changed, 91 insertions, 1 deletions
diff --git a/app-shells/dash/ChangeLog b/app-shells/dash/ChangeLog
index 8afe7136fd3f..f75afc9eba6e 100644
--- a/app-shells/dash/ChangeLog
+++ b/app-shells/dash/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-shells/dash
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/ChangeLog,v 1.42 2007/05/19 09:31:44 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/ChangeLog,v 1.43 2007/06/26 16:52:05 uberlord Exp $
+
+*dash-0.5.3.8 (26 Jun 2007)
+
+ 26 Jun 2007; Roy Marples <uberlord@gentoo.org>
+ +files/dash-0.5.3-read-length.patch, +dash-0.5.3.8.ebuild:
+ Use new debian patchset.
+ Add patch from Harald van Dijk to fix reading certain line lengths.
*dash-0.5.3.7-r1 (19 May 2007)
diff --git a/app-shells/dash/dash-0.5.3.8.ebuild b/app-shells/dash/dash-0.5.3.8.ebuild
new file mode 100644
index 000000000000..370b0941fd31
--- /dev/null
+++ b/app-shells/dash/dash-0.5.3.8.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/dash-0.5.3.8.ebuild,v 1.1 2007/06/26 16:52:05 uberlord Exp $
+
+inherit autotools eutils flag-o-matic toolchain-funcs
+
+DEB_PV=${PV%.*}
+DEB_PATCH=${PV##*.}
+DEB_PF="${PN}_${DEB_PV}-${DEB_PATCH}"
+MY_P="${PN}-${DEB_PV}"
+
+DESCRIPTION="DASH is a direct descendant of the NetBSD version of ash (the
+Almquist SHell) and is POSIX compliant"
+HOMEPAGE="http://gondor.apana.org.au/~herbert/dash/"
+SRC_URI="http://gondor.apana.org.au/~herbert/dash/files/${PN}-${DEB_PV}.tar.gz
+ mirror://debian/pool/main/d/dash/${DEB_PF}.diff.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="libedit static"
+
+DEPEND="libedit? ( dev-libs/libedit )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+
+ epatch "${WORKDIR}/${DEB_PF}".diff
+
+ cd "${S}"
+ epatch debian/diff/*
+
+ # Fix reading of long lines
+ epatch "${FILESDIR}/${MY_P}"-read-length.patch
+
+ # Always statically link libedit in to ensure we always boot if it changes
+ # which it has done in the past.
+ local s="s/-ledit/-Wl,-Bstatic -ledit -Wl,-Bdynamic -lcurses/g"
+ use static && s="s/-ledit/-ledit -lcurses/g"
+ sed -i -e "${s}" configure.ac || die "Failed to sed configure.ac"
+
+ # May as well, as the debian patches force this anyway
+ eautoreconf
+}
+
+src_compile() {
+ local myconf=
+
+ use static && append-ldflags -static
+ use libedit && myconf="${myconf} --with-libedit"
+ export CC="$(tc-getCC)"
+
+ econf ${myconf} || die "econf failed"
+ emake CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ exeinto /bin
+ newexe src/dash dash
+ newman src/dash.1 dash.1
+ dodoc COPYING ChangeLog
+}
diff --git a/app-shells/dash/files/dash-0.5.3-read-length.patch b/app-shells/dash/files/dash-0.5.3-read-length.patch
new file mode 100644
index 000000000000..07bf834d37d2
--- /dev/null
+++ b/app-shells/dash/files/dash-0.5.3-read-length.patch
@@ -0,0 +1,13 @@
+--- src/expand.c
++++ src/expand.c
+@@ -1643,7 +1643,10 @@
+ size_t fulllen = len + strlen(p) + 1;
+
+ if (flag & RMESCAPE_GROW) {
++ int strloc = str - (char *)stackblock();
+ r = makestrspace(fulllen, expdest);
++ str = (char *)stackblock() + strloc;
++ p = str + len;
+ } else if (flag & RMESCAPE_HEAP) {
+ r = ckmalloc(fulllen);
+ } else {
diff --git a/app-shells/dash/files/digest-dash-0.5.3.8 b/app-shells/dash/files/digest-dash-0.5.3.8
new file mode 100644
index 000000000000..1850f55b5deb
--- /dev/null
+++ b/app-shells/dash/files/digest-dash-0.5.3.8
@@ -0,0 +1,6 @@
+MD5 1a3cd6669459be4344ec55ec9d4914f8 dash-0.5.3.tar.gz 207201
+RMD160 fd445535708868fe206852320eece58c3c2bbbaf dash-0.5.3.tar.gz 207201
+SHA256 82aab2ff63e5fac4bff35c91222f735ec67551db86b5c3b3455ecc10e8889e53 dash-0.5.3.tar.gz 207201
+MD5 3337f54d71d5a1d8b46f3d2e5ca5e5b1 dash_0.5.3-8.diff.gz 65454
+RMD160 30cf2615e88ab885c4e0c1a8644b87b07fdda52d dash_0.5.3-8.diff.gz 65454
+SHA256 f9a785c7bb72deaa24eb81a918e3c85d3062121ad06874b501ba330e5c53d80a dash_0.5.3-8.diff.gz 65454