summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2003-12-02 22:30:46 +0000
committerTavis Ormandy <taviso@gentoo.org>2003-12-02 22:30:46 +0000
commit87f88c162c545661a26aa1efc890154d60acf426 (patch)
tree50651860b4d1ac7f944f8bd54dda0ecd5b0cbc3a /app-shells/csh
parentChangeLog neatified a little... (diff)
downloadgentoo-2-87f88c162c545661a26aa1efc890154d60acf426.tar.gz
gentoo-2-87f88c162c545661a26aa1efc890154d60acf426.tar.bz2
gentoo-2-87f88c162c545661a26aa1efc890154d60acf426.zip
syntax change
Diffstat (limited to 'app-shells/csh')
-rw-r--r--app-shells/csh/ChangeLog5
-rw-r--r--app-shells/csh/Manifest4
-rw-r--r--app-shells/csh/csh-1.29-r2.ebuild10
3 files changed, 11 insertions, 8 deletions
diff --git a/app-shells/csh/ChangeLog b/app-shells/csh/ChangeLog
index 31fc9c612a51..22aeba6d7927 100644
--- a/app-shells/csh/ChangeLog
+++ b/app-shells/csh/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-shells/csh
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/csh/ChangeLog,v 1.12 2003/11/17 11:45:30 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/csh/ChangeLog,v 1.13 2003/12/02 22:29:13 taviso Exp $
+
+ 02 Dec 2003; Tavis Ormandy <taviso@gentoo.org> csh-1.29-r2.ebuild:
+ no need to append-flags one at a time, minor syntax change.
17 Nov 2003; Tavis Ormandy <taviso@gentoo.org> csh-1.29-r2.ebuild:
"William Joy" => "Bill Joy", I think most people would recognise the
diff --git a/app-shells/csh/Manifest b/app-shells/csh/Manifest
index 49cccf927e29..035dd724622b 100644
--- a/app-shells/csh/Manifest
+++ b/app-shells/csh/Manifest
@@ -1,5 +1,5 @@
-MD5 1bfae74bd44195babcaebb0c999bbdb0 csh-1.29-r2.ebuild 4261
-MD5 89eeaaa3b8c55b9cc46aa073edd74399 ChangeLog 2398
+MD5 8ec12d50cd9fe5da54d64cd1fb488a6a csh-1.29-r2.ebuild 4262
+MD5 943b7c33b625a5e2bd2d0a1444ab2969 ChangeLog 2530
MD5 ce0694a6af9197d929533e9d0dfcb706 metadata.xml 706
MD5 49c0a95e6881eb7e2932d149f62f0de2 files/mksignames.c 10722
MD5 213922a7d6fdee0a89e9a349653be22d files/linux-vs-bsd.diff 7483
diff --git a/app-shells/csh/csh-1.29-r2.ebuild b/app-shells/csh/csh-1.29-r2.ebuild
index d70e7e5423ea..b6f6768b806c 100644
--- a/app-shells/csh/csh-1.29-r2.ebuild
+++ b/app-shells/csh/csh-1.29-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/csh/csh-1.29-r2.ebuild,v 1.5 2003/11/17 11:45:30 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/csh/csh-1.29-r2.ebuild,v 1.6 2003/12/02 22:29:13 taviso Exp $
inherit flag-o-matic eutils ccc
@@ -74,11 +74,11 @@ src_unpack() {
src_compile() {
einfo "Adding flags required for succesful compilation..."
+
# this should be easier than maintaining a patch.
- for i in {-Dlint,-w,-D__dead="",-D__LIBC12_SOURCE__,-DNODEV="-1",-DTTYHOG=1024,-DMAXPATHLEN=4096,-D_GNU_SOURCE,-D_DIAGASSERT="assert"}
- do
- append-flags ${i}
- done
+ append-flags -Dlint -w -D__dead="" -D__LIBC12_SOURCE__ -DNODEV="-1"
+ append-flags -DTTYHOG=1024 -DMAXPATHLEN=4096 -D_GNU_SOURCE
+ append-flags -D_DIAGASSERT="assert"
# maybe they dont warn on BSD, but _damn_.
export NOGCCERROR=1