summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-08-19 15:09:21 +0000
committerDan Armak <danarmak@gentoo.org>2002-08-19 15:09:21 +0000
commit8c43e1f4b9cc15490447113850194ebb9cf13c60 (patch)
tree2d6d25ecf75da9b79aa0f5c8d78a8b9378839f1e /app-sci/qcad
parentdep changes for gtop (diff)
downloadgentoo-2-8c43e1f4b9cc15490447113850194ebb9cf13c60.tar.gz
gentoo-2-8c43e1f4b9cc15490447113850194ebb9cf13c60.tar.bz2
gentoo-2-8c43e1f4b9cc15490447113850194ebb9cf13c60.zip
new qt3 version
Diffstat (limited to 'app-sci/qcad')
-rw-r--r--app-sci/qcad/ChangeLog10
-rw-r--r--app-sci/qcad/files/digest-qcad-1.5.11
-rw-r--r--app-sci/qcad/qcad-1.5.1.ebuild37
3 files changed, 46 insertions, 2 deletions
diff --git a/app-sci/qcad/ChangeLog b/app-sci/qcad/ChangeLog
index 10db8e1ab7cb..4ef3b336a064 100644
--- a/app-sci/qcad/ChangeLog
+++ b/app-sci/qcad/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-sci/qcad
-# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-sci/qcad/ChangeLog,v 1.1 2002/05/02 00:03:52 seemant Exp $
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/qcad/ChangeLog,v 1.2 2002/08/19 15:09:21 danarmak Exp $
+
+*qcad-1.5.1 (19 Aug 2002)
+
+ 19 Aug 2002; Dan Armak <danarmak@gentoo.org> ChangeLog :
+
+ New (QT3) version. Closes #6335.
*qcad-1.4.7 (1 May 2002)
diff --git a/app-sci/qcad/files/digest-qcad-1.5.1 b/app-sci/qcad/files/digest-qcad-1.5.1
new file mode 100644
index 000000000000..0be2369f834e
--- /dev/null
+++ b/app-sci/qcad/files/digest-qcad-1.5.1
@@ -0,0 +1 @@
+MD5 bb4b6e2f6a211a27c0588895e7446e09 qcad-1.5.1-src.tar.gz 2793608
diff --git a/app-sci/qcad/qcad-1.5.1.ebuild b/app-sci/qcad/qcad-1.5.1.ebuild
new file mode 100644
index 000000000000..d74018a7a2ad
--- /dev/null
+++ b/app-sci/qcad/qcad-1.5.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-sci/qcad/qcad-1.5.1.ebuild,v 1.1 2002/08/19 15:09:21 danarmak Exp $
+
+MY_P=${P}-src
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="A 2D CAD package based upon Qt."
+SRC_URI="mirror://sourceforge/qcad//${MY_P}.tar.gz"
+HOMEPAGE="http://www.qcad.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND=">=x11-libs/qt-3"
+
+src_compile() {
+ export QTDIR=/usr/qt/3
+ cd ${S}
+ emake CXXFLAGS="$CXXFLAGS" || die
+}
+
+src_install () {
+ dobin qcad
+
+ dohtml -r doc
+
+ dodoc AUTHORS COPYING INSTALL MANIFEST README TODO changes-*
+ docinto examples
+ dodoc examples/*
+
+ dodir /usr/share/${PN}
+ cp -a fonts hatches libraries messages templates ${D}/usr/share/${PN}
+
+ insinto /usr/share/${PN}/pixmaps
+ doins xpm/*
+}