summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2004-12-28 14:46:59 +0000
committerOlivier Fisette <ribosome@gentoo.org>2004-12-28 14:46:59 +0000
commit224b36e81e728611ec5101296822942b1c094287 (patch)
tree708016aab84e5b2e5aae37f4c59da80f687590ab /app-sci/octave/octave-2.1.50.ebuild
parentMoved from app-sci/num-utils to sci-mathematics/num-utils (diff)
downloadgentoo-2-224b36e81e728611ec5101296822942b1c094287.tar.gz
gentoo-2-224b36e81e728611ec5101296822942b1c094287.tar.bz2
gentoo-2-224b36e81e728611ec5101296822942b1c094287.zip
Moving to sci-mathematics/octave
Diffstat (limited to 'app-sci/octave/octave-2.1.50.ebuild')
-rw-r--r--app-sci/octave/octave-2.1.50.ebuild83
1 files changed, 0 insertions, 83 deletions
diff --git a/app-sci/octave/octave-2.1.50.ebuild b/app-sci/octave/octave-2.1.50.ebuild
deleted file mode 100644
index 2da4111f6a4f..000000000000
--- a/app-sci/octave/octave-2.1.50.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/octave-2.1.50.ebuild,v 1.7 2004/11/30 15:02:53 phosphan Exp $
-
-inherit flag-o-matic
-
-DESCRIPTION="GNU Octave is a high-level language (MatLab compatible) intended for numerical computations"
-HOMEPAGE="http://www.octave.org/"
-SRC_URI="ftp://ftp.octave.org/pub/octave/bleeding-edge/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 ~ppc ~alpha ~sparc amd64"
-IUSE="static readline zlib tetex hdf5 mpi"
-
-DEPEND="virtual/libc
- >=sys-libs/ncurses-5.2-r3
- >=media-gfx/gnuplot-3.7.1-r3
- >=dev-libs/fftw-2.1.3
- >=dev-util/gperf-2.7.2
- zlib? ( sys-libs/zlib )
- hdf5? ( dev-libs/hdf5 )
- tetex? ( virtual/tetex )"
-
-# NOTE: octave supports blas/lapack from intel but this is not open
-# source nor is it free (as in beer OR speech) Check out...
-# http://developer.intel.com/software/products/mkl/mkl52/index.htm for
-# more information
-
-pkg_setup() {
- use ifc || if [ -z `which g77` ]; then
- #if ifc is defined then the dep was already checked
- eerror "No fortran compiler found on the system!"
- eerror "Please add f77 to your USE flags and reemerge gcc!"
- die
- fi
-}
-
-src_compile() {
- filter-flags -ffast-math
-
- local myconf
-
- use static || myconf="--disable-static --enable-shared --enable-dl"
- use readline || myconf="${myconf} --disable-readline"
- use hdf5 || myconf="${myconf} --without-hdf5"
- use mpi || myconf="${myconf} --without-mpi"
-
- # NOTE: This version actually works with gcc-3.x
- ./configure ${myconf} --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var/state/octave \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- --host=${CHOST} \
- --build=${CHOST} \
- --target=${CHOST} \
- --enable-rpath \
- --enable-lite-kernel \
- LDFLAGS=-lz || die "configure failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- make \
- prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- install || die "make install failed"
- use tetex && octave-install-doc
-}
-
-octave-install-doc() {
- echo "Installing documentation..."
- insinto /usr/share/doc/${PF}
- doins doc/faq/Octave-FAQ.dvi
- doins doc/interpreter/octave.dvi
- doins doc/liboctave/liboctave.dvi
- doins doc/refcard/refcard-a4.dvi
- doins doc/refcard/refcard-legal.dvi
- doins doc/refcard/refcard-letter.dvi
-}